1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support K9 mail - syncing disabled


  1. EveR-1

    EveR-1 Member

    Hi

    I've installed K9 on my SG2, and it seems to be working OK. However, the message bar in my Inbox tells me that syncing is disabled.

    What does this mean? How do I switch it so that syncing is enabled and/or how do I get rid of this message?

    Thanks

    Advertisement
  2. koahhe

    koahhe Member

    You need to go to settings>accounys and sync>tick the first 2 options
    EveR-1 likes this.
  3. EveR-1

    EveR-1 Member

    Hi,

    Thanks - I have these 2 options ticked already and it's still showing as syncing disabled.
  4. Thunder22

    Thunder22 Well-Known Member

    You probably created the account over wifi.

    Delete the account and recreate it with wifi off, i.e. use 3G/4G.

    I was getting the same problem, and doing this fixed it.
    EveR-1 likes this.
  5. EveR-1

    EveR-1 Member



    Thanks!

    That seems to have fixed it. I'd never have thought of doing that. I keep having problems with K9; this is it's last go before I ditch it for good.

    One more thing though! Is K9 'push' mail (in the same way that the stock email app seems to be)?

    In other words - how do I set up K9 mail so that I get email delivered as soon as it's sent? At the moment, I seem to have to click on 'check mail'.

    Thanks for any further help.
  6. EveR-1

    EveR-1 Member

    Actually - this has only partially solved the problem.

    If I try to send via 3G (with wi-fi disabled) then I can't send mail - and get a message saying SMTP response is 0 length.

    Any ideas?
  7. danu_l

    danu_l New Member

    hello i have a solution for k-9 mail it work for me in my htc desire phone

    you need to go in setings - account settings--fetching mail - and choose time frequency in folder pool frequency
    that is all
    i hope that will work
  8. EveR-1

    EveR-1 Member

    Thanks - this is an answer to receiving email? EDIT - So, I can set it to check every minute. Is there any way to set it up as 'push'? I'm using a POP3 account.

    However, I still have the SMTP is 0 length. Any ideas, anyone?

    EDIT - this means I'm able to receive email but not send.

    The stock email app works fine btw!!
  9. stevehy

    stevehy Well-Known Member

    POP mail does NOT push, only IMAP that honors the IDLE command.

    Regarding your other problems with K9, I would uninstall the app (clearing data first) and then reinstall and set it up, allowing K9 to automatically configure.
  10. EveR-1

    EveR-1 Member

    Thanks - however, I did let K9 auto configure and it got it wrong. I had to correct it manually and have never got past this smtp error message whilst trying to send email on mobile signal.

    I've uninstalled/reinstalled about 4 times now. Will probably forget about using k9 as it doesn't seem worth all the hassle!

    I still don't know what the smtp error message means. Anyone?
  11. Bioman

    Bioman New Member

    First of all, if your syncing is disabled it means that you will not receive any new email unless you manually check your account. So in order to change this setting easily without reinstalling the app or whatever has been suggested just follow the following steps:

    To set up Syncing 02/26/2012
    1. make sure you have an account set up and syncing and that you start this tutorial from within the "inbox" of your account.

    2. Tap or Push the "settings" hard/soft key on your Android phone. Please refer to your phone's manufactures instructions for further info about this button.

    3. on the popup menu tap on the "More" button. A new menu will pop up.

    4. Tap "Accounts" from the menu.

    5. Now this may sound redundant, but you will need to push/tap on the "settings" hard/soft key at the bottom of the phone screen again, a list of options will pop up at the bottom the screen.

    6. , Tap on the "More" button, a menu with two selections should appear.

    7. Tap on the "Settings" button from the menu, a new menu will appear.

    8. Tap the "Network" button from within the menu.

    9. Tap on the "Background sync" button, a list of options will appear.

    10. Tap "Always" from the list of options. Exit the menu by the "back" button hard/soft key.
    Congrats, you have now set up syncing on your k9 email!

    To Set up Push syncing
    02/26/2012
    1. Make sure you start this tutorial from within the "inbox" of your account.

    2.Press or tap the "Settings" hard/soft key on the bottom of your phone screen. Several options will appear on the screen.

    3. Tap the "More" button within the options. A list of options will pop up.

    4. Tap the "Settings" button from within the list, a popup will appear.

    5. Tap the "Account settings" button from the list, a menu will appear.

    6. Tap the "Fetching mail" button from the menu, a sub menu will appear.

    7. Tap the "Folder poll frequency" button from within the menu, a popup will appear.

    8. Tap which ever selection suits your needs for syncing with your account, then press the back button twice to exit the menus.
    Congrats, you've set up push syncing!

    This ends my tutorial on setting up syncing and custom push syncing on your k9 email app!
  12. CharlieMac1

    CharlieMac1 New Member

    I have the same problem on my galaxy s11 have tried all of the suggestions syncing is still disabled
    Any more ideas?
  13. UFlippinIdiot

    UFlippinIdiot New Member

    Press Menu, more, settings, global settings, network and change background sync to always
    CharlieMac1 likes this.
  14. barberboy

    barberboy Well-Known Member

    I did everything in the instructions, went well only thing is friendcaster is NOT sending my notifications any help?????
  15. VTENGR

    VTENGR Well-Known Member

    So K9 doesn't truely "PUSH" the exchange email if you have to set it to poll every minute or hour or whatever.
  16. Jim 1

    Jim 1 New Member


    Thanks!!!
    I can't tell you how many times I have uninstalled k9 because I couldn't get it to work right.

    You are my newest hero = ))
  17. wcollinge

    wcollinge New Member

    I did all the above and it still said "syncing disabled" at the top menu bar. But then I thought, why not power off completely and then back on... sometimes that is necessary to reset things. I did and it finally worked, now it says at the top "Next poll @..." (time). So, power down and back on is the final step to activate the polling schedule.
  18. tirins

    tirins New Member

    together with restart of my Galaxy S2 it fixed the no sync problem! Many thanks for your post!
  19. ho33bi

    ho33bi New Member

    Excellent reply. Simple and works. Thanks
  20. libdancer99

    libdancer99 New Member

    This worked for my Transformer Prime, 4.03
  21. robrilla

    robrilla New Member

    This worked for me on my Evo Lte (Jewel) with CM10.

    Thank you,
    -Rob

Share This Page