1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Mass Storage mode not workingSupport


  1. Deke60

    Deke60 Member

    Greets all,

    Got the OE a few hours ago. Since then, using many different cables plus new cable in box, I haven't been able to get the mass storage mode to work. No disk icon for the device.

    Have Enabled Mass Storage in Connectivity. No luck.

    Dead USB port? Or user error somewhere?

    I can browse the device via Bluetooth FWIW.

    Thanks for any help/tips/suggestions. :)

    Advertisement
    :
  2. Prinny

    Prinny Resident Linux Nutcase Guide

    Stupid question but do you have an SD card? And what OS? Other computers work or no?
  3. axelxbc

    axelxbc Well-Known Member

    There is a huge glitch with windows XP service pack 1 and 2 with devices that are set up like the OE. And even more so with the windows 7 starter edition that is included with older net books. What operating system you running?
  4. Deke60

    Deke60 Member

    Yep. Put my OV 16GB card in. OS X Lion on the iMac. It is detected on Windows Vista as an Optimus Elite, but the removable drives E: and F: don't display any data.

    Does it mount or display on your computer?
  5. elgecko

    elgecko Well-Known Member

  6. Deke60

    Deke60 Member

    Got it working. Had to turn on USB Debugging. Don't remember having to do that for the OV.

    Thanks for the ideas/suggestions.
  7. Prinny

    Prinny Resident Linux Nutcase Guide

    That's...odd...but glad you got it!
  8. peeciigais

    peeciigais Member

    Hey, so I bought new Android phone, works good. But it got some issues as well. Now, I'm trying to connect phone to my PC, but I can't enable mass storage mode. Phone shows I have to enable it, but the selection is inactive. Tried turn USB debugging on/off, doesn't changes anything. Running Windows 7, Android system is 2.3.9. When I tried it first time, it worked perfectly, but not anymore. Can someone help me?

    Thanks, Pete.
    Sorry for my English.
  9. Murf1

    Murf1 Well-Known Member

    Being they both worked once, Have you tried rebooting your phone and PC and then tried again?

    Also before you yank the cable from the PC, make sure you do a "Safely Remove Hardware" before disconnecting the cable.
  10. PilotBob

    PilotBob Well-Known Member

    When you connect the USB cable to your device and the PC you should see a a USB icon in the top left of your phone.

    If you slide down the notifications it will show

    USB connection... Does it say "charge only"? If so, tap on it and set it to "Mass Storage"... (this will also charge it).

    Also, on the bottom of that screen you can turn on "Always Ask" so every time you connect it will ask if you want to mount the device. Since I mostly only connect to charge I have mine set to "Charge Only" and always ask is off. I expect perhaps that is how yours is set.

    BOb
  11. peeciigais

    peeciigais Member

    My USB selection is inactive, the problem is I can't select any options for USB mode. Only option what can I select is "Remember my choice". Tried to reboot my pc and connect to another PC, can't even install a driver for MTK6515. Maybe that's the problem? If it is, how can I update a driver if there isn't one, or maybe I can't just find.
    Thanks for answers.
  12. PilotBob

    PilotBob Well-Known Member

    Strange... have you tried to shut off your phone, remove the battery for about 20 seconds, put it back in and then turn on the phone?
  13. peeciigais

    peeciigais Member

    Yes, tried even that. Doesn't work either.
    This is the list what I have tried:
    *Turn debugging on/off
    *Rebooting PC
    *Connect to another PC
    *Switched phone on/off (removed the battery as well)
    *Tried another USB cable
    *Trying all USB ports

    Got nothing wrong with PC, USB cable. So probably it is the phone. I just don't find any clue what could be wrong.
  14. Dark One

    Dark One Well-Known Member Contributor

    I had this problem on my Optimus V with stock and a stock based custom rom that I tried, but it worked with CM7. I have no idea why.
  15. Artine

    Artine Well-Known Member Contributor

    At this point I would be inclined to say it's a hardware defect. Virgin Mobile should be willing to replace it without hassle within the week (only took three days or so for my girlfriend to get a replacement). Or if you got it at BestBuy with their Geek Squad Protection Plan, just bring it in, explain the problem, and they should be able to hook you up with a replacement no problem within an hour's time or so.
    peeciigais likes this.
  16. peeciigais

    peeciigais Member

    Well, then I will have to face it for some time, because I bought it on eBay. At least phone is working well and for my first Android, I don't regret it. Thanks for info. I will wait for any solutions anyway.
  17. miediev

    miediev Well-Known Member

    You could always use bluetooth or wifi, or an sd card reader, there's also dropbox. I rarely bother to connect my phone to my computer, it's easier and faster for me to use any of the other methods.
  18. peeciigais

    peeciigais Member

    Can't use bluetooth function, but wifi sounds good. I'm using right now ES FTP app, but it doesn't function so well how it should i think. I downloaded CuteFTP, don't even know if it's good or not (haven't actually work with ftp for some time). Maybe you can share some good app or software to transfer from phone to pc and from pc to phone quickly. Cheers.
  19. peeciigais

    peeciigais Member

    Thanks, that was useful. I also find solution for my problem, not the best, but hadn't any choices anyway. :)
Loading...

Share This Page