Mass storage modeSupport


Last Updated:

  1. dw14

    dw14 Member

    When I plug my phone into any pc I don't get prompted to enable mass storage mode. This seems to work fine on my wives phone. We both have Nexus S's and were both running 2.3.2 but I manually upgraded to 2.3.3 hoping that would correct the issue but it didn't help.

    Any ideas?

    Advertisement
  2. B2L

    B2L Well-Known Member

    You know what's weird is i have this exact same problem. When i connect my fiancee' Nexus S it automatically prompts to turn on USB storage. But when i plug in my Nexus S is doesn't prompt me automatically and i manually have to do it. There has to be a setting to change this but i haven't found it. It did this to me on stock 2.3.2 and is still doing it on CM7 RC1.

    If anyone knows a fix to this i would love to find out.
  3. dw14

    dw14 Member

    how are you manually turning it on? I can't even get that to work.
  4. B2L

    B2L Well-Known Member

    Really? So it doesn't even show up in the notification bar when you plug it into the computer?

    If that's the case the only thing I can suggest is to download an app like file expert so you can transfer everything wirelessly over an http server.
  5. mikeymike1234

    mikeymike1234 New Member

    I had the same problem with my Nexus S and 1st Generation MacBook Air. I was using a generic USB cable. I just switched it out for the cable that came with the phone and now it is finally prompting me for mass storage mode.
  6. RadDroid1

    RadDroid1 New Member

    I had the same issue but found a workaround:

    go to "settings" --> "SD card & phone storage" --> then uncheck "mass storage only" then put the check back in. You should now get the option on your phone to "Turn on USB Storage" Hope that helps even tho its a little late :D

Share This Page