1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Mediaserver using batterySupport


Last Updated:

  1. trumpetdad

    trumpetdad New Member This Topic's Starter

    Joined:
    Sep 17, 2010
    Messages:
    1
    Likes Received:
    0
    I am running Kaosfroyo V38. I been running and upgrading since Version 34. I upgraded the Kernel after v38 was burning through the battery too fast. That worked fine. Now, I am noticing that the battery is not lasting as long as it use to again.

    I check the battery stats, now Mediaserver is the number one user of the battery. Much more than the display.

    Does anybody what would cause this? What apps use the mediaserver? I noticed on a previous thread somebody mentioned Pandora. My Pandora is not one of the apps running.

    Any Ideas?
     

    Advertisement
  2. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,575
    Likes Received:
    1,877
  3. xyvyx

    xyvyx New Member

    Joined:
    Nov 23, 2010
    Messages:
    3
    Likes Received:
    0
    I'd never seen this problem until today. One thing I just remembered was attempting to play a Youtube video linked from Facebook. On the 1st attempt, it threw some error message. I refreshed the video & started to play it... then backed-out a short time later.

    An hour or so later, I noticed my phone was getting both very laggy & hot... so in my case, it seemed to be a delayed effect on the mediaserver service/application. It might not have been related to Youtube at all, but I didn't play back any other media, photos or launch any other apps in that timeframe.
     
  4. MikeAusA

    MikeAusA Well-Known Member

    Joined:
    Jul 27, 2011
    Messages:
    45
    Likes Received:
    2
    In my Telstra Atrix running 2.2.2, I had been using Repeater Ver 1.4 and next morning I disconnected the charger, then noticed the battery dropping quickly, even with screen off. MediaServer was using as much battery as the Screen.

    In Manage Applications I clicked on "Media Area" and noticed that the only App that was running in that group was Repeater, so I did a Force Stop.

    When I turned the Screen off I noticed the phone did a restart - MediaServer was no longer shown using any power.

    I was also using Google Maps with Traffic as Live Wallpaper, so I have yet to confirm that it wasn't a cause also.

    Mike
     
  5. itsforsab7

    itsforsab7 New Member

    Joined:
    Aug 11, 2011
    Messages:
    3
    Likes Received:
    0
    I got really frustrated with the Galaxy S2 because of this mediaserver issue...

    From wat i have researched, I found that once the 'gallery' is opened and closed,

    • Phone keeps using the cpu 100%.
    • Phone's back becomes red hot.
    • The battery drains rapidly in 2-3 hours.
    • I plug it on to a charger it doesn't charge up :(:(
    • the mediaserver process comes up in the 'battery usage' with 60% usage

    Now, I switch off the phone. Boot it up. Charge the phone to 100%. Its all perfect and no heating up too. After 7 hours of usage, no mediaserver process in 'battery usage'.

    I went into the gallery once. Browsed some photos. And Closed it.
    Now it all started again. I've tried this 3 times now.
     
  6. doogald

    doogald Guides Guide

    Joined:
    Jan 7, 2010
    Messages:
    6,575
    Likes Received:
    1,877
    This is an Eris group, but did you look at what I mentioned before - that others had noticed this problem with the Gallery when they had corrupted image files on their SD card?

    You could try a couple of things that I can think of, off the top of my head, to rule this out:

    - backup and then delete all image files from your SD. Does this still happen after, say, you take a photo with the camera?

    - are you syncing with Picasa? (From home, settings->accounts and sync, check your Google account, and uncheck Picasa syncing.) If you turn that off, does that help the problem?

    Otherwise, you may want to post the same question on the Galaxy S2 forums here: Samsung Galaxy S2 - Android Forums
     
  7. itsforsab7

    itsforsab7 New Member

    Joined:
    Aug 11, 2011
    Messages:
    3
    Likes Received:
    0
    oh k k.. Sry I dint notice the Eris group... Thanks for the suggestions..
    And I don think i am syncing the pics with picasa...

    will try removing all the photos and videos i got.. hope there is a corrupt file causing all this mess :eek:
     
  8. itsforsab7

    itsforsab7 New Member

    Joined:
    Aug 11, 2011
    Messages:
    3
    Likes Received:
    0
    it worked... :) :)
    I removed all the music videos and movies from the phone.
    Its all normal now. No heating no battery drain.
    Some file is corrupt or whatsoever.

    hope there Will be an update that would fix this...
     

Share This Page

Loading...