micro usb port stopped working

Last Updated:

  1. gymkapp

    gymkapp New Member This Topic's Starter

    Oct 21, 2010
    Likes Received:
    after having the phone for 4 months and everythign going well I go to plug my phone in to charge(cause the battery only last a few hrs) and nothing. I took it to t-mo and they put a new battery in and it worked,said it was the port. Anyone else have this happen,what did you do. I didn't buy the phone direct through t-mo,but it was a brand new phone. I took it to a shop that fixes phones,said it would cost at most $50 to put in a new port,but is now saying that they might have to change the motherboard because the ports they tried adding isn't working. It's been about 6 days and i'm pulling my hair out over this. I dont understand how 1 day its fine and the next it's bricked!

  2. behold_this

    behold_this Well-Known Member

    Nov 18, 2009
    Likes Received:
    well a dead micro usb port certainly does not = brick. the phone still works so cannot be called a brick, though i know its as useful as one without being able to charge. you could see if there is a charging pad that works with the slide then you don't need the port and it would likely cost less. also i know it sounds dumb but did you try a factory reset? there could be corrupted software that disabled the port.

    FYI next time you should post things like this in the "support and troubleshooting" sub-forum at the top of the main page, as that is the best (and right) place to post topics such as this.

Share This Page