Moving Apps to /system/app


  1. RTAdams89

    RTAdams89 Well-Known Member

    I would like to move a few apps (such as Terminal Emulator and OSMonitor) to the /system/app folder. I'm able to get them moved, then chmod them to 644, but upon trying to launch them, they force close. Am I missing something?

    Advertisement
    :
  2. doomedromance

    doomedromance Well-Known Member

    I do it in terminal emulator this way.

    su
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    busybox cp /sdcard/location/of/application.apk /system/app/
    busybox cp /sdcard/location/of/application2.apk /system/app/
    mount -o remount,ro -t yaffs2 /dev/block/mtdblock4 /system
    sync

    But I guess it wouldn't help you much in pushing terminal emulator over.
  3. RTAdams89

    RTAdams89 Well-Known Member

    Seems like the same thing I have already tried
  4. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    For me, the easiest way to move apps to /system/app is using Root Explorer:

    1. Copy the apk and paste it into /system/app -- you'll need to press the button on the top right that says "Mount R/W".

    2. Long-press on the newly pasted apk file and select Permissions.

    3. Change the permissions to User: Read - Write, Group: Read, Others: Read

    4. When you click Okay, you should see "rw-r--r--" in the fine print under the apk name.

    5. Click the Mount R/O button, then reboot.

    Since it appears that you've already moved the apps to /system/app, then all you really need to do is look at the permissions and make sure they show as noted above.
    Capnwalker, xploPR, Kaessa and 2 others like this.
  5. RTAdams89

    RTAdams89 Well-Known Member

    I think I have done all that. Here is the (partial) directory lsiting of my /system/app folder using ADB:

    Code (Text):

    # ls -l /system/app
    ls -l /system/app
    -rw-r--r-- root     root        50473 2010-05-12 07:59 jackpal.androidterm.apk
    -rw-r--r-- root     root       391160 2010-03-31 18:15 Camera.odex
    -rw-r--r-- root     root        20960 2008-08-01 05:00 LiveWallpapersPicker.odex
     
    Permissions seem to be correct, yet I still get a force close...

    Here is the code I am using to move apps using ADB:
    Code (Text):

    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    cp /data/app/com.swype.android.inputmethod.apk /sdcard/com.swype.android.inputmethod.apk
    cp /data/app/com.eolwral.osmonitor.apk /sdcard/com.eolwral.osmonitor.apk
    cp /sdcard/com.swype.android.inputmethod.apk /system/app/com.swype.android.inputmethod.apk
    cp /sdcard/com.eolwral.osmonitor.apk /system/app/com.eolwral.osmonitor.apk
    chmod 644 /system/app/com.swype.android.inputmethod.apk
    chmod 644 /system/app/com.eolwral.osmonitor.apk
    mount -o remount,ro -t yaffs2 /dev/block/mtdblock4 /system
    sync
     
  6. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    And they read the same way for Terminal Emulator and OSMonitor?
  7. Phateless

    Phateless Well-Known Member

    Where are installed apps stored? I cannot for the life of me find them.
  8. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    If they're stored on the SD card, you need to go into Settings>Applications>Manage applications and "Move to phone." All apps stored in data on the phone are in /data/app.
  9. Phateless

    Phateless Well-Known Member

    I see nothing under /data. Absolutely nothing. Tried 4 different file managers with the same results and they're all set to display hidden files. What gives?
  10. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    Did you use Root Explorer? It's the only file manager I know of that will display /data.
  11. Phateless

    Phateless Well-Known Member

    Yep, tried that one. None of my file managers display it. Why would that be?
  12. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    Are you rooted?
  13. Phateless

    Phateless Well-Known Member

  14. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    My instructions are for a Motorola Droid 1 (since this is the Motorola Droid forum). I take it you have a different device? If so, I have no idea how to help you.
  15. Phateless

    Phateless Well-Known Member

    I have a mytouch, thanks tho.
  16. Phateless

    Phateless Well-Known Member

    Can anyone help with this? It's preventing me from getting my ota update to 2.2.
  17. sharkerbaby

    sharkerbaby Well-Known Member

  18. Phateless

    Phateless Well-Known Member

    Just realized I DIDN'T try root explorer, I tried File Manager. Will Root Explorer make a difference? Don't wanna pay $3 just to find out...

    I think what I really need is an adb guide.
  19. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    You can try it and get a full refund if you decide you don't want, so long as you uninstall it within 24 hours from purchase.
  20. Phateless

    Phateless Well-Known Member

    Hmm, that's not a bad idea. Thanks!
  21. radek.god

    radek.god New Member

    Hi,

    I have Samsung Galaxy 3 (I5800) and it works for me :
    "rw-r--r--" - there is a problem
    by Root Explorer, I moved app from Data to System and set ALL PERMISSION to Enable , then reboot , ALL works

    tested on CPU FREQ, Beautiful Widgets, THINK OFFICE etc...
Loading...

Share This Page