My wifi is useless!Support


  1. jasondhsd

    jasondhsd Well-Known Member

    I can't keep my wifi connected on my Droidx!! Scanning... connecting.... connected...then a few seconds later the wifi icon disappears and it repeats the process seemingly forever.

    I've discovered that if I use the wps push button method to connect it was stay connected until the wifi goes to sleep when I tries to reconnect I get the scanning...connecting...connected loop.

    I've tried different settings in my router (wpa/wpa2 just wpa, just wpa2, tkip, aes) I refuse to go below wpa encryption.

    My current settings WPA2 AES. I'm running a Linksys WRT400N dual-band router latest firmware, 2.4ghz mode set to mixed b,g,n.

    Oddly enough, during the time it took my to write this it connected itself and it seems stable now (at least until I let it idle). Phone probably knew I was on here complaining about it lol :eek: but any help you can give me to obtain a wifi connection better without having to spend 15mins each time trying to get it to connect would be great.

    Advertisement
  2. colchiro

    colchiro Well-Known Member

    What happens if you go into wi-fi settings, click the menu button, choose "advanced" and change wi-fi sleep policy to "never"?
  3. jasondhsd

    jasondhsd Well-Known Member

    No doesn't make a difference I found where to put in the static ip by pushing the four square button once while on the wifi setup screen the touching advanced. Although I did notice if I try touching the peer to peer adhoc channel button the app crashes each time and boots be back out to the wifi settings screen.
  4. Galt56

    Galt56 New Member

    I have had the same problem on both DXs that we have. I have a WRT400n Linksys router and I get a periodically stable connection, but mostly both our phones just cycle, connected, drop, connected, drop....I even had my phone replaced a few weeks ago and the new phone worked for about a week and now the same problem.

    I have connected to wifi hotspots just fine, but at home, on the linksys router, no go. I have changed security settings, set up static IPs, etc. All that happened was I made a mess of my wifi network and the DXs still don't work. Anyway, 3 phones....none work with this router with anything but periodic random success.

    Going to have to go buy a different wifi router and see what happens. The last firmware update for the WRT400 was about a year ago and I am running that. Seems that Linksys is not going to support this router with any further firmware upgrades, so I'll shell out some more cash and see what happens.

    Michael
  5. colchiro

    colchiro Well-Known Member

    Cisco/Linksys WRT 160N here and no issues.
  6. thirteen113

    thirteen113 Well-Known Member

    What encryption are you running?

    Hah! Should have read better... Try switching over to TKIP instead of AES in WPA2
  7. colchiro

    colchiro Well-Known Member

    Have you tried with wireless mac filter turned off?
  8. Galt56

    Galt56 New Member

    I have tried TKIP in WPA2. Doesn't make a difference. I will try turning off wireless MAC filtering and see what happens.

    Thanks!
  9. Bankswood

    Bankswood Well-Known Member

    My Wifi is useless!

    Mine too! Oh sorry I misread it. Thought it said "Wife".
  10. Galt56

    Galt56 New Member

    colchiro--now that I am able to look at the settings, I have Wireless MAC Filtering disabled. Previously I did try to turn it on and permit the specific devices. I have also tried using the wifi protected setup "push-button" registration which failed as well.

    DXs are the only two devices that give me any trouble with this router....all the rest of my devices--laptop, TV, DVD Playter, Itouch...etc, all connect just fine.

    Let you know what happens when I get around to installing another router....

    Thank you!!
  11. Doit2it

    Doit2it Well-Known Member Contributor

    Had the same problem with Droid Eris, never resolved it.
    Droid X was a little iffy at first.

    I switched my router from WP2 to WPA / PSK / TKIP and have a very stable connection with my Droid X now.

    You might try to switch the channel on your router also. I switched to ch 1 cause it auto selected ch 6 and a look with WiFinder app showed 2 other router in the area on ch 6.

    And I'm using a cheap TRENDnet router.
  12. dragonbro

    dragonbro Well-Known Member

    This what I did as well, works great! I had both TKIP and AES for the Wii console, but that doesn't get much use anymore anyhow.
  13. IdaWan

    IdaWan New Member

    I've a reference board (the Real6410) running Android 2.1. I'd the problem of Wi-Fi automatically turns itself off while signal strength is "excellent" when I'm right next to the Wi-Fi modem. The radio is ON for a long enough time for me to pull down the CNN home page then it turns itself OFF. I can go into "Settings->Wireless & Network" to turn the radio OFF then ON. The cycle then repeats, rendering the Wi-Fi link useless. My system/Android widget doesn't have any Menu Button::Advance entry for me to choose.

    Does any one has a better idea where/how to tackle this nasty problem?

    Thx.
  14. Galt56

    Galt56 New Member

    well it finally worked--I was using the "WPA2 Personal" which the router indicated was WPA-TKIP or WPA2-AES....not sure if it would accept either or what. I don't totally understand the setting.

    I changed to plain WPA-TKIP and it is working just fine on both phones for the last 12 hours or so...we'll see. Not real sure if I tried this security setting in the past.

    Thanks to all!!
  15. stereoeclectic

    stereoeclectic Well-Known Member

    having the same problem. it worked fine at first, then the problem started. updated the router firmware which fixed it for two days. now it is doing it again. i really hope they release an update to address this, because it seems that the problem is very common.

    i have a netgear n 150.

Share This Page