MyTouch 4G Market and Talk not workingSupport


Last Updated: 2011-04-28 15:46:02
  1. supdeva

    supdeva New Member

    Hi I am using a mytouch 4g (android 2.2.1).
    Even though wifi is working for browsing and even syncing the gmail account, it is not working for android market downloads(Market is the new version 2.3.6) and "Talk" is always giving an unable to connect message. I have tried everything suggested from
    1) factory resetting several times
    2) Clearing cache
    3) Using google mail instead of gmail
    4) detaching battery/SD

    But it always shows only "Starting to Download" or "Downloading" but nothing is actually downloaded. I am connected to the Wifi network at my office. It is WEP Enterprise(Enterprise-802.1x), PEAP, MSCHAPV2.

    Can you please tell me what I can do to get the market app working? :confused:

    Advertisement
  2. dasudevil

    dasudevil Well-Known Member

    I have had this issue sometimes. I seem to get it fixed via un wifiing myself. If that does not work i select the ones downloading and hit cancel. Then restart them after a reboot. Sometimes the downloads hang.
  3. supdeva

    supdeva New Member

    Market and talk are now working in at home in WPA2-Personal Network. Now that it worked once it might work at the office as well will try and update.
    But what i don't get is why the 4g on froyo couldnt connect while a 3g slide on a rooted froyo downloaded from the market just fine from the same network at office.
  4. supdeva

    supdeva New Member

    Now its working at office as well. I think the trick is to get talk initialized at least once. Then no problems.
  5. dasudevil

    dasudevil Well-Known Member

    Glad you were able to figure it out.

Share This Page