Nexus 7 won't update to 4.2.2Support

Last Updated:

  1. theclarkes

    theclarkes Member

    My Nexus 7 will not accept system updates to take it from 4.1.2 to 4.2.2 (All other apps seem to be updating OK on a regular basis). When I get the prompt to download a system update to 4.2.2 it re-boots and then a droid appears. The download bar gets about halfway across then the droid falls over and an exclamation mark appears above it. I then have to do a

  2. SiempreTuna

    SiempreTuna Well-Known Member

    Very strange.

    How much free memory do you have on the device?

    The download is somewhere around 50MB, so I doubt that is an issue but it's possible that 4.2.2 requires more resource than 4.2.1.
  3. theclarkes

    theclarkes Member

    Don't think memory is an issue. I have 28Gig free space! And I am stuck in 4.1.2 (not 4.2.1) Any ideas welcome Thanks
  4. jlede

    jlede Well-Known Member

    try getting the 4.2.1 image and stock rom and try from there
    never heard of your problem either just throwing out ideas
  5. John Bean

    John Bean Happy Wanderer

    4.2.2 seems to be an incremental update to 4.2.1, so I suspect having some earlier version (like 4.1.2 say) is the cause of the failure.
  6. coach660

    coach660 Member

    I'm so new at this I hate to get involved but from my limited experience if you are rooted what you're doing wont work and I'm hopeful that one of the very experienced people will be able to help you. Good luck.
  7. theclarkes

    theclarkes Member

    Thanks for the replies so far. I don;'t think it is an incremental issue as when I got it at Christmas it tried to update to 4.2.1 with the same problem. jlede mentioned "image and stock rom" no idea what that means - sorry. Someone out there must have a solution or perhaps I should take it back to the shop!
  8. jhsrennie

    jhsrennie Well-Known Member

    There have been a few reports in this forum of 32Gb models refusing to update. It might be worth searching through old posts. As I recall the only solution is to RMA the tablet. You could try the shop, but if they won't co-operate you'd probably find the Google support guys would help.
  9. John Bean

    John Bean Happy Wanderer

    That extra information is important - you don't have a problem with updating to 4.2.2 specifically, you have a problem with updates in general.

    I think perhaps a factory reset is in order, which will clear all data and costs you nothing as you will otherwise have to get a replacement anyway if it doesn't work.
  10. theclarkes

    theclarkes Member

    I did a factory reset this afternoon but still no joy. Everything restored OK from the backup and it downloaded the 4.2.2 but on 'reboot and install' if failed halfway through with the familiar 'dead android' appearing again. It's wierd. In every other respect the tablet is working perfectly and takes updates from apps and gmail etc etc. Anyone have any other ideas?
  11. John Bean

    John Bean Happy Wanderer

    I have only one suggestion - do another factory reset but this time attempt the update before restoring any apps by turning off sync, just in case it's some installed app (or its associated data) that's somehow interfering with the update process. Better yet, see if you can update before even signing in to your Google account by skipping the welcome screens and not creating an account. I don't know if it will offer the update if not logged in but if it will it will prove whether the problem is the tablet itself or the software installed on it.

    If that also fails I can think of no alternative to trying to get a replacement.
  12. LaLaLives

    LaLaLives Member

    FWIW, you are not alone as I've had the exact same problem since receiving mine for Christmas, too. Have also read on a number of forums about others not being able to update to either version. Early on, however, I read where a few people complained that they did not like 4.2.1 and had rolled back to 4.1.2. After hearing those complaints, I stopped worrying about it.

    My husband just got his N7 less than 2 weeks ago and is running 4.2.? (sorry, forgot which) and as far as I can tell there aren't any major differences. Sure, there are a few nice tweaks, but I don't feel like I'm missing anything.

    Still, it's frustrating to keep getting offers to update, going through the motions and getting the same (non) result.
  13. jhawkkw

    jhawkkw Chinchillin' Moderator

    If you get tired of failed updates, and really want the update, you could flash the 4.2.2 factory image.
  14. theclarkes

    theclarkes Member

    I like the sound of jhawkkw's suggestion but 'flashing the 4.2.2 factory image' sounds a bit beyond me and rather rude! How tricky is this?
  15. jhawkkw

    jhawkkw Chinchillin' Moderator

    It be done either manually through fastboot, or through the use of Wugs nexus toolkit virtually automatically. You will need to have your bootloader unlocked first though.
  16. theclarkes

    theclarkes Member

    Thank you for all your help and suggestions. However, I am taking the easy way out! I contacted the Asus technical helpline and, after describing the problem, they have come back to me to say that this can only be repaired by the Asus Technical Support Team and, as it is only a couple of months old, there is no charge for the repair. I will just be without it for a week or so. I will let you know the follow-up in due course. Thanks again.
  17. LaLaLives

    LaLaLives Member

    Hmm, I should probably follow suit, especially since I got mine at the same time you did. Although I'm not overly concerned about the lack of update now, I'm sure I'll want to update eventually. Just don't know if I can go a week without my baby.
  18. theclarkes

    theclarkes Member

    Just wanted to end this thread with the news that my Nexus7 has just been returned to me after a week away. I sent it back with RMA forms etc, It was picked up and I was able to keep track of it. Checked it all this afternoon and it seems to be working perfectly. Updated to 4.2.2. I think LaLaLives needs to bite the bullet and send it off. Good luck and thanks for all the comments.
    LaLaLives likes this.
  19. LaLaLives

    LaLaLives Member

    Thanks for the update!

    Still haven't gotten the courage to follow suit, but I'll post here if I do.
  20. Icekool

    Icekool New Member

    I'm in exactly the same position. Am on 4.1.2, have been since I bought it in December 2012, and it constantly wants to update to 4.2.2. It comes up every hour or something daft (I know I can't watch a film without it coming up at least once). If I try, it's bellyup android man with warning triangle, and then reset back to same version as before.

    I have spoke to google...who say it's an Asus problem (as I didn't buy it direct from the play store), and Asus do indeed say it's a RMA. However, I've not taken the leap to be without it for a week or more.

    This seems to be somewhat pants, seeing as it's a software issue. Just give me the update as a downloadable...without all the rubbish about bootloader and unlocking. It's files on the system that need to be added / replaced by others. Why do I have to send it back at all for that???!?

    Just fix the update that it's struggling on now!
  21. jhawkkw

    jhawkkw Chinchillin' Moderator

    Unfortunately if you're completely stock, there's not much that can be done in regards to fixing the update itself. The only way you're going to successfully get the update is by unlocking and flashing the factory image through the bootloader. Wugs Toolkit can make it significantly less painful and fairly automatic.
  22. bupkus

    bupkus New Member

    I had a Nexus 7 go bad about 3 weeks ago. The display shows an image that looked frosted over with white fog.

    I called Google support and they offered a refurb cause my 8 GB tablet is no longer being manufactured. My wife and I both tried to impress upon them that we didn't want a refurb as we have both had bad luck with them.
    They said they couldn't offer me a new N7 even if we were willing to pay more for the upgraded unit, which we offered to do.

    The first day I got it it wouldn't update the OS from 4.1.2 to 4.2.2 as reported in this thread. Today, 6 days later and after my house closing yesterday, I called and I was told my warranty had ended yesterday but he would contact a "specialist" to see if it could be replaced. He'll email me.

    I am not a happy camper but I will edit this post if and when I hear from Google support.
  23. Icekool

    Icekool New Member

    I got one toolkit...dunno if it was Wugs... and when I tried that it got stuck booting...nothing worked at all when I tried going up and down the menu in the 'bios'. Eventually it died and it's since recovered, but seeing as there's no proper backup either I'm reluctant to try anything again.

    It seems extremely rubbish that a stock product with 1 version of software cannot install a stock update that has come from the manufacturer/developer, and that the only official way of fixing it would be to send it back to have them 'fix' it...presumably at the loss of everything I have on the device.
  24. jhsrennie

    jhsrennie Well-Known Member

    This can happen if you didn't clear the various caches when you flashed the new image. Clearing the caches usually fixes it immediately.

    Well, yes, but to be fair it's a bug not intentional design, it's pretty rare and Google know about it and immediately replace any affected tablets.

    Flashing an image is pretty safe in the sense that it's hard to render the tablet completely unusable. Any problems are usually easily recovered (with assistance from forums like this one).
  25. Icekool

    Icekool New Member

    Immediately replace?

    When did this change?

    I was under the impression that I had to raise an RMA, send it back, and then when they had 'fixed' it, I would get it back, and that would take ~10days.

Share This Page