Problems overcoming country restrictions...Support


  1. Pizzaul

    Pizzaul Member

    Hello all, first post here.

    I am a member of the US military deployed overseas. This deployment I decided to order a tab 2 P5113, and it (finally) came in the mail about a week ago.

    I quickly realized that getting apps onto it would be a pain in the butt due to my global location (I'm in Timor Leste, a small country by Indonesia. If I remember correctly our internet comes via Australia).

    After a bit of research I figured out it would require a root, something I knew about but was unfamiliar with (never felt the need before with android devices) and after a few days of research I successfully rooted my phone and installed CWM 6.0.1.0.

    Next I tried installing a modified GooglePlay app that is supposed to bypass country restrictions (a bit outdated but I hoped it would work - pretty much every page about trying to fix my issue points to this same page, i'll dig up the link if anyone wants it to view) but you need a root explorer to install it properly. I can't download a root explorer because of country restrictions!!

    This seems like a catch-22.

    So then I discovered APK Leecher and I would like to try and use that to get a root explorer, but it requires a device ID and the only method to identify that is a method for phones, and I can't find anything saying how to get an android tablet device ID.

    This is very frustrating!! Is there a way to download APKs without needing a device ID? Can I find my device ID so I can use APK Leecher? Is there a root explorer I can download without country restrictions? I can't even install third party apps like Market Enabler or Market Unlocker, GooglePlay store just won't show them.

    I feel like I must be missing something...

    I really don't like having to jump through all these hoops to just be able to download apps.

    Advertisement
  2. Pizzaul

    Pizzaul Member

    Here's a link to the XDA thread with the modded googleplay app that I was talking about: http://forum.xda-developers.com/showthread.php?t=1582422

    Doing searches pretty much just brought me to a ton of blogs/etc that just redirected me back to this over and over again. Is there another way?? This is driving me insane.
  3. Pizzaul

    Pizzaul Member

    Just found a place I could get a Droid ID APK, can now try and use APK Leech (or the google chrome APK download extension I discovered also).

    I still want to find a way to use the actual play store app on my tab though... Any help in that regard would be great! Especially since I won't be able to test APK leech until later tonight and if for some reason that doesn't work out I'm back to square one.
  4. Pizzaul

    Pizzaul Member

    Well I finally solved my issue.

    Found the website APKTOP and was able to download some of the essential APKs to get myself started, such as Device ID, Market Enabler, and Droid VPN.

    I'm a little disappointed that nobody even replied to my thread, though.

    Guess I won't be using these forums if I need help in the future.
  5. Bosbouer

    Bosbouer Well-Known Member

    Hi

    I have read and re-read your postings and have to say that I am still confused. If you can access the internet from any location you should be able to access Google's Playstore and in the language preset that you setup.

    A colleague who works on a contract in Papua-NG has no problems with SA bought tablet that he uses there on a local sim service
  6. Pizzaul

    Pizzaul Member

    I was never able to browse the play store and see any apps - zero, period. When I went directly to an app link (via browser for example) it would tell me that the app was unavailable in my country, no matter what.

    I had everything set up as USA, it showed up in English just fine, I just was not able to download anything at all due to country restrictions.

Share This Page