Problems transferring files via USBTips


Last Updated:

  1. peace3314

    peace3314 Member

    I cannot find a mass storage setting for the USB connection that will allow me to transfer files from my PC to my main drive or to my SD card, or to create folders in either.

    I can transfer using WiFi Explorer Pro and create directories there, but there I must create the folders for each music album first, then transfer the files in bulk.

    I can also create folders using Polaris.

    With my Optimus M, I could activate the 'mass storage' function, then transfer multiple folders in one action or create folders without issues. How does one do this here?

    Thanks

    Advertisement
  2. chicle

    chicle Well-Known Member

    AFAIK, make sure that your phone is in debugging mode, then when you connect to the pc's usb port, drag down the notification area and click on connect as a hard drive, or something like that. Once you're connected like this, you should be able to manipulate files in Windows explorer.

    IDK if that's what you meant, but I do it like that and it works for me .
  3. peace3314

    peace3314 Member


    Thanks. I had disabled debugging.

    I enabled it , then chose the setting 'MTP' (media transfer protocol) and I can now move folders from my PC into folders on my phone or my card. I cannot create folders in the phone drive there or on my card. I cannot move files between the card and the phone.

    This isn't a huge issue because Polaris allows folder creation and also allows files and folders to be copied or moved to and from the card easily.

    Should I turn off debugging when I am done moving things? I think that I can create a toggle for it with Power Toggles.
  4. THE W

    THE W Well-Known Member

    i just tried this for the first time with the motion. i didnt have to put the phone in debugging mode in order to copy a file from my PC to the phone(MTP).

    havent tried creating a folder yet.
  5. peace3314

    peace3314 Member

    Transferring is fine now for me (with debugging enabled). I can rename and delete items on the phone from within Explorer, just can't create folders. A simple work around (besides employing Polaris to the files on the phone) is to create the folder tree that I want on my phone (or SD card) in Explorer and then transfer the whole tree to the phone (or SD card).

    No big deal with this...just curious as to why it won't allow me to create folders from Explorer on the phone's drive or the SD card. I did format the card before putting it into the phone.
  6. cjbandroid

    cjbandroid Well-Known Member

    There are weird things when connecting to computer.

    It autoloads drivers and other stuff to XP or Vista or Win7.

    You get to connect in various modes.... hmmm.

    I've had problems renaming files, and with thumbnails for pictures.

    Its like the whole USB bus is slow... sluggish. Its NOT. But it acts that way with certain functions. You do a transfer... copy files... its quick as it should be.

    Still exploring....
  7. THE W

    THE W Well-Known Member

    Yeah it is kinda quirky.
  8. anubispax

    anubispax Well-Known Member

    Yeah it's different than any other Android I've owned. I can't figure out how to trasnfer files at all when my pc is running Linux, I have to reboot into Windows 7 which is kinda funny cuz Android is Linux based lol. And I could't load a video I had in my phone to my PS3 either, although I didn't try very long I got frustrated and transfered the file to my pc then to a USB drive.

Share This Page