Rooted, tried to go back to stock and now having problems

Last Updated:

  1. Miette

    Miette New Member

    Hello! I rooted my phone last year using the instructions from these forums ("how-root-vm-samsung-intercept-froyo-2-2-2-easy-way-updated-6-24-12"). Everything worked running IceCreamFroyo 1.2 ROM and crap_kernel1.5 as it should, but I got frustrated with certain processes so I flashed to bROM_1.3.1. This new ROM still didn't recover certain functionalities (force close after doing specific things) so I wanted to reflash back to the stock froyo 2.2.

    This is where I did something wrong. I used Recovery mode to wipe cache and dalvik cache, then flashed the stock kernel and stock ROM downloaded from the original How to Root thread. After rebooting my phone, I found that it was now semi-bricked. I do not know whether I accidentally flashed Stock_recovery or maybe mixed 2.1 and 2.2 versions. I obviously wouldn't have done it on purpose, but I had saved every file from the original thread so I just want to throw it out there as a possibility.

    After some intense searching online, I finally found a live link to "" that Virgin Mobile had pushed over the air to update Intercepts to Froyo. I was able to load this in recovery mode, and got my phone running again. Now my first problem is that my phone won't connect to my wi-fi network. It will turn on, find my router, allow me to enter the password, presumably connect, then disconnect again. I have unplugged my router and model for 15minutes and rebooted my phone multiple times but it won't connect.

    (I'm not sure how related this is, but I ran some app which gave me an error that "playlogo-orig not found" but the does have playlogo.p. I forget which app asked for this though.)

    A secondary problem which prevents me from trying to do any more software tinkering is that I can't tell if my phone is still rooted or not. I believe the Intercept Root.apk is a permanent root but Titanium Backup and Terminal Emulator both tell me I'm not rooted. If I re-install Intercept Root.apk then it tells me I am already rooted, but I can Re-root or Install CM01 Recovery. Neither of those options actually work (it goes to the installing screen but just sits there for over 15 minutes).

    I saw instructions for rolling back to 2.1 but didn't want to cause further messes on my phone because of this questionable root status. My most pressing concern is getting wi-fi back on, whether rooted or not.

    Is there anyone that can please provide some guidance to get my phone back to track? I promise to stay away from custom mods if I can get wi-fi back :eek:

  2. Miette

    Miette New Member

    I don't know where to start to try to figure out the internal wireless settings.. I'll try one of the developer forums in a few days if there is no response here :),
  3. markzombie82

    markzombie82 Well-Known Member

    You should ask over at sdx they had an update at vm that borked rooting the easy way now I think you have to use sw updater to reflash recovery and get a rooted kernel.

Share This Page