S3 Won't Charge/ Discharges QuicklySupport


  1. saluki450

    saluki450 New Member

    Hello all,

    I have a GS3 on T-Mobile that's about a year old. About two weeks ago I noticed the battery won't charge, and when it read a 100% charge it would discharge quickly. I replaced it with an Ankher 2200maH battery and had the same problem. Today I did the factory reset and still no luck, I'm having the same issues. I only charge it with the factory charger that came in the package. Any help is much appreciated. Thanks!

    Dan

    Advertisement
  2. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Sounds like you need to replace the charger
  3. saluki450

    saluki450 New Member

    I use my charger and my wife's charger, and I have the same issue with both.
  4. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Try blowing out the charging port with some "air in a can".

    I assume when you say you tried your wife's charger, you also used her cord? :)
  5. saluki450

    saluki450 New Member

    Yes, I use her cord. I just tried blowing out the charging port. I'll see what happens over the next few days. Thanks!

    Dan

Share This Page