Scottys noob friendly root guide-start to finish


Last Updated:

  1. thornev

    thornev Well-Known Member

    Your previous post said all I had to do is put back the stock recovery. Now you're saying I have to ensure the updater scripts are installed and that the firmware version is the OTA's expected version. Well, sir, looks like I'm back to doing what I said I did for the .11 update: running the RUUxxx.exe. Oh well. It was exciting while it lasted.

    Advertisement
  2. Aremihc

    Aremihc Well-Known Member

    scotty85 likes this.
  3. scotty85

    scotty85 Guides Guide

    if you want to,you can. tho if you have working root apps and superuser is granting things permissions when you allow it to,sounds like you are rooted :) not sure why youd get the error message,and have it work at the same time,but rooted is rooted :D

    sorry if i confused you,my oversimplified "reinstall stock recovery" direction was assuming that you were running a stock rom,and also that it was fairly common knowledge that custom roms are typically modified to protect the user from unwanted OTAs.

    if youre running custom roms,the benefits of an update from htc/vzw are going to mainly be from firmware(new radio,hboot,etc) as we can easily flash new custom roms in recovery to take advantage of any software updates. *if* we lived in a perfect world wed be s-off and have the option to install the updated,allready rooted rom via recovery, and the updated radio in an unsigned file via hboot. but alas... we live here in crappy unlocked s-on land where things are more difficult and we need to be more creative. ;)

    without any over simplifying this time,to get updated firmware these are the methods i can think of off the top of my head:

    when stock:
    1)lock and run current RUU prior to OTA, so OTA occurs
    2)lock and run RUU for OTA after the fact
    3)keep stock recovcery on phone,let OTA happen.

    all 3 are going to require re-rooting afterward. #3 has the advantage of letting the user keep his data,downloaded apps and settings,making life alot easier than someone whose chosen 1 or 2

    when running custom roms:
    1)lock and run current RUU prior to OTA, so OTA occurs
    2)lock and run RUU for OTA after the fact
    3)restore a (mostly)unmolested stock backup. replace recovery with stock,if running custom recovery
    4)flash a stock rom(such as this one from scossler ). replace recovery with stock if running custom recovery

    all should work,provided OTAcerts.zip or any other important files have not been modified to prevent OTAs in the backup restored,or rom flashed. if youre just going to flash a custom rom anyway,there is not a whole lot of point IMO to 1,3,or 4 as all youre really wanting is new firmware-youre OTAing to software that youre just going to change.

    while i put my phone thru alot of "abuse" :)eek:) so i know how it will react to things,i generally try and reccomend folks to flash important things like bootloaders and radios as little as possible(especially when s-offed). running RUUs is generally very safe,as its signed files being installed,but there are small chances that different things could happen to interupt transfer of files during an hboot/radio flash wich could well leave the phone permanently hard bricked: phone could fall,spitting out battery. power could go off,killing the PC. your dog could jump on the desk,pulling the USB out of PC. yeah,somewhat far-fetched,but you get the picture-any of those things could happen,so the fewer things that affect hboot and radios that we flash,IMO,the better.

    if youre running custom roms and accustomed to re-setting up your phone,then #2 may be your best option to obtain new firmware,as it will only require the one RUU flash. tho,you will have to relock and re-unlock to do it.

    heck,it could be that the next OTA will be minor(not ICS) and therefor not contain any firmware. if there is no new hboot,radio,etc,there would be no value in even trying to get the OTA. simply flash a new rom based on the new software in recovery.

    hope that helps clear it up some so you dont have to renounce your disciple status ;) i see you doing alot of good and helping out alot of folks here,i dont want to cause you any fustration. :cool:


    awsome! glad you got it :cool:
    thornev likes this.
  4. thornev

    thornev Well-Known Member

    No Problem, Scotty. Too many people giving me the shits this week so I took it out on you. I apologize about that. "We're good" as Ving Rhames said to Bruce Willis. :p
    scotty85 likes this.
  5. beef623

    beef623 Member

    I'm having a little bit of trouble with root access. I got my device unlocked, installed recovery and flashed a ROM (I skipped rooting the stock ROM). Now I don't appear to have root access. Titanium backup says it can't get root and the superuser app also fails to get root. What am I missing?
  6. scotty85

    scotty85 Guides Guide

    What rom did you install?
  7. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator

    I had that same issue with TiB. Uninstall it, then reinstall, that worked for me. Maybe will work the same with SU.
  8. beef623

    beef623 Member

    I tried uninstalling and reinstalling, but I still get the failed to get root access message in TB.

    The ROM I used is ineffabilis-Deus-1.01. The ROM itself is working fine, just no root.
  9. scotty85

    scotty85 Guides Guide

    are other root apps working? or none of them are? i agree,with BC... try uninnstalling tibu and its prokey,then wait until the free app is done downloading before downloading the prokey. its easy to miss the superuser pop up when the prokey downloads if your downloading other apps or doing other things.

    if that doesnt work,then you could open your superuser app and make sure titanium is there,and being allowed su permissions.

    failing that,id just launch,or boot to recovery and flash the superuser root files like your rom was stock :)
  10. beef623

    beef623 Member

    Thanks for your help guys. Nothing is showing up in the apps list in the superuser app. I haven't purchased the prokey for TB yet, I wanted to make sure it would run ok first.

    I'll try reflashing the superuser files. Just so I'm clear, is that the same as in step 3 or is that the option in the amon-ra recovery menu? If it's step 3 from the guide, will I need to wipe everything again or just flash it?
  11. scotty85

    scotty85 Guides Guide

    You could do either. I have never personally used the amon menu option,but others have and say it works fine.

    If you flash the file,juust wipe cache and dalvik cache,then flash it. No need to wipe data.

    One other thing you might try is clearing data in titanium,then open it again and watch for the Su prompt :)
  12. beef623

    beef623 Member

    Hmmm.. still no luck. I tried both ways. I also tried clearing the data for TB, but that didn't work either. I don't get a prompt for su, it just sits at the screen that says asking for root rights for 10 or 15 seconds then says it couldn't get root.

    I'll probably try reflashing the rom and kernel later tonight or tomorrow and see if that fixes it, maybe something went wonky there.
  13. Bob Cat

    Bob Cat Careful, They're sharp!! Moderator

    That's exactly what it did with me. Weird that uninstalling/reinstalling didn't work. That being said I have always have had the pro so.........

    I flashed Nil's business ICS and love it.
    beef623 likes this.
  14. beef623

    beef623 Member

    Reflashing the ROM didn't work so I tried Nil's and everything appears to be working now, thanks for mentioning it!

    The link to the kernel on the post that had the ineffabilis rom was broken and I had to go elsewhere to get it, that must have been my problem.
  15. Brent372

    Brent372 Well-Known Member

    Will unlocked using the method detailed in this thread still result in having to wipe the phone (as mentioned on the HTCdev website)?
  16. scotty85

    scotty85 Guides Guide

    Unfortunately yes. The unlock procedure performs a factory reset. No way around it,I'm afraid
  17. FumanII

    FumanII New Member

    Scotty - Great guide!! I've managed to get my Rezound rooted and everything seems fine except ..... and i'm not sure why this is doing it.
    I can no longer get 4G and no option to change it either, am stuck on 3G now. I have checked the normal stuff, power options etc but haven't found a solution - anyone have any ideas??
  18. scotty85

    scotty85 Guides Guide

    i dont remember exactly where it is on GB,but there should be a setting in wireless/networks to change from "cdma" to "cdma/lte"

    -make sure youre set to cdma/lte.

    -make sure the rear cover is fimrly attached

    -try a reboot of the phone

    -try toggling mobile data on/off

    -try toggling airplane mode on/off

    *give it a little time. ive noticed on my thunderbolt that a factory reset,or fresh RUU install will sometimes have flakey data for a bit :eek:

    also dont discount the notion that theres trouble in your area,cold be a very random,yet unconnected coincidence... just a couple days ago i had no 4g all day long :mad: turned out there was an outage in the indianna,ky,southern oh area
  19. FumanII

    FumanII New Member

    Scotty i Bow to your greatness!! i now have my 4G back! Thank you sooo much sir, Alan
  20. leasiz6

    leasiz6 New Member

    I appreciate the step by step rooting guide Scotty. I followed the first post with the temporary recovery and successfully rooted my Rezound. Unfortunately I'm unhappy with the Rezound and want to sell it now. I'm doing the mini RUU method and I'm stuck on run mini ruu:

    Code (Text):
    1. c:\mini-adb_vigor>fastboot flash zip RUU-2.01.605.11-mini.zip
    2.           sending 'zip' (0 KB)... OKAY [  0.144s]
    3.                  writing 'zip'... INFOzip header checking...
    4. FAILED (remote: 32 header error)
    5. finished. total time: 1.678s
    Any idea what went wrong? Also, how do I make the cool blue scrolly code insert? Thanks in advance.
  21. scotty85

    scotty85 Guides Guide

    what is your main version?

    what is your hboot?

    on the cool blue scrolly insert,when youre on an "advanced reply" there is a # at the top of the reply box. click on that,and it will give you a pair of "
    Code (Text):
    1. " tags. just paste your code between then :) the [B]#[/B] does not show up for a "quick reply" ,however :) i edited your post so you could see what the code tags look like :)
  22. leasiz6

    leasiz6 New Member

    Thanks for the edit/lesson. It looks like the main version is 1.00.000.0 and I'm guessing/hoping the hboot info is somewhere in there too.

    Code (Text):
    1. Microsoft Windows [Version 6.1.7601]
    2. Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    3.  
    4. C:\Users\Leasiz6>cd c:\mini-adb_vigor
    5.  
    6. c:\mini-adb_vigor>adb devices
    7. List of devices attached
    8. HT1BNS211464    device
    9.  
    10.  
    11. c:\mini-adb_vigor>adb reboot bootloader
    12.  
    13. c:\mini-adb_vigor>fastboot boot recovery-ra-vigor-3.14-gnm.img
    14.         downloading 'boot.img'... OKAY [  1.920s]
    15.                        booting... OKAY [  0.003s]
    16. finished. total time: 1.924s
    17.  
    18. c:\mini-adb_vigor>adb reboot bootloader
    19.  
    20. c:\mini-adb_vigor>fastboot getvar all
    21. INFOversion: 0.5
    22. INFOversion-bootloader: 2.10.0000
    23. INFOversion-baseband: N/A
    24. INFOversion-cpld: None
    25. INFOversion-microp: None
    26. INFOversion-main: 1.00.000.0
    27. INFOserialno: HT1BNS211464
    28. INFOimei: 990000651159776
    29. INFOproduct: vigor
    30. INFOplatform: HBOOT-8260
    31. INFOmodelid: PH9810000
    32. INFOcidnum: VZW__001
    33. INFObattery-status: good
    34. INFObattery-voltage: 4276mV
    35. INFOpartition-layout: Generic
    36. INFOsecurity: on
    37. INFObuild-mode: SHIP
    38. INFOboot-mode: FASTBOOT
    39. INFOcommitno-bootloader: dirty-f1438441
    40. INFOhbootpreupdate: 11
    41. INFOgencheckpt: 0
    42. all: Done!
    43. finished. total time: 0.543s
    44.  
    45. c:\mini-adb_vigor>fastboot erase cache
    46.                erasing 'cache'... OKAY [  0.222s]
    47. finished. total time: 0.223s
    48.  
    49. c:\mini-adb_vigor>fastboot oem rebootRUU
    50.                               ... INFOStart Verify: 3
    51. INFOStart Verify: 3
    52. INFOerase sector 130560 ~ 131071 (512)
    53. OKAY [  0.208s]
    54. finished. total time: 0.209s
    55.  
    56. c:\mini-adb_vigor>fastboot flash zip RUU-2.01.605.11-mini.zip
    57.           sending 'zip' (0 KB)... OKAY [  0.144s]
    58.                  writing 'zip'... INFOzip header checking...
    59. FAILED (remote: 32 header error)
    60. finished. total time: 1.678s
  23. scotty85

    scotty85 Guides Guide

    hmm. definately nothing immedately looks wrong.

    a quick search for error 32 suggests a bad download,maybe try re-downloading it.

    also make sure the phone is charged to 100%

    last and not least,it could have something to do with being on hboot 2.10. maybe the android info document needs modified? you could try swapping out the android info text document from the mini ruu with the one from the official,signed ruu.( download android info 2.01.605.11 )

    having said all that,you may want to take this oportunity to go ahead and relock and run the full ruu,to get yourself on the current hboot and newer radio.

    ill search around some more later this evening for that error. effin "unlocked" s-on hboot :mad:
    leasiz6 likes this.
  24. leasiz6

    leasiz6 New Member

    Yup, you're first guess was right Scotty. As I was downloading RUU-2.01.605.11-mini.zip, my computer went to sleep. I continued the dl and that must have caused an error. I re-downloaded it and everything went smoothly after I replaced the corrupted file. Thanks a lot for being so helpful. It's much appreciated.
    scotty85 likes this.
  25. scotty85

    scotty85 Guides Guide

    awsome! glad that was the only prollem :)

Share This Page