setting minSdkVersion in android source, for included apps

Discussion in 'Application Development' started by arnoldl, Jan 28, 2010.

  1. arnoldl

    arnoldl New Member
    5

    Jan 28, 2010
    4
    0
    5
    Hello all,

    I'm making some modifications to the calender app.
    Since we can't load this app in the SDK -> eclipse..
    i'm building it from the android source. (eclair branch)

    This works good , and i can run the modificated calendar app on the
    emulator.

    But i can't install in on my 2.0 running milestone.
    it gives INSTALL_FAILED_OLDER_SDK.

    Setting <uses-sdk android:minSdkVersion="5" />
    in the calendar manifest.xml doesn't work and gives :
    Warning: AndroidManifest.xml already defines minSdkVersion (in
    http://schemas.android.com/apk/res/android)

    during make.
    also editing build/core/version_defaults.mk doesn't do the trick..

    so any help is welcome..i'm stuck!!
    thanks
     

    Advertisement

  2. homunq

    homunq New Member
    5

    Feb 8, 2010
    1
    0
    5
    I'm working on it. I'd love any tips, and I'll let you know here if I figure out how to fix this.
     

Share This Page

Loading...