Setting up the Android SDK in Eclipse.


Last Updated:

  1. TheLupineOne

    TheLupineOne Member This Topic's Starter

    Joined:
    Jan 19, 2010
    Messages:
    10
    Likes Received:
    0
    I am currently on Eclipse setting up the Android SDK. In the Android section of Preferences, I have applied the SDK location as C:\android, but no SDK targets are turning up. Why?
     

    Advertisement
  2. tmette

    tmette Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    98
    Likes Received:
    0
    I had the same problem the other night when trying to do this. Are you working on Windows or OSX?

    Go to step number five on this website, which shows you how to set up the environment variables. After I did this, I was able to get SDK targets to show up when setting up a new project.
     
  3. htngon

    htngon Member

    Joined:
    Jan 26, 2010
    Messages:
    10
    Likes Received:
    0
    I have a simple way like this:
    Requirement:
    + Eclipse with installed ADT (any version)
    + Download SDK from developer.android.com.

    Practice:
    + Step1: Extracting the downloaded SDK into a folder (Example:f:\android-sdk-windows-1.6_r1\)
    + Navigation Window>Preferences. Then select "android" term in the left panel. Android Preferences appears in the right panel at the moment.
    + Put path of above folder into SDK Location (f:\android-sdk-windows-1.6_r1\)
    + finally click OK

    finish.
     
  4. hourang

    hourang Member

    Joined:
    Jan 25, 2010
    Messages:
    13
    Likes Received:
    0
    i had the same problem. ran the sdk and avd manager and got all the updates and now they all show up.
     
  5. jarnaud

    jarnaud New Member

    Joined:
    Jan 24, 2010
    Messages:
    4
    Likes Received:
    0
    Well, it seems that
    1/ you have not downloaded the appropriate SDK (make sure it matches your machine's architecture)
    or
    2/ you have not extracted it in C:\android

    --
    Complete Android Development Training on Android training online
     

Share This Page

Loading...