sgs firmware upgrade problem


  1. fridgey

    fridgey New Member

    Hi,

    I followed a guide (How to Upgrade Samsung Galaxy S to Android 2.2 Froyo | Gadget News) to upgrade my firmware to froyo.

    The rooting went fine, but when I tried to upgrade I encountered a problem. I did everything as explained in the guide: Pointed to all the correct files for "PDA", "PHONE" and "CSC" in Odin and I did tick the "Re-Partition" option. With my phone I booted into download mode and connected it to the computer. Clicked start in Odin and got the following printout:

    <ID:0/010> Added!!
    <ID:0/010> Odin v.3 engine (ID:10)..
    <ID:0/010> File analysis..
    <ID:0/010> Set PIT file..
    <ID:0/010> DO NOT TURN OFF TARGET!!

    It got stuck there so I left it hoping its just taking a little bit of time...however, after an hour's wait I figured the upgrade was not successful.
    I wasnt sure how to cancel the upgrade, so i looked on the web and apparently I was suppose to remove my battery for about 5 minutes or so and then put it back in and it should be okay...I did that, but now my phone doesnt startup at all. It just shows a picture of a cellphone trying to connect to a desktop pc but with an exclamation mark in the middle of the connection indicating that it cannot connect or something. Tried to plug the phone into my computer again and tried using ADB to reboot it again, but adb can no longer see my device.

    If anybody can help, please do? Getting a bit desperate here :| And reeaalllly wanna upgrade to froyo. T_T

    Thanks

    Advertisement
  2. fridgey

    fridgey New Member

    Oh and the 3 button combos to boot into recovery mode/boot mode does not work on my galaxy s
  3. Cyb3r5c4r

    Cyb3r5c4r Well-Known Member

    this happened to me and i fixed it so all is not lost, im not 100% but i think i pulled the battery pluged the phone into my pc with odin running and firmware selected then put the battery back and turned it on and reflashed it

    also try using Odin3 v1.3
  4. wbexpress

    wbexpress Member

    Hello, I am having the same problem. Please clarify these 2 things: "firmware selected" (does that mean with the pit and the pda filled in via the drop down?), and, "turned it on". I think the probelm Fridgey & I are experiencing is that once the battery is put back in the triangle thing comes right back. Also, can you please post a link where Odin 3 v1.3 can be found? I've Google dit but cannot find it. Thanks...
  5. Cyb3r5c4r

    Cyb3r5c4r Well-Known Member

    @ wbexpress: your post says you have vibrant?? to the best of my knowledge there is no working froyo firmware for that phone yet.
    go to www.samfirmware.com and register there they have all the latest firmwares for all us and international galaxy s phones

    I9000XXJP2 is also not the latest froyo version firmware I9000XXJPC is and its much more stable and ive found no glitches in it yet.

    my head was up my ass when i wrote this:(also try using Odin3 v1.3)
    i should have said are you using Odin3 v1.0?

    this i what i mean when i say sellect the firmeare:

    Press on the PIT button and load the
  6. wbexpress

    wbexpress Member

  7. Cyb3r5c4r

    Cyb3r5c4r Well-Known Member

    im sorry i couldnt help more. but i deffinately had the same problem. and was still able to solve it as my phone works fine now.

    on the upside if it does turn out to be bricked at least T-mob will never figure out that you were flashing it and voiding your warranty

    odin dosnt recogmise the phone atall when its plugged in??
  8. wbexpress

    wbexpress Member

    No, because until it were to get into download mode it can't tell it is connected. Yeah, it's bricked. I did talk to a decent guy in Technical Support, and I am getting a replacement. Without actually saying the words, he gave a strong indication that they are aware that it is a "manufacturing defect". I should have had him put a note on my account to test it before sending it out so I don't get another hardware locked one. Oh well, if I do, I'll shoot myself before ever trying to flash anything else again with Odin. Give me my GPS fix and FroYo, I'll swear off ever flashing anything else again (maybe...:D).
  9. snapper.fishes

    snapper.fishes Well-Known Member

    Yup.. You were screwed. Big time. That's the infamous brick logo for the non 3buttoncombo phones.
Loading...

Share This Page