SGS3 Thinks an earpiece is connected so no sound! !!!!General


Last Updated:

  1. aje99999

    aje99999 Member This Topic's Starter

    Joined:
    Jun 10, 2012
    Messages:
    20
    Likes Received:
    0
    Was outside yesterday and had a series of urgent calls from my wife but when I answered them she couldnt hear me and I couldnt hear her! !!

    When I got home I realised there was a headphone icon in the notifications bar at the top of the display, now I hadnt noticed this while I was out due to the poor screen visibility in sunlight (thats another story).
    Rang THREE who wanted me to back up and reset the phone back to factory defaults, I am going to have to do this today but anyone any ideas? ??
    I have never even plugged an earpiece into it, well hadnt until this problem occured as thought it might clear the earpiece connected problem but no luck :(:(:(
    Adey
     

    Advertisement
  2. Mashi

    Mashi Member

    Joined:
    Jun 12, 2010
    Messages:
    7
    Likes Received:
    1
    I notice when I have my earpiece connected. The phone did ring but not through the earpiece. It ring through the phone speaker.
     
  3. aje99999

    aje99999 Member This Topic's Starter

    Joined:
    Jun 10, 2012
    Messages:
    20
    Likes Received:
    0
    Thats how it should work I think, I can hear mine ring but when I answer the call I cant hear the caller and they cant hear me because its expecting all the audio to go throug the earpiece because it thinks one is connected when there isnt one connected! !
     
  4. Doit2it

    Doit2it Well-Known Member Contributor

    Joined:
    Oct 23, 2009
    Messages:
    1,962
    Likes Received:
    467
    It sounds a little like this problem, except no one mentioned the headphone icon being present.
     
  5. mauchlen

    mauchlen New Member

    Joined:
    Jul 1, 2012
    Messages:
    2
    Likes Received:
    0
    It happened to my phone after i dropped it! There are a couple of solutions, one which you stated i.e. full factory reset (make sure you back up everything on external source,as you will lose everything) or you can install the wired headset routing widget app from play store. I initially dowloaded app which worked, but then did a reset which cured the problem.
     
  6. Doit2it

    Doit2it Well-Known Member Contributor

    Joined:
    Oct 23, 2009
    Messages:
    1,962
    Likes Received:
    467
    Is this the widget you are talking about? aje99999 let us know if it helps your issue also. Sounds like a good temporary fix till Samsung finds a one.
     
  7. mauchlen

    mauchlen New Member

    Joined:
    Jul 1, 2012
    Messages:
    2
    Likes Received:
    0

    Yes thats the widget. Worked a treat for me.

    I should add that if you've got the headphone icon on phone, i found to get rid of it was to dial a phone number and then press speaker phone. That removed icon and sound returned from phone. However, if you plugged in ear phones the phone did not recognise it. However, if you switch your phone off and then back on, the headphone icon reappeared and problem of no sound from phone returned. That widget gives you the option of where the sound comes from. I resetted the phone to factory settings out of curiosity and found it solved problem totally, tho having the widget is very handy just in case......
     
  8. ikefox

    ikefox Member

    Joined:
    Jun 29, 2010
    Messages:
    7
    Likes Received:
    2
    Has anyone else run across a fix for this? I have tried both the aforementioned widget (which did not seem to do anything) and a factory reset. No matter what I do, the icon remains in the notification bar and sound is still a no-go.
     
  9. nseriessaga

    nseriessaga Well-Known Member

    Joined:
    Jun 26, 2012
    Messages:
    142
    Likes Received:
    23
    This has happened to me MANY times on different types of phones. 1st thing i ALWAYS make sure is that there's no lint/dirt/etc... in the headphone input hole. Get a q-tip or a paperclip and wrap it with a thin cloth.. Give it a very good cleaning holding it upside down making sure if somethings in there it gets cleaned. Even a very tiny piece of lint, if sitting on a specific spot of the jack, will do this to the phone. Make sure you blow everything out as much as possible when your done with the cleaning.

    I would try this first, then try the software troubleshooting route afterwards.
     
  10. nseriessaga

    nseriessaga Well-Known Member

    Joined:
    Jun 26, 2012
    Messages:
    142
    Likes Received:
    23
    Please try cleaning your headphone jack area as stated in my previous post.
     

Share This Page

Loading...