[SOLUTION] Market Webstore


  1. chrlswltrs

    chrlswltrs Well-Known Member

    I logged in and downloaded an app just fine, I really like the online market
  2. zerocool79346

    zerocool79346 Well-Known Member

    Yeah I successfully installed one...to a phone that has been deactivated (and has a bad ESN to boot) since October 5th. Something isn't adding up here. I have two phones listed as devices on there, neither of which is the phone that I actually have setting in front of me.
  3. EarlyMon

    EarlyMon The PearlyMon Moderator

    I'm going to do the whole Google account delete from Accounts & Sync, re-sync and say back later if that worked.
  4. A.Nonymous

    A.Nonymous Well-Known Member

    Yep. When I log in, I can see the Nook and my phone. Both are rooted. The Nook is running stock rooted and the phone is running a custom rom. That's the only real difference between the two. When I go to install an app, it simply asks me which device to install it to. It says it hasn't talked to my phone since 1/17 though. I have logged into the market on my phone, bought (free) stuff and rebooted my phone. None of it works. Market on my phone has no issues, but I can't push to it from the web. I'm guessing it has to do with my ROM.
  5. bjanow

    bjanow Well-Known Member

    I also had the initial invalid request message at the very outset. Tried it about 1/2 hour later and I was able to login. Picked some silly Amex app just to see if it worked and it did. Turned on the phone 2 seconds later and there it was, installing the app. Very cool website, something we really needed. I'm rooted on CM7 #23 Invisiblek's beta kernel, if anyone cares.
  6. A.Nonymous

    A.Nonymous Well-Known Member

    Cleared the market cache and reset it on my phone. Made no difference. Still can't push apps.
  7. EarlyMon

    EarlyMon The PearlyMon Moderator

    ^Same here - and I'm too work-busy to backup/reset/restore at the moment.

    Although you run a custom rom - I had a leaked Froyo then patched it (all rooted). There was some HTC phone-home stuff I didn't like, so I deleted it. So - our roms may be similar in that we're missing some file like that. My Market list is stale since 8/10 - and that would've been about the time I deleted those files.

    It's likely I have backups of everything. If I find the missing culprit, I'll shoot you a PM so you can check your /system for it.
  8. A.Nonymous

    A.Nonymous Well-Known Member

    The ROM I'm using now is buggy. I'm gonna update it to the new version. Been planning to do it anyway, but I've just been too lazy. It's bitterly cold out and everyone but us is closed for the weather. I may update the ROM today and see if that's the problem. Might save other people some issues.
  9. Podivin

    Podivin VIP Member VIP Member

    Running a rooted DInc with stock ROM (bloatware removed) and an updated kernel, I was able to login and install an app with no problem. The market does still show my old phone though, so I set that one to 'hide in menus' so I wouldn't see it.
    EarlyMon likes this.
  10. EarlyMon

    EarlyMon The PearlyMon Moderator

    OK, I've checked at Google.

    Rooted and non-rooted users alike are reporting this issue.

    I did the same hide-thing for my wife's old phone - she's running just fine with all this.
  11. chrlswltrs

    chrlswltrs Well-Known Member


    Mine shows 2 also, the one I have now and a previous one I no longer have. As long as I pick the right phone the app installs just fine
  12. zuben el genub

    zuben el genub Well-Known Member

    Why is there a price difference between Appbrain and Market? There was a $2 price difference on one book.
    Also, does Market have a list where you can store what you are interested in until you buy or install it?
    Thanks
  13. Steven58

    Steven58 Reformed PH VIP Member

    My uneducated guess is that the market is looking under rom version and seeing all sorts of things it doesn't recognize. Mine's Liberty v 1.5. I'd like to see us get that under control and fix it to see if it works. I forget what it's supposed to say.
  14. nycebo

    nycebo Well-Known Member

    Having the same issue. Rooted DX, running stock with bloatware removed, though I have tried a custom ROM in the past. I'm wondering if it is worth the trouble of SBFing back to stock, upgrading, seeing if android market push works, and then methodically removing bloatware and customizing to see if the market still works. Meanwhile, chrome to PC works but has a lag as mentioned above.
  15. nycebo

    nycebo Well-Known Member

    Alright, you guys won't like this, but I did a data erase and restore and it fixed the issue....on stock. I'll root now, then try another download, then customize some more, then try another download and report back. Bah humbug but at least it's working.
    EarlyMon likes this.
  16. EarlyMon

    EarlyMon The PearlyMon Moderator

    Those are survivable with backups. Glad you nailed it!
  17. A.Nonymous

    A.Nonymous Well-Known Member

    I somehow partly fixed it. The Market now says that my phone checked in with it today. Pushing apps does not work though. Oh well. I didn't have this functionality before and never missed it. And it does work on the Nook so it's kind of a wash I guess.
  18. nycebo

    nycebo Well-Known Member

    Okay, I'm rooted, removed bloatware and customized to my liking. Market is pushing apps OTA. It was a hassle, but I'm good to go. Was it worth it? Probably not but I hate the idea of functionality not working as it should for my DX.
  19. GrenW

    GrenW Well-Known Member

    Tried to install an app and it said that 'this item is not available on your carrier' when I tried to select my phone in the app install pop-up screen. The very same app installed fine the usual way. Rooted with custom rom. Maybe that's why it doesn't work with my 'carrier'

    Hmm... tried another app and this one worked fine. I guess there are still some teething problems
  20. Clementine_3

    Clementine_3 Well-Known Member

    Mine shows only about 1/4 of my apps (market on phone now isn't showing everything either!). My phone is showing the right info in settings etc., it's just not pulling everything. (stock Moto Droid)

    When I access the site through Chrome I get the "this is not the page you want" message and have to click to go there anyway. Big red line through https. FF just takes me there. You'd almost think Google would let me in! Hello!

    So far I'm not impressed, and I haven't even tried to install anything yet!
  21. chrlswltrs

    chrlswltrs Well-Known Member


    I have been using the site on my Cr-48 laptop (Chrome OS, no other browser on it) without any problems
  22. EarlyMon

    EarlyMon The PearlyMon Moderator

    SOLUTION TO THE MISSING DEVICE ISSUE FOUND!

    From -
    Unable to install apps. There are no Android devices associated with this account. - Android Market Help


    • Log on to http://market.android.com
    • Click on My Account
    • Click on Recovering Password
    • Enter password (to validate it's you)
    • Under the SMS Section:
      1. Click Edit
      2. If phone number is there - remove your phone number - if number not there, go to step 6
      3. Save
      4. Sign Out
      5. Sign back in, go back to same page as needed - or if prompted:
      6. Enter and save your phone number
      7. Sign out
    • Log on to http://market.android.com
    • Click on My Market Account
    • Click Settings tab - your phone should now appear!


    w00t! :) :) :)

    (thanks also to Kelmar for the Tip suggestion!)
    jroc and chrlswltrs like this.
  23. eriku16

    eriku16 Active Member

    Does not work if your phone is registered to your ISP's Google Apps email (yourname@domain.com). If I register my phone to my gmail email account, web market will work. But will I lose all paid apps if I do this.
  24. rizzla

    rizzla Well-Known Member

    Google must of changed something because now I can see my device without the solution but it still wont download apps, you just get a message saying "you have not opened the android market recently on this device. Please open it and try again" when you select your device and the install button is grey out on the pop up menu. I used the market today, before and after trying it, so god know what they are talking about. Maybe google shouldn't let their programmers leave the building until they get it sorted.
  25. Psitech

    Psitech Member

    I get the same error (you have not opened the android market recently on this device. Please open it and try again). It recognizes what apps I've already installed, but won't let me download anything from the web due to this error. I opened market on my phone and downloaded a random app, but this didn't help. I still get the same error from the webstore.
Loading...

Share This Page