speakerphone active by defaultSupport

Last Updated:

  1. 323elliot

    323elliot New Member

    My 2 week old samsung galaxy s2 is defaulting to speaker whenever i make a call, although its not a major problem is does get very annoying ive done some research on other forums and such, but there hasn't been any answers that have solved the problem, that i have found anyway. Has anybody else experienced this problem, or even better does anybody have a solution, ive checked through every menu on settings, and stopped voice command running but the problem still persists. Thanks for any and all help

  2. I've just found the same thing in the last couple of days. I'm sure my phone didn't do that before.
  3. dimus101

    dimus101 New Member

    Mine too, in the last week or so. Also at the same time the screen rotation has started to be constantly on too even when toggled off. The lock screen has started rotating too.
  4. mrmarkgray

    mrmarkgray New Member

    My S2 also defaults to speakerphone and constantly does the screen rotate thing.
  5. quasar551

    quasar551 New Member

    My S2 also defaulted to speakerphone when accepting calls. At this point I don't know what caused the change of behavior. After a reboot it went back to normal behavior.
  6. s14.2nv

    s14.2nv New Member

    I also have the same issue. Whenever I call someone or receive a call from someone my sg2 will default to speaker phone.

    Does anyone have a resolution for this problem??
  7. postdunous

    postdunous New Member

    I've had the same problem and a host of other random weirdness ever since yesterday morning when I tried to connect it to the wi-fi network at work and then installed two alledged samsung updates: One was 'samsung apps' and another 'UNA Service' both with Samsung logo on them. No idea if my problems are related to these updates but its a bit of a coincidence. I'm now not sure however whether to delete the updates or whether that may mess up the phone even more : ( My problems include:

    -ridiculously long and random vibrating
    -it thinking there's a 'high power usb device attached when there's not and my battery losing all power in a few hours
    -Car mode activating (I don't even know how to do that myself!)
    -Voice commands activating when Im in a silent room just about to go to sleep

    If anyone from samsung is reading this Im seriously thinking of ditching it for the new Iphone when it comes out if this randomness persists!
  8. mickv

    mickv New Member

    I dont suppose anyone has got anywhere with the faults listed above?

    I have had my SGS2 for two weeks and it has developed all the faults listed above.

    I moaned to Vodafone and they immediately said they would send a new phone.....I presume there is a big problem as they did it without any arguments!!

    The iphone starts to look more attractive samsung listen up!!! And I really dont want an iphone....
  9. skynet99

    skynet99 Member

    this is happening to me as well. This phone is starting to p*** m
    e off. I have already begun to regret getting it!
  10. shibbysteve

    shibbysteve New Member

    I have had it happen to me but hear this...... me ear peace speaker is being made default to lol ???????? confused.com so u miss calls and sms
  11. stiglet

    stiglet New Member

    Hi people.

    I have the same symptoms as described here. Car mode will activate, speaker phone will default on every call and voice activation pops up. I'm certain this is related to the the micro usb. Not sure if its dirty or has a loose connection, but blowing on the port seems to solve the problem temporarily but the fault still occurs after time.

    I think a possible solution is a cover for the usb port, but cannot find one online anywhere.
  12. daveeeeee

    daveeeeee New Member


    i had the same problem yesterday - speakerphone always on, lock screen rotating, auto-rotate switch doesn't stop screen auto rotating, Car Mode randomly starting.

    found the solution! for me anyway...

    i had installed a GPS navigation app called Sygic Aura - this is what was causing the problem. I uninstalled it and everything went back to normal. according to another thread i found, another app does the same thing called Police Scanner or something similar.

    so basically -- have you recently installed an app that you might use in the car?? e.g. GPS navigation? some apps obviously don't implement a car mode properly and cause the problems above. try uninstalling them (one at a time if more than one) and see if the problems go away.
  13. retrorobert

    retrorobert New Member

    Same problem here. Had to uninstall all of the GO products (keyboard, contacts and launcher), since then, it appears to be working 'normally'.

    Although the GO Launcher is sxy, in my experience it really mucked up a lot of settings, including mounting USB when connecting to PC, KEIS, etc.
  14. jasivy

    jasivy New Member

    It works fine for me thus far after I ....

    > Double press the HOME button
    > It will bring you to a "Voice Talk" app (powered by Vingo).
    > Tab on "Driving mode" to turn on
    > Tab on "Call", speak into the mic of a person from you contact
    > If you speaker function is off, please turn it "ON" now
    > Then exit "Voice Talk", now make a normal phone call, the speaker mode should be off by now.

    Hope this would able to solve our problem. :rolleyes:
    hrealadam1 and nuhiheheart like this.
  15. chiki2852

    chiki2852 New Member

    SAMSUNG phones s**ks !! I jst bought a Galaxy S2 fone last month and already ma fone has strted hanging up...by default speakerphones get activated when a call is made....It doesnt strtup sometimes even after charging for 6hrs....It goes blank at tyms when we r using some applications...n sucha bad speaker quality.
    S2 is nt worth the price...they r selling it at.
    N on top of it samsung doesnt give warranty for the basic software problms too.
  16. nuhiheheart

    nuhiheheart New Member

    Jasivy, it worked!! Thank you! It was driving me CRAZY!! I had seen this app but always choose to close it out instead of setting it up. Once I finished set up and did as you suggested it was fixed! Awesome!!!:D
  17. greggebhardt

    greggebhardt Well-Known Member

    You spelling and grammer checker is broken, too!:eek:
  18. hrealadam1

    hrealadam1 New Member

    I was having the same exact issues as mentioned above. I have now fixed the issue. I'm hoping it is permanently fixed. I went in to the "Voice Talk" app under apps, opened it, then click on the far left button of the phone, the settings button, once inside of the settings display, scroll to the bottom and click on Voice Talk Settings and select it, there is an option called "Auto-start speakerphone", I unchecked it, and restarted my phone. Since then, it has resolved the issue. If it comes back, I'll be on here looking for answers.
  19. monty1923

    monty1923 New Member

    Tank u 4 da comment Steve Jobs, yo.

    Seriously though, I was having the same speaker phone and rotate problem for no apparent reason. I turned off the phone, restarted it, problems gone. Worked for me anyway.
  20. akashhari

    akashhari New Member

    hey hi,i did the same thing what you have told,but iam experiencing the same problem again,any other solution for this....
  21. weedtip

    weedtip New Member

    This worked for me. You have to make sure you restart the phone, though!

    Thanks Buddy!
  22. gahdaym214

    gahdaym214 New Member

    I had the same problem, when I would call my phone would automatically start on speaker. I went into the voice talk hit the menu scrolled down to voice talk settings and unchecked automatic speaker mode .. Problem solved!
  23. sandeeps

    sandeeps New Member

    I had the same problem . After removing the setting in voice talk, the speaker is not set when I receive incoming calls. But for all outgoing calls the speaker turns on automatically. What could be the problem ?
  24. mrqs

    mrqs Well-Known Member

    apparently this problem isn't just with samsung, as i got it with my htc sensation

    apparently there's an actual setting for defaulting to the speaker, so i figured i'd search google play for "speaker default" and voil
  25. nick1966

    nick1966 New Member

    I had the same problem, it was caused by a call recording app called call recorder pro,
    there was a setting in the app called AUTO SPEAKER which i had enabled, once i disabled it the phone didn't default to speakerphone.

Share This Page