Support Straight Talk Galaxy S2 and Amazon MP3 App

Discussion in 'Android Devices' started by crashsite68, Nov 9, 2012.

  1. crashsite68

    crashsite68 New Member
    5

    Nov 9, 2012
    3
    0
    5
    Male
    Professional DJ
    Howell, MI
    Anyone else have the Straight Talk SGS2 and having issues with Amazon MP3 App?

    It won't log me in, then at some point it did log me in and when I try to download anything I get "Network error, try again when you have a network connection. Error 70"

    I have internet and it even plays the song samples. All apps work great, except for this one, which works fine on my Samsung Tab and my old Samsung Precedent.

    I get a similar error when I try to download my cloud music.

    I contacted Amazon about this, but I'm curious if it's a problem with all Straight Talk SGS2 phones.

    Anyone else got issues like this?
     

    Advertisement
  2. crashsite68

    crashsite68 New Member
    5

    Nov 9, 2012
    3
    0
    5
    Male
    Professional DJ
    Howell, MI
    I forgot to mention that I uninstalled and reinstalled the app, tried turning the phone on and off... still doesn't work.
     
  3. zukaru

    zukaru New Member
    5

    Nov 25, 2012
    1
    0
    5
    Yessir. As a matter of fact, as selfish as it may be, Im glad Im not the only one going through this. No solutions on my end yet. Will keep you posted on if its an easy fix or impossible.
     
  4. tollhaus

    tollhaus New Member
    5

    Feb 11, 2013
    1
    0
    5
    Any solutions? I've had the same problem. When I click on Cloud (instead of Device) in the app, I get an error saying "A cloud player network error has occurred. Please try again. If the problem persists, contact Amazon customer service by tapping 'Contact us' below. Exception #151"

    This worked the first two days I had the phone (about two months ago), but hasn't worked since.

    Samsung Galaxy SII, Straight Talk.

    I've tried uninstalling and reinstalling. I've cleared the data/cache from two different places on the phone. I've registered my device on Amazon (by downloading the Amazon Appstore).

    Any thoughts?
     
  5. sowhat073

    sowhat073 New Member
    5

    Feb 22, 2013
    1
    0
    5
    got the same problem same phone and same plan
    do you think its a deal with straight talk?
     
  6. harinair

    harinair New Member
    5

    Feb 28, 2013
    1
    0
    5
    Anyone with this problem... Can you confirm the following:
    1. Is your phone rooted?
    2. Do you have a custom ROM installed?
    3. Is the time in the phone correct?
    4. Is there any app that interferes with Network operation? Examples: Adblock Plus, Anti Virus, etc
    5. Have you by any chance disabled the Trusted CA Certs in your phone? For this go to Settings -> Security -> Trusted Credentials....Do you have all the CA Certs enabled? Do you have VeriSign CA Certs (10 of them should be there).
     

Share This Page

Loading...