Swype 1.3.1.9274 not working on Jelly Bean


  1. gtbarry

    gtbarry Well-Known Member

    I was prompted to update swype this morning. I did so, and now everytime I select swype it closes automatically and I get the android keyboard. Anyone else having this issue?

    - Swype Beta is checked in Language & Input (android keyboard is selected and grey in this screen)
    - Choose Input Method screen. I select "Swype Beta". It flashes to Swype. Then reverts back to Android keyboard immediately
    - I have cleared cache, etc. and rebooted the phone. This brought me to the new swype EULA and activation process. Which I did successfully. I rechecked all settings.

    Jelly bean 4.1.2
    Swype 1.3.1.9274 (downloaded on 18 October, 2012)

    Thanks!

    Advertisement
  2. CHRISTEVAN

    CHRISTEVAN New Member

    I have the exact same problem. I did the update on my Nexus 7 as well, but didn't run into this problem.
  3. viperfan7

    viperfan7 New Member

    having the same issue on a rooted galaxy nexus, running stock firmware 4.1.2
  4. Digital Controller

    Digital Controller The Real Bass Creator Guide

    My Swype is acting fine on my GNex with a nightly of Cm10...sounds like a weird error, have you tried reinstalling swype yet?
  5. CHRISTEVAN

    CHRISTEVAN New Member

    It might be affecting only those with stock versions of Jelly Bean. I did uninstalled swype beta as well as the installer then reinstalled everything. Still no luck.
  6. gtbarry

    gtbarry Well-Known Member

    Uninstalled. Reinstalled. Reactivated. EULA accepted. Selected. Still crashing.

    Bombed them on twitter, facebook and youtube (that's what you get for not having any other way to get a hold of you). Let's see if we get a reply.
  7. lexluthor

    lexluthor Well-Known Member

    Try here too.
    Swype BETA for Android

    I know they read those forums.
    gtbarry likes this.
  8. The Greatjon

    The Greatjon New Member

    Same exact issue. I'm running Vicious JB (taken directly from AOSP months before Verizon decided to release the update) and Swype was fine until this morning when I upgraded. I can access all the settings, etc., but every time I try to actually switch to Swype, it flashes and then goes back to the stock keyboard. Considering how much they damage Swype with each update, this may be the final push for me to not use them anymore.
  9. gtbarry

    gtbarry Well-Known Member

    Thanks! I'm on them in the forum. They should have made this easier to find off their website so I wouldn't have taken the fight to twitter, etc.
  10. gtbarry

    gtbarry Well-Known Member

    Latest from swype:
    "We have been able to reproduce this in-house and are confident we know what the issue is.

    We are still investigating this but will keep this thread updated as we have more information.

    We'll reach out to you further if needed."


    In the meantime they are recommending:

    "you should be able to use Swype be disabling any apps that are in Android Settings > Accessibility."

    Which is only a temporary fix and I think (and hope!) they know that.


    Official Galaxy Nexus Jelly Bean Swype Issue Thread
  11. csx321

    csx321 Member

    If you're rooted, you can also temporarily move the stock keyboard files out of /system/app, and still use any accessibility apps and Swype. There are instructions in that thread on the Swype forum. That's what I've done for the time being.
  12. jghayes

    jghayes New Member

    I found that it is a problem with Lightflow. Go to accessibilty under settings and deselect Lightflow. Mine worked when I did this.
  13. csx321

    csx321 Member

    It's actually a conflict with anything that uses Android's Accessibility services. For me, it was the Augmented Smartwatch notification system for the Sony Smartwatch.
  14. gtbarry

    gtbarry Well-Known Member

    I don't personally believe good things will happen to swype's marketshare or credibility if they say "nothing else can use Accessibilty Services except us."

    This would make people choose between them and Tasker. Them and Light flow. Them and Talkback. Etc.

    A long term fix seems to be in the works/near future and can't be released soon enough for me.
  15. zebug

    zebug Well-Known Member

    Yep, once I disabled things in accessibility, swype started working. On a side note I love this forum. Figured I wasn't alone. Let's hope they fix this fast as I love my lightflow
  16. gtbarry

    gtbarry Well-Known Member

    currently swype has not posted a fix for this other than disabling everything else in Accessibilty Services. (Which I do not believe is a long term fix.)

    On the official swype forum someone mentioned this and it works:
    - under apps disable the Android keyboard
    - reboot phone and select swype.

    Worked for me and I have both swype and lightflow working.
  17. UncleMike

    UncleMike Well-Known Member

    Working here too.

    Edit: I take that back. While this did manage to keep Swype selected as the current keyboard, the accessibility issue that's the root cause of the problem was causing Tasker use of the accessibility service to fail, meaning it couldn't detect any notifications. After an hour or so trying to figure out why Tasker suddenly wasn't working as expected, I restored the previous Swype using Titanium Backup and Tasker functionality is back to normal.
  18. gtbarry

    gtbarry Well-Known Member

    Swype has gone mostly dark on this after staying mostly on top of this on the 18th when the issue broke???

    Last thing on their official forum was "ensure that all applications or settings that are in Android Settings > Accessibility are disabled/turned off." And how should that be considered a final solution?

    No word on an update or real fix? And demanding to be the only app or program running in Accessibility sounds somewhat unrealistic.

    Be nice to hear something current from Swype.
  19. Digital Controller

    Digital Controller The Real Bass Creator Guide

    I have always loved Swype, and usually they respond quickly to errors like this, it is kind of saddening that it has taken them this long to do anything about this issue. :(
  20. gtbarry

    gtbarry Well-Known Member

    Swype was really active on the 18th when this issue blew up on them.

    They had one more post on their official forum on the 19th.

    Then after my posting on the official forum (on the 22nd) about their silence, this is their current response:

    "We understand that this is a temporary solution and as I stated before we are still investigating the issue.

    On another note:

    Is anyone out there without apps that interface with accessibility experiencing this issue?

    Thanks!"
  21. tcat007

    tcat007 Well-Known Member

    No problems on Nexus 7 (not rooted). Updated on the 18th no issues. I don't have any apps listed in the accessibility section other than Talkback and Widgetsoid, and they are both off.
  22. gtbarry

    gtbarry Well-Known Member

    Alleged fix on the way. Posted on official Swype forum on 23, October.

    "Hi all!

    This has been fixed and will be delivered to you via an OTA within the next 72 hours!

    Feel free to respond with any questions you may have. Thank you all for your patience!"
  23. The Greatjon

    The Greatjon New Member

    So the update to restore basic functionality is great and all, but they changed the duration of the vibration back to the overly long setting, rather than the new&improved short vibration that was on par with the stock keyboard and softkeys.
  24. gtbarry

    gtbarry Well-Known Member

    I received the OTA update today. Everything is fine for me.

    I enabled my android keyboard and rebooted the phone. Android keyboard is back now.

    I have seen on their official forum that people are having issues with having two swypes installed after the update, removing of personalization/dictionary, auto spacing not working etc. I luckily have none of these.
  25. gtbarry

    gtbarry Well-Known Member

Share This Page