1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Tasker Help needed


Last Updated:

  1. BigknockHawk

    BigknockHawk Active Member This Topic's Starter

    Joined:
    Oct 30, 2010
    Messages:
    28
    Likes Received:
    4
    I am trying to set up tasks that will set my notification to "vibrate" between the hours of 9:30pm - 5:00pm the next day, from Sunday evening through Friday evening, so it does not ring while sleeping or at work, but vibrates. I also want it to be set to vibrate between 9:30pm - 7:00am from Friday evening through Sunday morning.

    I understand that I am going to have to set up multiple tasks for this. I started to do this:

    Set to vibrate from 6am-5pm M-F. Got that one set up just fine.
    Set to vibrate from 930pm - midnight every day of the week, but when I try to choose each (or All) weekdays, I get an error asking me to choose at least one month or day.

    Is this a bug? Any ideas of how to better accomplish what I am trying to do?:confused:
     

    Advertisement
  2. amlothi

    amlothi Well-Known Member

    Joined:
    Jul 23, 2010
    Messages:
    1,185
    Likes Received:
    201
    Yeah I get the same error when I select all days.

    I think the reason is, you don't need to add a day context if the event should happen every day. You only need a time context.

    If you select all Weekdays except Saturday, you don't get the error.

    Basically, you can't set a context for all days because that context will always be active, and that is pointless.
     
  3. chrlswltrs

    chrlswltrs Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    6,728
    Likes Received:
    1,790
    I just tried setting it up this way.

    You need 2 contexts
    1. Time 2130-1159
    2. Day - weekdays

    Then set your vibrate option

    Then make another profile
    1. Time 0001 - 0700
    2. day - weekdays

    Then set your vibrate option

    When you choose DAY, there is a drop down menu under months that says "month day" click that and choose week day, that should fix your error to choose month or day

    I got no errors doing this, There is probably an easier way without a 2 minute gap, but I have been drinking and I know this works :D
     
  4. chrlswltrs

    chrlswltrs Well-Known Member

    Joined:
    Nov 12, 2009
    Messages:
    6,728
    Likes Received:
    1,790
    You do need to select a day if you only want it on weekdays, you just have to change from "month day" to "week day" when picking days
     
  5. BigknockHawk

    BigknockHawk Active Member This Topic's Starter

    Joined:
    Oct 30, 2010
    Messages:
    28
    Likes Received:
    4
    Also, does setting the notification to "vibrate" take care of the phone ringer? I had a task set up last night, correctly I think, and tested it by calling my phone. It still rang instead of vibrating. The test was done while the task was on and running.

    Do I need to choose something different than just "Vibrate"?

    I really appreciate your help!
     
  6. amlothi

    amlothi Well-Known Member

    Joined:
    Jul 23, 2010
    Messages:
    1,185
    Likes Received:
    201

    All weekdays = 7 days a week.

    You don't need a DAY context if you want it to happen every day.


    Hawk,

    There are a few Vibrate tasks. I think what you want to use is "Silent Mode". After you choose silent mode, you can choose On/Off/Vibrate in the options. That will silence the ringers and put it in Vibrate only.
     
  7. BigknockHawk

    BigknockHawk Active Member This Topic's Starter

    Joined:
    Oct 30, 2010
    Messages:
    28
    Likes Received:
    4
    Ok, thought I had it, but no such luck. Here is what I tested tonight:

    Profile called Vibrate:

    Time: From 21:30 till 23:59
    Silence Ringer
    Vibrate

    I let the phone cycle past 9:30 pm and then called my phone. Still had it ring with my ring tone.

    So then I thought I would add a day context. I chose Sunday, Monday, Tues, Wed, Thurs and Friday (as I mentioned before, it will not allow me to choose all days).

    Tried it then and, still heard ringtone.

    What am I doing wrong???
     
  8. UncleMike

    UncleMike Well-Known Member

    Joined:
    Nov 15, 2009
    Messages:
    2,319
    Likes Received:
    482
    Silence Ringer will only have an effect at the time the phone is ringing. Ringer Volume is probably what you want to use.
     
  9. BigknockHawk

    BigknockHawk Active Member This Topic's Starter

    Joined:
    Oct 30, 2010
    Messages:
    28
    Likes Received:
    4

    Ok, I'll give it a shot and let you know.

    Thank you -
     
  10. BigknockHawk

    BigknockHawk Active Member This Topic's Starter

    Joined:
    Oct 30, 2010
    Messages:
    28
    Likes Received:
    4
    Ok, so I got my profiles to work for turning off my ringer and setting to vibrate. Thank you very much UncleMike for setting me on the right path.

    Now I am trying to use Tasker to do what JuiceDefender does. Shutting my connectivity down during the day with the exception of 1-2 minutes every 20 minutes or so. I am trying to follow the steps on this web page:
    Periodic Data Check (Juicedefender Replacement) - Tasker Wiki
    but am stuck on the first profile. When it says to add a "Stop Task", I can not find on in Tasker on my phone.

    Am I not looking in the right place? I tried just adding another task, thinking that since the first was the enter task, that would be the exit task. No, it isn't.

    Help?:confused:
     
  11. amlothi

    amlothi Well-Known Member

    Joined:
    Jul 23, 2010
    Messages:
    1,185
    Likes Received:
    201
    The "Stop" command can be found like this: Add Task (+) > Tasker > Stop

    That said, I haven't used the Wiki to do this. I kind of designed my own solution below.


    Profile: [Profile Name]
    Time: From 07:00 every 30m Till 23:30

    This controls the time the profile is active. It is set to turn on every 30 mins to get updates.

    Enter Tasks:
    A1: Perform Task [ Name:Mobile On Stop:Off Priority:5 ]
    A set list of commands I use whenever turning mobile data on

    A2: Auto-Sync [ Set:On ]
    A3: Wait Until [ MS:0 Seconds:0 Minutes:3 Hours:0 Days:0 ] If [ %ONLINE ~ 1 ]
    I have another profile that sets the %ONLINE variable to 1 when mobile data is connected. This way, I know it will always wait until I have a connection before the sync timer starts.


    A4: Wait [ MS:0 Seconds:0 Minutes:2 Hours:0 Days:0 ]
    A5: Perform Task [ Name:Mobile Off Stop:Off Priority:5 ]
     
  12. BigknockHawk

    BigknockHawk Active Member This Topic's Starter

    Joined:
    Oct 30, 2010
    Messages:
    28
    Likes Received:
    4

    Hmmm, I tried this but got the error saying that "Mobile On" was not a valid task. When setting up this task are you choosing from the Action category of "Tasker" to choose the action "perform Task", or "Net" to choose the action "Mobile Data" or "Mobile Data APN"?
     
  13. amlothi

    amlothi Well-Known Member

    Joined:
    Jul 23, 2010
    Messages:
    1,185
    Likes Received:
    201
    I have a task named Mobile On. In it are a set of commands that include turning on mobile data, but you could just replace it with whatever mobile data on command you need to use. I recommend downloadng apndroid and using that plugin with tasker.
     

Share This Page

Loading...