Tried to root , now I'm facing MANY problems. PLEASE help , Cant use my phone.


Last Updated:

  1. lovexXxBroken

    lovexXxBroken Member This Topic's Starter

    Joined:
    Jan 7, 2012
    Messages:
    12
    Likes Received:
    1
    I tried to root my Samsung Galaxy S2 using Odin , well halfway through I noticed that the green bar wasn't moving any and went to check my phone. It said recovery.img and wasn't moving on the Odin. Well , my phone is currently at a black screen saying
    "Firmware upgrade encountered an issue. Please select recovery mode in Kies and try again."

    The problem being , Kies isn''t recognizing my phone. I've tried uninstalling and reinstalling the software , downloading all of the drivers for the phone again through Samsung. & Kies says to reboot my phone , but I can't without the same stuff coming up.

    Basically , I'm stuck at this screen and nothing I have tried is seeming to work . Please help , I'm desperate to at least have a phone that's working again :(
     

    Advertisement
  2. nyydynasty

    nyydynasty Well-Known Member

    Joined:
    Sep 13, 2010
    Messages:
    955
    Likes Received:
    171
    i assume you dont have a USB Jig to get into download mode. Pull the battery out and put it back in, then hold the vol down button and plug in the USB cable. You should see the phone boot into download mode (press vol up to enter DL mode).

    from here, you can open odin and flash whatever you need.
     
  3. lovexXxBroken

    lovexXxBroken Member This Topic's Starter

    Joined:
    Jan 7, 2012
    Messages:
    12
    Likes Received:
    1
    it's in download mode , but i can't get it out to do anything because of the messed up firmware thing....


    [​IMG]
     
  4. nyydynasty

    nyydynasty Well-Known Member

    Joined:
    Sep 13, 2010
    Messages:
    955
    Likes Received:
    171
    odin should detect the phone while its in download mode, no matter how screwed up the phone is. Your best option is probably to flash back to stock and start over. Do you have the i777 or the skyrocket?
     
  5. jerofld

    jerofld Fixing stuff is not easy VIP Member

    Joined:
    May 10, 2011
    Messages:
    7,688
    Likes Received:
    4,273
    Also, as a note...sometimes flashing firmware takes an excessively long time. It's best to leave it be. If it's hung up after 20 minutes, then I'd get concerned. But a halted progress bar for 5 minutes or so isn't uncommon.
     
  6. lovexXxBroken

    lovexXxBroken Member This Topic's Starter

    Joined:
    Jan 7, 2012
    Messages:
    12
    Likes Received:
    1

    Odin is recognizing the phone , Kies won't connect with the phone.
    i777 or SkyrockeT? Honestly , no idea. I feel so stupid :/
    Any tips on flashing back to stock , steps??


    You guys help is MUCH appreciated.
     
  7. lovexXxBroken

    lovexXxBroken Member This Topic's Starter

    Joined:
    Jan 7, 2012
    Messages:
    12
    Likes Received:
    1
    It's basically stuck in ODIN mode....
     
  8. nyydynasty

    nyydynasty Well-Known Member

    Joined:
    Sep 13, 2010
    Messages:
    955
    Likes Received:
    171
    you dont need Kies to flash your phone. If you have an odin-flashable file, thats all you need. I need to know if you're phone is the original GS2 or the newer skyrocket. They have different software that aren't compatible with each other. if you pull the battery and look at the sticker on the phone, it should tell you the model number. It if says "SGH-i777" then you have the original GS2.

    based on the picture you posted, it LOOKS like the skyrocket because of its size but I can't be sure because they both look similar from the outside
     
  9. lovexXxBroken

    lovexXxBroken Member This Topic's Starter

    Joined:
    Jan 7, 2012
    Messages:
    12
    Likes Received:
    1
    My model number is SGH-T989

    Any way you could direct me to a ODIN flashable file that will actually work? I can't seem to find one.
     
  10. nyydynasty

    nyydynasty Well-Known Member

    Joined:
    Sep 13, 2010
    Messages:
    955
    Likes Received:
    171
  11. yosiraz

    yosiraz New Member

    Joined:
    Apr 27, 2012
    Messages:
    1
    Likes Received:
    0
    I had the same issue - tried to root it and in the half way of the installation of the recovery via Odin it stuck and didn't finish.
    After working many hours I found the solution which was SO simple - I tried to to use another computer and it worked great and finish the recovery flashing in few second....
    The problem was in my computer. if you are facing such issue make sure not to turn off the phone - leave it in the download mode, then move to another computer, load the odin again and flash the recovery again - it will work.
     
  12. jefboyardee

    jefboyardee Well-Known Member

    Joined:
    Jan 18, 2011
    Messages:
    5,032
    Likes Received:
    1,352
    This is a classic episode of Why I Won’t Root.
     
  13. danaj

    danaj Well-Known Member

    Joined:
    Dec 20, 2010
    Messages:
    723
    Likes Received:
    245

Share This Page

Loading...