1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Unable to connect to PC through Kies or My ComputerSupport


  1. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    When I try to connect my Galaxy to the computer either through Kies or by just plugging it in the computer does not recognize my device. The following message comes up on my phone regardless of which connection method I choose. "PC connection available only on idle screen. Close running applications".

    The only thing I have running that I know of is the "weather widget" which is part of beautiful widgets. Can I get a list of applications running on my phone somehow? Is there a way to turn the weather widget off? I am assumming that that is the problem. Anyone else out there have similiar difficutlies hooking up to Kies or just your PC with the same kind of message?

    Any comments/suggestions would be appreciated.

    Thanks for reading my post.

    Advertisement
    :
  2. singsong

    singsong Member

    I had the same issue before, but I manually uninstalled the Kies, including cleaning up all of the Kies-related registry settings; downloaded the latest version of the Kies and installed it. After that, my phone gets discovered by the Kies properly. Also, you need to mount the USB connection in order to access the phone's memory. If you are trying to use AndroidSDK or Odin, you must connect the phone with the USB Debugging option enabled.
    I hope you get your problem fixed. ^^
  3. devonblue4u

    devonblue4u New Member

    I found that some aftermarket data cables are just power cords. They don't sync data. The other issue is using any other launcher besides TouchWiz. It wont sync to Kies unless you use it. Or try pulling the external SD while unplugged, unmounting the internal SD unplugged, then remounting the internal SD while plugged in. This may help re-install the usb drivers.
  4. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    Thank you for the suggestions. Anyone out there have any other ideas, so far, I haven't had any luck.
  5. NZtechfreak

    NZtechfreak Well-Known Member

    Few suggestions:

    First, are you on 2.1 or 2.2? I believe 2.2 has sorted the Kies and LauncherPro connection issue, otherwise use Home Switcher (or a similar app) to change back to TouchWiz and then try connecting.

    If you have no joy there then enable USB Debugging (in Settings--> Applications --> Development), then try connecting to your computer (not Kies). If the phone drivers have not been installed it should install them on making this kind of connection.

    Make sure you are on the latest version of Kies. I found it easier to go to the internet and do a fresh install of the latest version, rather than try to update within Kies (it kep failing, if yours will update from Kies that is the easiest thing).


    Finally, what is it you want Kies for? I don't use Kies at all, and I struggle to see what useful purpose it could have that can't be achieved with other (much better and easier) softwares. If there is a particular thing you want to do within Kies, then myself or others can probably give you an alternate method to accomplish your ends.
    mapleleaf-mick likes this.
  6. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    Thank you for your response NZtechfreak. In answer to your questions, I am on 2.1. I have downloaded "Home Switcher" and tried to hook up to my computer using touchwiz, no success. The last time I was on my PC and brought up Kies, I hit the update button and it updated my version of Kies to the most current. Before and after updating Kies, I got the same message (see my original post). I have tried unmounting and remounting my external SD card. For some reason, when I went into the SD card menu, it did not show that there was one in there. Strange. Now my phone does recognize the external SD card but it has not made any difference when trying to hook up to my PC.

    As you mentioned NZtechfreak, I am quickly getting the impression that Kies is a piece of s**t and if you don't really have to use it, forget about it. I guess I would be satisfied if I could sign on to my PC and have it recognize the phone as an external device/storage. With that, I could load songs, pictures etc. On the other side, I would like to use Kies to synch contacts and calendar info from Outlook. What about downloading software etc. from AppBrain, can you do that and can you synch with AppBrain without using Kies. Do I not need Kies to download 2.2 on to my phone when it finally comes out here in Canada?

    NZtechfreak, I will try your suggestion of enabling USB Debugging (in Settings--> Applications --> Development) and let you know how it turns out.

    Once again thanks everyone for your assistance/suggestions.
  7. NZtechfreak

    NZtechfreak Well-Known Member

    You don't need Kies to sync Appbrain.

    Connecting it in debugging mode should install the drivers needed to recognise the phone in Mass Storage mode. Once you've connected and the drivers are installed try turning off debugging, and then go to your homescreen (in LauncherPro or TouchWiz, either will work for this) and connect in Mass Storage mode (chosen in Settings --> Wireless and Network --> USB Settings).

    Have never tried syncing from Outlook with Kies, having stopped using Outlook a couple of years ago, and stopped using Kies immediately. You can export all your contacts in Outlook into as a .csv file and then import that into Google and sync with Google to retrieve them (of course you lose contact pictures in that case, and some of the data may not survive the sync entirely intact, but you'll get the bulk of what you need).

    Connecting to Kies for the 2.2 upgrade is one use I can see, although I would update with Odin instead once the official firmware is available somewhere like XDA-developers (but thats a whole other story, for now suffice to say that you don't need Kies for firmware updates either).
    mapleleaf-mick likes this.
  8. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    Well, I have tried everything. I set it up for debugging. My PC running Windows 7 gave me the message basically no drivers installed. I tried it in "mass storage" same thing. I turned off my widget locker and ran under TouchWiz still no luck. I have no idea where my drivers went. I had this phone working off both Kies and my PC a couple of weeks ago. The only thing I did was update Kies but when I did that, my phone was not attached. I have tried to hook my phone up to other PC's and I get the same message no driver found. Is it possible to check to see if I have drivers installed on my phone? I am assumming that there are drivers installed in Fies but yet, I can't get anything under that as well. I am starting to get real p**sed off with this phone. This is basic shit. I have never had problems hooking any of my previous phones to my PC. There must be something going on that I am not aware of. Any other suggestions?
  9. NZtechfreak

    NZtechfreak Well-Known Member

    So in debugging mode you connected and it didn't install drivers, then you disconnected and tried Mass Storage and it didn't work? When you tried to connect in Mass Storage did you pull down the notification tray and press on the USB notification and choose to mount the memory? I should have mentioned that last part before, but its handled differently in 2.2 and I forgot sorry.

    Perhaps also try this. Its a link to an XDA thread that has the drivers apparently.
    mapleleaf-mick likes this.
  10. NZtechfreak

    NZtechfreak Well-Known Member

    Any luck? Or is your SGS in a thousand pieces by a wall somewhere?
    mapleleaf-mick likes this.
  11. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    Love it. Good on ya Mate.......:) Haven't had a chance to try out your recommendations yet. I will tonite though and I will post my successess or failures..........:(

    P. S. Do you have any superglue, at least the screen didn't break......:D

    Thanks again NZtechfreak for all your assistance.
  12. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    Well, I tried to attach the phone in debugging mode again with no results. (I guess I was just hoping that something changed overnight. No luck.....:mad:

    I then tried to connect with the phone in Mass Storage and I pulled down the notification tray and changed the USB connection to mount the memory. Still no luck although I did get a different error message that said "problems installing drivers contact the manufacturer".

    So now, I am going to try the link provided to the XDA thread that maybe has my drivers. Will update once I have tried that.

    Once again thanks for your patience and assistance.
  13. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    Well, I went to the XDA thread and downloaded the drivers. When I went to execute the .exe file, it gave me a message that Samsung drivers were already installed on my machine and did I want to continue. I said yes and away it went. After reinstalling the drivers, I went in and uninstalled Kies. I did that in case that was causing problems with my PC recognizing the Galaxy. I then attached my phone in mas storage mode and mounted the USB. Gave me the same message "device not recognized" I went into my PC under "control panel" and checked the installed programs etc. and sure enough, there were the Samsung drivers. So I am not sure where to go from here. It would appear that my PC has the drivers installed. Why then would it not recognize the phone? I am wondering if I should reinstall Kies and see if that makes any difference.
  14. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    Well I uninstalled Kies and then went to the Samsung site and reinstalled Kies. Tried to hook my phone up through Kies by setting up the USB connection on my phone to "use Kies" no success. So now the question, where to from here. Is there something wrong with my phone? With my internal storage?, my cord?, my USB connection in the phone? My phone is registering on the computer else it would not give me a message plus I get the sound from my PC when I connect it as well as a message. Have I come up with yet another "brand new problem" wtih the Galaxy. I sure as hell hope not.
  15. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    I took my Galaxy to the vendor and asked them to plug my phone into one of their computers to see if they could get it to work. they plugged it in and up came the menu to ask how I wanted to open up the external drive. We set it for Mass Storage and mounted the drive and it worked perfectly. :eek: I then went to another computer and plugged it in and it actually loaded drivers from the phone to the PC and then I was able to access the phone (and it showed correctly under windows explorer) as an external device and see all the files etc. Now I was getting really pissed. this damn phone was making me look like a fool. they kind of looked at me like I was crazy as if saying how could it not work for you at home. the only thing I can think of was their two computers were running XP the three machines I tried it at home were running windows 7. I am thinking I will go home uninstall all the drivers on my machine as well as Kies and then just try to plug my phone in and see if it loads drivers from the phone. make sense?
  16. mapleleaf-mick

    mapleleaf-mick Well-Known Member

    I came home uninstalled drivers, Kies and plugged my phone in using exactly the same process that we used at the vendor, same message (device not recognized) came up. Now I was really pissed. Then I read on one of the other threads that an individual haqd just tried a USB port on the rear of his machine rather than the front. I had previously tried different USB's on my PC but it had made no difference. So I said to myself, myself give it a shot. Plugged into the rear of my PC and instantly the PC loaded drivers from the phone and it came up just like it was supposed to. It was in mass storage mode with the drive mounted. Great, I could not move stuff from my PC over to my phone. Then I got frisky and decided to download Kies and see if that would work. Did the task and then plugged in my phone. Told me to change from Mass Mode to Kies. I did that and immediatly Kies recognized my phone and I was away to the races. For the life of me, I cannot figure out what the hell is going on. My front USB ports work fine with everything else. My only concern is that I don't trust this fix. I hope it is permenant but working with this phone makes me think otherwise. Anyway, Thanks everyone for their assistance I could not have done it without you.
    NZtechfreak likes this.
  17. NZtechfreak

    NZtechfreak Well-Known Member

    Glad to hear it seems sorted (at the moment anyways, hopefully you're all good to go now). Strange about some USB ports not working though, wouldn't have thought of that, good to know for future troubleshooting assistance.
    mapleleaf-mick likes this.
  18. NISMOFO

    NISMOFO Member

    I would like to connect mine and drag and drop files from PC to phone or visa versa. I have samsung kies and it's crap, so let's not even talk about that.

    But my question is, can I only move files from my external memory card on the phone....what about the internal memory card?

    Also, I see the settings for unmounting the internal memory card.....is that necessary to do before connecting to the PC via USB?
  19. NZtechfreak

    NZtechfreak Well-Known Member

    Both drives will show up, if you select to mount with your phone connected you will be able to access both.
  20. NISMOFO

    NISMOFO Member

    Okay thanks for the info.

    So i plug the phone into the laptop and select "Mass Storage" (which has Kies on it, and works fine)....but I don't want to use Kies of coure. I want to connect like an external HD.

    It looks like it's going to install drivers, but then it fails to recognize my phone. I have tried USB ports on both sides of the laptop.

    I have also tried selecting the USB Debugging.

    I'm running windows Vista. Does this matter?

    My friend has 2.3 on his DroidX. Has never connected his phone to a PC before today. Plugged it in, and he had an option for "PC Mode". It instantly recognized his phone and treated it like an external HD. I'm not sure if this is his phone, or 2.3 that allows him to do this?

    Attached Files:

    • USB.jpg
      USB.jpg
      File size:
      29.1 KB
      Views:
      1
  21. NZtechfreak

    NZtechfreak Well-Known Member

    Its his phone I would think.

    What firmware are you on?

    When you select USB debugging and plug the phone in does it start to install the drivers (do nothing else while its happening)?

    What version of Windows/Mac/whatever are you on?
  22. NISMOFO

    NISMOFO Member

    When I plug in the phone........I'll click "Mass Storage", it says "Installing device driver software". It looks like it's installing and then it says:

    Device driver software was no successfully installed
    Please consult your device manufacturer for assistance getting this device installed.
    USB Mass Storage Device Failed

    The phone itself says USB connected though. And it asks me if I want to mount or dismount it.

    I don't see any firewall blocker coming up at all, but I am on my work PC.....so hopefully I'm not wasting anyone else's time here.

    Laptop:
    Vista SP2 32-bit

    Phone:
    Samsung Captivate (not rooted)
    2.1 -update1
  23. NISMOFO

    NISMOFO Member

    I GOT IT CONNECTED!

    Page 136 of the User Manual:
    http://downloadcenter.samsung.com/c...SGH-i897ATT-Captivate_English_User_Manual.pdf

    This seems incrediblity obvious, but rather than having it set to "ask on connection"...I changed it to mass storage. I'm an idiot. It installed the drivers instantly and connected right after.


    From the Home screen, touch
    ➔ Settings ➔
    Applications ➔ USB settings ➔ Mass storage.

  24. NISMOFO

    NISMOFO Member

    Never mind. This did work, and I tried it one more time and now I can't get it to connect again. Go figure. I tried setting to back to ask connection then mass storage...nothing works again.
  25. ayongkot

    ayongkot Well-Known Member

    connecting to kies really depends on firmware. i use windows 7 home premium, 64 bit and latest kies version. i tried flashing the latest xxjpu firmware and the phone won't connect, i had to flash back xxjpo because of other issues aside from kies and now i can easily connect to kies.
Loading...

Share This Page