[Verizon] Navigation Button Lag

Last Updated:

  1. KuroTsubasa

    KuroTsubasa Well-Known Member

    I've recently flashed a few custom roms on my new Galaxy Nexus and experienced some button issues.

    On both AOKP and LiquidSmooth, I've had an issue where the Navigation Bar (buttons at the bottom of the screen) lag or freeze. Sometimes this is brief and hardly an issue, other times the buttons stay frozen for several minutes. The rest of the phone, and any apps continue to work fine (minus the ability to go back/home).

    This never happened at all while running the stock rom, but both of these custom roms experienced this issue. I've done some searching but I can't find anything similar to it.

    Has anyone else had this issue or have any suggestions on how to fix it (besides an obvious workaround like Button Savior, etc)?

    Edit: It by using the developer tools, it seems that the bottom portion of my touchscreen periodically fails. Going to have to request a replacement.

    *Edit2: Reflashed a nandroid of the stock rom and utilizing the developer tools shows everything is fine. I can draw lines all over the nav buttons whereas on the custom rom it cuts out so much that I can hardly draw *a* line over that area.

    Guess I'm back to my original question, has anyone had this happen before? Should I still consider getting this phone replaced? I have no idea why the touchscreen would function properly under one rom (stock) and not others.

  2. jbdan

    jbdan Well-Known Member

    I've actually never heard of this specific issue.

    When you are flashing LS or AOKP, are you doing a full wipe in clockworkmod recovery (cwm)? Or are you doing everything through ROM Manager (RM)? If you are doing it through RM, try manually wiping in CWM. Do a full wipe: wipe data, wipe cache partition, wipe dalvik (in advanced), format system (in mounts and storage).
    colchiro likes this.
  3. KuroTsubasa

    KuroTsubasa Well-Known Member

    That's why I'm a little worried that it could be the phone. The first rom I flashed (AOKP) I wiped data, cache, and dalvik cache out of habit from my last phone (LG Ally). When I flashed LiquidSmooth I only did a data wipe since I noticed my recovery was wiping the cache as well during the operation.

    I didn't bother wiping dalvik cache this time, but it didn't seem to have caused any issues (boot loops, app crashes, etc). I've never *manually* wiped /system, since presumably it does so automatically when flashing an update zip for a new rom. I might try doing a full wipe of everything sometime. Too busy today though, but thanks for the suggestion.

    After flashing back to a nandroid of stock last night for testing, I returned to the nandroid backup of LiquidSmooth and haven't played with it enough to tell if the issue is still there or not.

    It hasn't happened yet, but I know the moment I say this it's going to act up again. I've got another few test ideas for when it does happen to check if it's the touchscreen or just a software issue. I've also got to convince my girlfriend to let me throw a custom rom onto her Galaxy Nexus and see if she has any similar issues.

    Edit: Still happens, and when it does it seems that that section of the screen is dead no matter whether the nav buttons are under it or not. I rotated the screen while it was happening and that edge still had the same non-responsive issue.

    Still odd that it never happened while on the stock rom. Guess I should go play with stock more.

    Edit2: Still unable to reproduce the issue in the stock rom. I have however noticed that both AOKP and LiquidSmooth run Franco Kernel. Going to try flashing a different kernel underneath and see if that has any effect on the matter.

    Edit3: No effect. Still have the issue.
    kool kat2 and jbdan like this.
  4. jbdan

    jbdan Well-Known Member

    The newest LS has franco, but aokp uses faux kernel. Maybe you're on to something why don't you try the stock kernel with either LS or AOKP. You can get it here ---> :)

    That is the 4.0.4 kernel if you've been flashing the latest AOKP and LS based on 4.0.4
  5. KuroTsubasa

    KuroTsubasa Well-Known Member

    I must have been reading outdated info about AOKP being Franco Kernel (it was an article about an older version, and may have been talking about manually putting them together).

    I've tried several kernels, including the stock one you provided, but none made a difference. I tried another rom, Apex, but it still had this issue. It did seem to happen a little less, but that could just be a coincidence.

    Even on the stock rom I have a small, ~1mm, deadzone on the bottom of the screen. On the stock rom however it stays this size and doesn't effect anything. On any other rom I've tried the deadzone periodically stretches to about 1mm over the top of the nav buttons.

    If you try to swipe back and forth over the nav area, it cuts in and out, generating a lot of "touch" events. Other times it cuts out completely and after you cross over the threshold it's like you're not touching the screen. Completely unresponsive, etc.

    Anyway, that's all I've got for now. Thanks for the help, let me know if you've got any other suggestions. In the meantime I'm seriously considering sending it back. I've only had the phone for about a week and a half though, so I've still got some time to decide.
  6. kool kat2

    kool kat2 Well-Known Member

    flashing franco kernel fixed this for me. i thought i had a defective phone. i was on aokp b35 and the problems disappeared after i flashed the kernel. exact problems you were describing.
  7. KuroTsubasa

    KuroTsubasa Well-Known Member

    No luck. I tried b36 with the Franco Kernel and still had the same issues. Thanks for the suggestion though.

    Tried the same setup on my girlfriend's Galaxy Nexus and as expected, it worked fine. Going to be sending my back at some point to get a replacement. =(
  8. NSutherl

    NSutherl Well-Known Member

    My "Recent Apps" navigation button has lagged since day 1, pre unlocking/rooting. I hoped new ROM's and/or Kernels would fix it, but alas, none have worked. My lag seems much less severe than Kuro's, but it's enough to bug me...
  9. KuroTsubasa

    KuroTsubasa Well-Known Member

    If it's only your Recent Apps button that has issues, try modifying the button layout in your custom rom. Most have an area in their settings app where you can customize aspects of the rom (beyond what you can do in the stock rom).

    You could increase the number of buttons on the bar, pushing the recent apps button further left. If you do this you could probably set the new buttons to have no action and a blank image for an icon. Or, you could set the "long press" action of the home button to bring up recent apps (like in android <4.0).

    This is all assuming of course that you've already gone past the return/exchange period for your phone and can't get it replaced. Also, if you had an insurance plan (like some phone stores try to push) on it they might cover that too.
    NSutherl likes this.
  10. jbdan

    jbdan Well-Known Member

    Did you get this solved kuro?

    @ NSutherl if you have a lot of recent apps going on (pretty normal) the recents button will lag with every ROM I've ever tried. Swipe away all but 2-3 apps then try it again. Should be fairly instant. I know....it shouldn't be like this.
    NSutherl likes this.
  11. NSutherl

    NSutherl Well-Known Member

    It definitely helps. It lags ever-so-slightly after I swipe away all but one app, better than the ~1 second lag when there were many apps open.

    I got rid of the recent button and just made a long press on home bring up recents (like Sense). The lag issue is the same as when I had the actual recent button. It was worth a try though, and I actually like it better like this because now I can have a search soft key :)
    jbdan likes this.
  12. KuroTsubasa

    KuroTsubasa Well-Known Member

    No, I've got to call up Amazon sometime and have a conference call with Verizon so I can prove to them that I know what I'm talking about more-so than them. ;P

    I have however done testing on the stock rom that proves it's a hardware issue. Using an app called Z-DeviceTest, I did a pressure sensitivity test on both my custom rom and on stock. The bottom half of my screen is about *half* as sensitive as the top half. Near the bottom, where the nav buttons are it drops down to even less.

    I've come to assume that the reason why it works on the stock rom must be a difference in sensitivity settings.

    Anyway, I'll convince them to give me a new phone sometime later this week. Haven't had any time to call them when my girlfriend's phone was around (since if I call them on mine I *know* they'll ask me to restart it at some point).
  13. jbdan

    jbdan Well-Known Member

    :thumbup: lol

    Well gl! Post us when you get the new GN I'm curious to see

Share This Page