[Virgin Mobile] obtaining IP address problem


  1. lox

    lox New Member

    So I just spend 300 dollars on something that has essentially become my old phone, which I paid 35 for. My BRAND NEW Galaxy s3 from virgin mobile is trapped in this vicious cycle of "obtaining IP address", "internet connection is not stable", and no wifi at all, eating up my data.
    seeing that this is a common issue with android devices, I did some digging and found the common static IP solution, which I used, and that got me from stagnantly being in the "obtaining IP address" phase, into the other two. Funnily enough, it only moves to stage two when I visit the google play store.
    Factory reset has to be my last resort, but if all else fails that is where I will go. please help. I have downloaded WiFix and attempted at the manual reset, but to no avail.

    Advertisement
  2. Tokens210

    Tokens210 Well-Known Member

    I've never had a WiFi issue, although I also removed the stock ROM within an hour of opening the box with the phone lol


    Are you sure you entered the correct password, cause if u accidentally hit another key it would have saved it causing it to hang at connecting or obtaining IP address

    Typically I'd also ask what type of wireless you have but I believe this phone actually supports everything up to wireless N
  3. kwknott

    kwknott Well-Known Member Developer

    I've never had any wifi issues like you describe, neither on stock roms or custom roms.

    I have however heard of people having these issues with certain routers. I think Belkin was the big troublemaker. If the issue is only on your wifi, I'd say it's a router issue. If it's on multiple routers, I'm not sure what to recommend as a fix as I've never seen the issue span multiple networks.
    lox likes this.
  4. Ping0

    Ping0 Well-Known Member

    Seems to be a problem with the way your wifi is set up, I only get that error at work and I know it's the way they have their routers set up.
    lox likes this.
  5. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Are you rooted if not have you done a factory data reset . this will clear your device of any static bugs causing this error .
  6. lox

    lox New Member

    I did the factory reset, still with the same problem. I've come to the conclusion that yeah, it's my router. Anyone know how to reset it and not completely botch it so I don't get my torso ripped apart by my mother?
  7. MopedRyder

    MopedRyder Well-Known Member

    Reboot the router. Unplug...wait 30sec...plug back in. Try to connect
  8. bbk3e

    bbk3e New Member

    I recently had this problem and have searched the Interwebs to figure something out. This is one solution I came across that worked for me:

    <copy/paste>
    To resolve this I found another thread on the forum and I tried this, and Bingo! it worked.

    Press these menu options on your phone: Settings > Wi-fi> (Choose your network by tapping on it for a few seconds) > Modify network config

    Check "Show advanced options"

    Choose IP Settings: "Static"

    Enter these details
    IP - 192.168.1.253 or 195.168.1.253 (I chose 192.168.1.253)

    Gateway - 192.168.1.1 (I chose 192.168.1.1 since that's my router address)

    NPL - 24

    Netmask - 255.255.255.0 (I could not find this option)

    DNS 1 - 8.8.4.4 or 8.8.8.8 (I had the latter by default and let it stay)

    DNS 2 - 4.4.4.4

    And save.

    Presto! It just connected in a few milliseconds.

    It may not be so simple for each phone, but it's certainly worthwhile to try.
  9. hatredg0d

    hatredg0d Well-Known Member

    The problem sounds like your router/network. Seriously even if changing it to static fixes it for now, I bet it will happen again later on.

    tip- do not by the cheap ones, as you might have the exact same problem after everything connects to it.
  10. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Make shore you Dont have the dhcp relay enabled on the router .
  11. Tokens210

    Tokens210 Well-Known Member

    Just an FYI tho to the static setup, your router gives IP's out as needed by setting as static it never usues another IP (kinda making it like an apple device but not as bad as it would at least release it lol)

    Basically if you take your phone off WiFi and another Device happens to fall to that IP when you try to reconnect the phone both devices will then have connection issues until its changed, IP listed does seem further down the list of possible ones so it may not cause any issues but still good to know
  12. tech_geek

    tech_geek New Member

    Try this method:
    1. Go to Settings and tap on Wi-Fi.
    2. Turn on the Wi-Fi and connect to a network.
    3. Long press on the connected network and select Modify Network.
    4. Check Show Advance Options.
    5. On IP Settings drop down menu, select Static.
    6. Assign IP of your choice but leave other variable untouched.

Share This Page