websites: cannot log in / too many redirectsSupport


  1. n7of9

    n7of9 Active Member

    i assume this would be an Android stock browser problem, not a HTC Desire specific one??

    1. i am have problems logging in to some sites...one site in particular was always OK until i cleared all my cache and cookies, etc, now i can't log in to it at all

    the page just keeps reloading to the 'please log in' page, it shows no error, just behaves as if i hadn't included any log in details

    2. some sites cannot load with an error saying "too many server redirects" - does anyone know what that's about?

    i am so frustrated!!

    edit: i just installed Opera Mini and that allows me to log in straight away - but damn it looks ugly on the Desire

    Advertisement
  2. kilroy

    kilroy Well-Known Member

    Try the Dolphin HD browser. Best one for Desire by far IMO. You can also customize the colour with different skins. Very functional.
  3. n7of9

    n7of9 Active Member

    thanks Kilroy...i also tried it on Skyfire and same, cannot log in

    will try Dolphin
  4. n7of9

    n7of9 Active Member

    Dolphin HD, awesome look and feel...but heaps slower than stock browser for me...also...

    ...now i can't sign in to Google Reader, even though i am already signed in to my Google account and using other services (Gmail, Buzz, Picassa, Calendar)

    and it STILL won't log in to the original site (livejournal)

    i tried it with Skyfire too, no go (though Google Reader works on that)

    so Opera Mini is the only browser that will accept cookies or passwords correctly? the stock browser DID work for me, until i cleared cache
  5. snowmobile

    snowmobile Well-Known Member

    I've only had this error message once when I sent a very long complicated weblink to my phone using LinkPush. I'm not sure what I did (just pressed back or something) but the page successfully loaded despite the error message.

    I use the stock browser and have no problems with it saving all my login passwords and accepting cookies. Clearing cache certainly shouldn't result in passwords and cookies being deleted as I regularly clear mine and the browser still remembers them.

    For instance when I browse this site I don't need to login. For others which don't have a 'keep me logged in' option the browser automatically fills my username and password at the login page.

    If you have cleared cookies then I don't understand why it isn't letting you log in as normal as it did originally.

    I've tried Dolphin HD and Opera but I prefer the stock browser.
  6. n7of9

    n7of9 Active Member

    thanks snowmobile, i'm at my wits end, really...the fact that it worked yesterday but refuses to work today is mental! i have decided to keep stock browser (because i quite like it) and an install of stupid opera for those sites i can't log in to :(
  7. lau83

    lau83 Member

    I have d same problem with n7of9, but the different is: I've cleared all history, cookies, etc, but still I can't open any website using stock and dolphin. But i can open the web using opera...
  8. n7of9

    n7of9 Active Member

    lau83, thanks for the input...i'm still having the problem but i'm hoping froyo may fix it...IF i can ever get it...i've tried 5 times to get the update and it keeps saying it's corrupted!
  9. nbobbitt

    nbobbitt New Member

    I am using the stock browser in the galaxys but it does not allow me to save username. Very inconvenient for banking for example. Is there some setting to correct this problem?
  10. mikebell

    mikebell Well-Known Member

    "too many server redirects" is a response that is made by a browser under the following circumstances:

    1. User goes to web page A, where A is a dynamic page (i.e. the web server does some processing before delivering its content).
    2. The web server tells the browser to go somewhere else (for example a page that tests for the existence of cookies on the user's device)
    3. That page then tells the browser to go back to page A.

    All of this happens quickly without the user being aware of this happening. However, if the website is poorly coded it is possible for an infinite loop to occur, and the browser will end up continuously making page requests, with the website playing along.

    Some browsers, like Internet Explorer (certainly older versions) do not guard against this eventuality and will blindly request the above pages time after time until the user gets fed up, or the server finally gets its act together.

    Other browsers, like Google Chrome, detect that loop happening right away and report too many redirects as an error condition.

    Yet other browsers may indulge in a redirect loop taking place a few times before shouting.

    Ultimately, it's a poorly developed web site that causes the problem. I know that to be the case because I once introduced such a coding error myself into a dynamic website.
  11. n7of9

    n7of9 Active Member

    thanks for the reply...even if i can't get something working i still like to understand what's happening, so thank you :)

    the thing that annoys me in this particular instance is that it works using Opera Mini but not on stock browser...i've gotten used to it, though, i use Opera to access the site
  12. n7of9

    n7of9 Active Member

    SOLVED SOLVED SOLVED

    omg it drove me NUTS! today i couldn't log in to Google Reader (and i've become totally obsessed with reading feeds on the way to work)

    the issue in the end was the APN set up!!!!! i removed the proxy and port information and not only do log-ins on every site work, EVERY PAGE LOADS FASTER

    i want the last few months of my life back!


    ...
    does anyone know how to edit the subject line of the main post to include "SOLVED"
  13. queglay

    queglay New Member

    Hey guys. this is my first post here.

    I am having the same problem. I tried the above solutions including the apn setup and the alternative browsers (dolphin gives me the same issue, and opera thinks there isn't even an internet connection). I have also tried clearing the cache and cookies. does anyone have any other suggestions?

    I have a feeling it may even be optus's fault - the APN

    thanks for any help. this problem is a frustrating one.

Share This Page