Why can't I clear my calendar?

Last Updated:

  1. uscpsycho

    uscpsycho Member

    Today I started getting the dreaded "The application Google services Framework(process com.google.process.gapps ) has stopped unexpectedly. Please try again. error.

    In the past clearing calendar data in my settings (calendar storage & all calendar applications) then re-syncing solved the problem. This process is well documented and I'm quite familiar with it. Didn't work today...

    When clearing all calendar data didn't work I tried deleting all calendar data in my Google account through the website. There is now NO data in my Google calendar. But when I open my calendar app, if my Google calendar is selected, all the previous events suddenly reappear. They shouldn't be there since I've deleted my calendar data both on my phone (allegedly) and in the cloud.

    I've tried selecting/unselecting my calendars. I've deleted calendars. I've added new Google accounts with virgin calendars. Tried everything I could think of with no success so I'm hoping someone has a new suggestions.

    Of course every time I try to manually sync I get the error.

    How do I get my phone to erase all this calendar data??? Is there an app on the SD card that I can delete?

    NOTE: I added a new Google account to my phone with a virgin calendar. I can manually sync with this calendar without getting an error. However, when I go to the options screen to select which calendar I want to use, I get the "syncing" symbol in my toolbar and a few seconds later I get the error again. This happens no matter what is checked at the time.

  2. losf

    losf New Member

    I am so glad to have stumbled onto your posting. I too am having the exact same problem and have been unable to find the solution anywhere online. Did you ever get a response? Do you have a solution you would be willing to share with me? I would be eternally grateful!

  3. uscpsycho

    uscpsycho Member

    Damn you! You brought back some horrible memories!

    I don't have the problem anymore. I don't know exactly what fixed it but I think I just created a new calendar on Google, copied everything to the new calendar and just started using that. So in other words, if my memory serves me right I never did solve that problem.

    I can't remember if there were any issues with that band aid solution. But I did reset & root my phone at a later time and have not had this problem since. Prior to rooting I would get this error every so often.

    Are you on Gingerbread? I wonder if people are still having this problem with Gingerbreat?

Share This Page