Wifi keeps disconnecting and immediately reconnecting: FIXTips


Last Updated: 2015-03-15 23:06:21
  1. wkorniot

    wkorniot New Member

    So I was having this problem with my wifi connection on my S3. It would disconnect for about 1 second then immediately reconnect. Getting the notification I was connected to my network every few seconds was getting really annoying. I searched all over the internet for an answer and I tried going into service mode and turning off power saving mode, that didn't help. I tried a factory reset, nope. Then I decided to try something that I did to fix a connectivity problem with my iPhone 4 way back when.

    I logged into my router and I changed the wifi channel from 10 to 9. And it worked! Granted I only did it about 10 minutes ago, but since I did it my S3 hasn't disconnected once. I'll report back if this turns out to not be a permanent fix.

    Advertisement
  2. Shotgun84

    Shotgun84 Well-Known Member

    Welcome to the forum wkorniot.

    Thanks for sharing your tip. The same solution worked for me in my old gs2 days and I've never had any problems since with either the s2 or s3.
  3. pauleden

    pauleden Active Member

    This is usually because the channel you were on is congested.

    InSSIDer can tell you what other wifi devices are on any given channel and it has versions that work on PC and android.

    What it can't tell you if another, non wifi device is making a channel noisy. Wireless baby monitors are often the cause. I found everyone near me was on channel 11 so I went down to channel 1, but the signal was very unstable and nothing could stay connected. I went upstairs and turned the baby monitor off, channel 1 suddenly was nice and smooth again. Microwave ovens, radio controlled weather stations, Nintendo Wii controllers, all of them use wireless, but baby monitors use exactly the same frequencies as 2.4 wifi.
  4. preston001

    preston001 New Member

    Just wanted to say this worked for me. I changed from 3 to 4 (not that it matters). The constant reconnecting was out of control. Thank you for posting a fix. I created an account just so I could say it worked and thank you.
  5. pauleden

    pauleden Active Member

    Cool. Do you or your nearby neighbours have baby monitors?
  6. wkorniot

    wkorniot New Member

    Thanks for that tip. The problem had started again so I used InSSider to check the channels around me and it turns out the channel I was using had a lot of traffic on it. I guess maybe my neighbors were using that channel too. Well I switched my router to channel 1 which didn't have any traffic and I haven't had the problem since.
  7. pauleden

    pauleden Active Member

    You're most welcome. :)
    One of the tell tale signs there might be something other than a wireless network on a channel making it 'dirty' is the signal strength flucuating for no reason.

    If InSSider (I also use wifi analyzer from the store, despite it being spelt wrong:))shows the wireless strength going up and down over the course of ten or so seconds when thee's no other wifi on that channel, you can tell it's 'competing' with something else for channel space.

    The thing it is competing with might be a baby monitor.
  8. javamann

    javamann Well-Known Member

    I don't use a router but go directly from my phone to the internet. Is there a way to switch to a diff channel directly from my phone. I lose about 10% an hour on my battery and believe that the poor connection is the major cause.

    JM
  9. txshiva

    txshiva New Member

    This used to work for me, but after 4.1.1 (Verizon), I don't even HAVE service mode.

    Have the codes changed? Have they disabled it totally? Do I need a new phone?
  10. TYPaulitworked

    TYPaulitworked New Member

  11. davidmanvell

    davidmanvell Well-Known Member

    Mine does this as well:

    My router just says auto for the channel. I can manually change it to 36,40,44,48, 149, 153, 157 or 161. Currently it is set to auto. Suggestions?
  12. TYPaulitworked

    TYPaulitworked New Member

    I just used inSSIDer to check which channels were used by other networks and choose the nearest that was free, not had a problem since.
  13. Thedarksidewolf

    Thedarksidewolf New Member

    Thank you so much! I bought a brand new tablet for my mom (kitkat 4.4) and she started having those issues while all the other devices we have at home never disconnected. We were both really sad and frustrated, we were ready to take it back to the shop :( But then I searched online for 2 days until I found this thread. Her tablet hasn't disconnected for an hour. I can't describe how thankful we are!! :) I'd give you a thousand hugs if I could!
    -Helen

Share This Page