1. Download our Official Android App: Forums for Android!

App works fine in 2.3 Version android device but shows IO Exception in 4.0 version device

Discussion in 'Android Apps & Games' started by vinaychanduri, Aug 13, 2013.

  1. vinaychanduri

    vinaychanduri Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 12, 2013

    Aug 12, 2013
    2
    0
    5
    Sir,
    I am new to android.My company has given me a project for analyzing which is developed using Eclipse and android (all Latest software) using platform: 2.2 and API level: 8 and given me two Android devices which are 2.3 version and 4.0 version for testing the application. At the time of developing they got only one device which is of version 2.3. In my project i am connecting to the server using SOAP service and getting the response in XML format which i am parsing and using in the UI.

    I found that the application after installing works fine as expected in 2.3 version device but it fails to work in 4.0 version device. I am using the same application in both cases. In my debug I found that the XML response which i should get from the server is coming as aNULL value and gives IO Exception. I have changed the "Android Project build target" to 4.0 in "Project properties" and also checked whether "ksoap jar" files are added and are latest.. Everything is fine but I don't understand why application is working fine in 2.3 device, but fails in 4.0 device?
    Please can anyone tell me what is the mistake which gives NULL value and an IO Exception for 4.0 version android device where works fine for 2.3 version. Is there any change in the methodologies from 2.3 to 4.0 ?
    I have changed the target to latest but it does not work instead should i develop the whole application by taking fresh new project with target 4.1 from the first..?? Please suggest..

    Thanking you...
    Vinay
     

    Advertisement

Share This Page

Loading...