1. Check out our companion app, Forums for Android! Download from Google Play

Support Augmented Reality / Camera apps

Discussion in 'Android Devices' started by Adrift, Nov 1, 2009.

  1. Adrift

    Adrift Well-Known Member
    Thread Starter
    93

    Nov 1, 2009
    716
    104
    93
    College...
    Corpus Christi, TX
    Hey folks,

    I was wondering if anyone else has tried a 3rd party camera app (like CameraFX) or an augmented reality app yet. My Moment wont render the image from the camera correctly it's all green and staticy looking. sorry for the terrible description.

    Has anyone tried an AR or 3rd party camera app? Or can you and then tell me if your moment is working fine with it or not?

    Thanks!
     

    Advertisement

  2. Adrift

    Adrift Well-Known Member
    Thread Starter
    93

    Nov 1, 2009
    716
    104
    93
    College...
    Corpus Christi, TX
    Quick update, Layar app works fine... others apps don't. FXCamera (wrong name in first post) doesn't work correctly.
     
  3. Gremlyn1

    Gremlyn1 Well-Known Member
    36

    Sep 10, 2009
    221
    1
    36
    San Diego, CA
    Might have gotten a dud :(
     
  4. Adrift

    Adrift Well-Known Member
    Thread Starter
    93

    Nov 1, 2009
    716
    104
    93
    College...
    Corpus Christi, TX
    This is what I fear, can anyone else try out either FXCamera or SpecTrek Light, both are free apps, and tell me if they worked correctly? If so I will be going back to BB tomorrow for an exchange...
     
  5. Bernal

    Bernal Well-Known Member
    15

    Aug 26, 2009
    55
    0
    15
    layar worked

    fxcamera is a near solid green set of vertical lines

    spectrek light has a multiple copies side-by-side of the camera view in black and white with static lines

    I'm hoping the reason for these issues is that the app developer is using some non-standard methods of getting camera image data, because otherwise this could be a bad omen for android.
     
  6. Adrift

    Adrift Well-Known Member
    Thread Starter
    93

    Nov 1, 2009
    716
    104
    93
    College...
    Corpus Christi, TX
    Hmm relief and dissapoinment at the same time...

    My phone isn't borked but it may be a problem with android...

    Funny thing is with FXcamera, taking a picture the photo comes out fine. This makes me think something is interfering with the display, like maybe it is trying to run it through the stock camera app and then through the third party app? Where as Layar simply utilizes the stock camera app. I dont know.
     
  7. yourm0m1

    yourm0m1 Active Member
    15

    Nov 2, 2009
    26
    0
    15
    does your camera hard key on the outside of the phone still bring up the camera after installing any of these apps? i have tried 3 different ones and now have done 2 hard resets.
     
  8. stile65

    stile65 Member
    5

    Nov 2, 2009
    9
    0
    5
    Layar works for me on the Moment. Barcode Scanner was not working due to an issue with the way the Moment reports its preview format, but the fix is currently in SVN. I'm wondering if the issues with other camera apps are due to the same problem. More info about the Barcode Scanner bug here.
     
  9. Edaze55

    Edaze55 Well-Known Member
    81

    Aug 26, 2009
    973
    1
    81
    Data Tech
    Chicago, IL
    I was wondering why Barcode Scanner wasnt working properly. Thanks.
     
  10. pking

    pking Well-Known Member
    35

    Nov 4, 2009
    156
    0
    35
    Denver, CO
    Barcode Scanner devs seemed to think this may have been a phone bug, it's quite possible the camera is misreporting it's mode, which would be causing these problems.

    I've got some kind of problem with the default camera app not working now, pretty sure it's something I installed from market but can't figure out what, anyone else just getting a blank screen on the built-in camera app?
     
  11. Adrift

    Adrift Well-Known Member
    Thread Starter
    93

    Nov 1, 2009
    716
    104
    93
    College...
    Corpus Christi, TX
    FXCamera was updated today... Works great now! Obivously this is an easy fix so, here's hopeing all apps that use the camera are updated soon!
     
  12. stile65

    stile65 Member
    5

    Nov 2, 2009
    9
    0
    5
    Barcode Scanner 3.0.1 is up on Android Market with fix for the force close issue on the Moment.

     
  13. VerusZetec

    VerusZetec New Member
    5

    Nov 9, 2009
    3
    0
    5
    I'm having the same camera errors with SpecTrek Lite. I downloaded Barcode Scanner early this morning, so I believe I got the upgraded version, and it does indeed work with my Moment. CameraFX works as well.

    SpecTrek is also having issues with the GPS and the Compass, but considering the lack of proper support in CDMA 1.5, I'm not terribly surprised, just waiting for that update...
     
  14. Pieter007

    Pieter007 New Member
    5

    I'm the author of SpecTrek and stumbled on this thread when looking for clues on the Samsung Moment camera problems.

    We are working on the issue, but without a Moment to test on, we have trouble locating the cause. I will send an email to the author of "FxCamera", maybe he/she can shed some light on the issue.

    Any hints are appreciated.

    VerusZetec, what kind of problems do you encounter with GPS and the compass? Any other apps that have those problems, or is it just SpecTrek? (we haven't received any complaints about GPS/compass so I'm very curious).
     
  15. agent0014

    agent0014 Well-Known Member
    36

    Nov 6, 2009
    394
    1
    36
    The GPS issues are the Moment's... not tied to any apps. You can read about it in this thread:

    http://androidforums.com/samsung-moment/15931-gps-has-failed.html

    Basically aGPS is semi-broken and seems to only work if WiFi is on (or is it off? I forget right now)... so it's nothing you could address via your software.
     
  16. Adrift

    Adrift Well-Known Member
    Thread Starter
    93

    Nov 1, 2009
    716
    104
    93
    College...
    Corpus Christi, TX
    Hello Pieter007,

    I'd like to thank you for your rapid response. I contacted you earlier today via email, after seeing you had recently updated SpecTrek. I had assumed others had already emailed you concerning the problem, but it seems few did. I am glad I went ahead and contacted you on this matter, seeing how quickly you respond.

    After testing SpecTrek further, I can report that GPS and Compass are both working normally on my device. The only problem I am encountering is the camera view.

    Hopefully you can figure this out

    Thanks again!
     
  17. Amber Moment

    Amber Moment Member
    36

    Nov 24, 2009
    11
    1
    36
    Psycho Keeper
    Maryland
    I downloaded Camera Magic from the market and it allows you to zoom with your volume button and it works fine.
     
  18. Adrift

    Adrift Well-Known Member
    Thread Starter
    93

    Nov 1, 2009
    716
    104
    93
    College...
    Corpus Christi, TX
    I believe you are meaning to respond to a different thread.
     
  19. Pieter007

    Pieter007 New Member
    5

    The author of FxCamera gave me the fix he implemented. It was ridiculously simple: just leave out some of the camera initialization code that Google recommends you use.

    In my case, the only thing to leave out would be the "set camera preview size to 480x320". I am not convinced that this will solve the problem, but then again it just might. So I build a version of "SpecTrek Light" with this fix in place and placed it on our webserver:
    http://www.spectrekking.com/download/spectrek-light-moment.apk

    Can anyone with a Samsung Moment test this version and check whether the camera now works correctly?
     
  20. satinkzo

    satinkzo Well-Known Member
    35

    Oct 26, 2009
    144
    0
    35
    I've been playing with AugSatNav, it seems to work pretty well on the moment.
     
  21. VerusZetec

    VerusZetec New Member
    5

    Nov 9, 2009
    3
    0
    5
    This is what I love about Android that you don't see with the other platforms: Developers and users working together in a timely manner for the greater good :)

    The GPS/compass issue I was having seems to be resolved. I'm not sure if it was a teething issue on a brand new phone, or if the place I happened to test/notice the issue had some sort of magnetic anomaly.

    I'm downloading the moment .apk now, I'll let you know how it goes.

    Thanks for your hard work, I really appreciate it :)

    edit: Silly me, I can't start a game until I have a GPS fix, and i'm tied to a phone at my desk all day (inside). I'm gonna have to wait until i can get a chance to get a break. I'll keep you guys posted.

    edit again: Just noticed a typo in the GPS options -- "excellend signal" instead of "excellent signal". Just FYI. :)
     
  22. VerusZetec

    VerusZetec New Member
    5

    Nov 9, 2009
    3
    0
    5
    Pieter007, I'm proud to announce, SpecTrek Lite 1.07b works perfectly with your fix. :) Think I'm gonna have to buy the full version soon :D
     
  23. Adrift

    Adrift Well-Known Member
    Thread Starter
    93

    Nov 1, 2009
    716
    104
    93
    College...
    Corpus Christi, TX
    I too can confirm, SpekTrek is working correctly in that build
     
  24. Pieter007

    Pieter007 New Member
    5

    YES! I will need a couple of days to tidy up the current version. After that I will release new versions of the light and full versions with this patch in place. Thanks guys!
     
  25. tdomhan

    tdomhan New Member
    5

    May 1, 2010
    2
    0
    5

Share This Page

Loading...