1. Download our Official Android App: Forums for Android!

Support Calendar Time Zone Changes Event Times

Discussion in 'Android Devices' started by raptorjrf, Nov 26, 2009.

  1. raptorjrf

    raptorjrf Newbie
    Thread Starter
    Rank:
    None
    Points:
    15
    Posts:
    15
    Joined:
    Nov 8, 2009

    Nov 8, 2009
    15
    0
    15
    Is there a way to keep the Droid (Google) calendar from adjusting event times each time I go into a different time zone ?

    I live in the Pacific Time Zone, and enter all my events at home. When I travel, the calendar "adjusts" the event time by the number of hours difference between PST and the time zone I am in. This is frustrating, since I then need to mentally calculate the time back to PST.

    Does anyone know a way to defeat this feature ?

    john
     

    Advertisement

  2. Plakius

    Plakius Member
    Rank:
    None
    Points:
    18
    Posts:
    65
    Joined:
    Dec 8, 2009

    Dec 8, 2009
    65
    16
    18
    Los Angeles/NYC
    did you figure this out John?
     
  3. 714tman

    714tman Lurker
    Rank:
    None
    Points:
    5
    Posts:
    7
    Joined:
    Nov 17, 2009

    Nov 17, 2009
    7
    0
    5
    I had this same problem.

    Go to Settings>Date & Time and uncheck Automatic.
     
  4. Plakius

    Plakius Member
    Rank:
    None
    Points:
    18
    Posts:
    65
    Joined:
    Dec 8, 2009

    Dec 8, 2009
    65
    16
    18
    Los Angeles/NYC
    if you unchecking automatic is not a fix .... because now that i am in nyc my twitter and facebook are 3 hours behind .... iphone has a option called time zone support that keeps your calendar in your timezone ... we need that
     
  5. dscha

    dscha Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Feb 13, 2011

    Feb 13, 2011
    1
    0
    5
    Same issue. I have following setup:
    Mac runs on european time, galaxy S runs on UK time. With spanning sync i send ical appointments from mac to google calendar. android syncs with google calendar. Since android phones is on UK time, all appointments are 1 hour off.

    on the iphone it works perfectly with the time zone support switch.

    Any ideas welcome!

    thanks
    Dietmar

    EDIT: problem solved.
     
  6. pderkay

    pderkay Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Jan 8, 2012

    Jan 8, 2012
    3
    0
    5
    May I know how this was fixed?

    I have a school calendar and a private calendar. Both set to (-6 time zone)... I went on vacation to a (+1) and when creating new events on the browser gmail calendar, it was showing up with messed up times on my Galaxy Nexus.

    Thanks
     
  7. squaredeal

    squaredeal Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Mar 11, 2012

    Mar 11, 2012
    1
    0
    5
    I have been looking for a fix for this forever. Today just found Calengoo app on the market that solves this problem. Also had a problem with my phone not showing events older than a month although they were on my google calendar. This solved this problem as well. Hope it helps.
     

Share This Page

Loading...