1. Are you ready for the Galaxy S20? Here is everything we know so far!

debranding issues o2

Discussion in 'Android Devices' started by alankfc02, Aug 3, 2010.

  1. alankfc02

    alankfc02 Lurker
    Thread Starter

    Just wondering of anyone can help. I can't be bothered wait on o2 to release there version so tried to debrand my desire. I'm normally pretty good at this kind of thing but this has me stumped.
    I was just using the sd card from my desire so I mount the disc, formatted and got my goldcard image via email. I completed the instructions and it said it was complete.
    I then tried the wwe.21.etc rom. This reads my phone and then starts to load bootloader. It counts to about 80 then error with the usb.
    Any one have any idea where I am going wrong

    1. Download the Forums for Android™ app!


  2. SL4VE

    SL4VE Well-Known Member

    i couldnt do mine either via the unrevoked tutorial
  3. anoniemouse

    anoniemouse Android Expert

    Have you set your phone to usb debugging mode, settings/applications/development?
  4. alankfc02

    alankfc02 Lurker
    Thread Starter

    Yes debugging is on. Can anyone confirm a generic Rom to run on a o2 branded phone
  5. skyband123

    skyband123 Newbie

    Hey there, i was having the same problem today on my branded t-mobile desire.

    Each time i tried to flash the stock rom (i used RUU_Bravo_HTC_WWE_1.21.405.2_Radio_32.36.00.28U_4. 06.00.02_2_release_126984_signed.exe), it would try to reach the bootloader but would remain on the HTC Splash screen until it timed out with an error cod (think it was 170). When unplugging the usb the phone would show the bootloader but upon plugging in again it would go back to the splash screen.

    Here's what i did to get it to work.

    1. When the Ruu.exe for the stock rom gave me the usb error message, i unplugged the usb and the phone showed the bootloader
    2. I replugged the usb and the phone went back to the HTC splash screen.
    3. I ran the Ruu.exe for the stock rom again whilst the splash screen was on the phone. This time the ruu.exe started to load whilst the splash screen was still on without going to the bootloader. Voila, the stock rom was loaded and my phone debranded.
    4. Next problem i had was that, upon checking for system updates, i was continously getting the dreaded "your phone is up to date message" I logged into my gmail account and tried again and this time the update showed for Android 2.2 and Sense. Since then i've been enjoying froyo goodness. :-D

    Maybe you guys who are having the same problem, try what i did and it may work, it did for me.
  6. alankfc02

    alankfc02 Lurker
    Thread Starter


    I followed your instructions and unplugged the USB once the error came up. I ran the RUU again and it worked this time. Said everything waas complete. I started the phone and it asked what network i am with 02 pre pay 02 post pay or tesco. I picked o2 post pay and went though the setup for my email etc.

    Now when I go to check for update I am not getting any. My software is 1.21.405.2

    Anyone have any idea why the update is not working

    Update - Can someone look at my software version and let me know if they see anything wrong

    firmware version
    2.1-update 1

    build number
    1.21.405.2 cl174215 release key

    software number
  7. skyband123

    skyband123 Newbie

    Lol, I had the same problem as well. I had to make sure I was signed in to my google account in accounts and sync in the settings menu, I wasn't (if you are try signing out and back in again), let it do its sync for a few minutes , reboot phone, try checking for updates it should work

    BTW I had the same software version as yours before updating to 2.2

HTC Desire Forum

Features and specs are not yet known.

Release Date

Share This Page