1. Are you ready for the Galaxy S20? Here is everything we know so far!

Default GMail Account for Sharing

Discussion in 'Android Devices' started by amgala, Apr 23, 2012.

  1. amgala

    amgala Newbie
    Thread Starter

    Apps such as the Gallery, Browser, etc. of course have the Share button so you can share something via text, bluetooth, email, etc. When I try to share something via GMail, the default From address is my work e-mail address, not my personal email address, even though my personal GMail account is my main account (the one I set up on the phone first). I am thinking it is showing my work account as the first option because alphabetically it comes before my personal email address. However, does anyone know if/how I can set my personal email address as the default option in the share menu? I have searched and searched and haven't found any solutions yet. Thanks for any help!
     



    1. Download the Forums for Android™ app!


      Download

       
  2. pappabacon

    pappabacon Well-Known Member

    Did you: open gmail, settings, go to the one you want to use, settings, "make priority?" I think that's the steps I used.
     
  3. amgala

    amgala Newbie
    Thread Starter

    Thanks for the suggestion, but the option I see in that menu is to enable Priority Inbox, which is a different option for the emails you see in your inbox.
     
  4. quiklives

    quiklives Android Enthusiast

    Go to gmail on your computer, to settings, and check what you have set as your default address to send from, as I think that has an effect.
     
  5. amgala

    amgala Newbie
    Thread Starter

    Sorry for not being more clear. I have two GMail addresses.

    One is for my personal email, and for example's sake I'll call it personal@gmail.com.

    The other one is an account where I auto-forward any emails from my actual hosted work email address to this email address. In other words, any email sent to my work email (let's call it me@business.com) gets autoforwarded to my second GMail account (let's call it business@gmail.com).

    My work address (me@business.com) is set as the default send-from address for my business GMail account. However, this GMail account is the secondary account on my phone. My personal account is the primary account on my phone, so I would think that it should be the default send-from address when I'm trying to share something. However, I think that because my work address (me@business.com) comes before my personal address (personal@gmail.com) alphabetically, it is showing up first on the list of send-from options.

    Sorry if that was confusing, but that is the situation I'm facing.
     
  6. pappabacon

    pappabacon Well-Known Member

    Well after I did that it changed the default email address for sharing to the address I picked.
     
  7. Tim K

    Tim K Android Expert

    I just added another gmail account to my phone. Even though it comes first alphabetically, my original gmail account remains the default when I go to share gallery photos etc. So its not an alphabetical thing. And neither one of them had priority inbox enabled.

    Are you sure you added your personal account first?
     
  8. Tim K

    Tim K Android Expert

    Just saw this too...
    Go into Gallery - make sure you are at the main page with all your albums. Click the 3 dot menu button. Choose settings. What does it list as the account settings? Are both listed, and it what order?
     
  9. amgala

    amgala Newbie
    Thread Starter

    Thanks for your input. I'm definitely sure I added my personal account first.

    You suggestion to enable the Priority Inbox did in fact make my personal address my default address in the share menu. I then disabled the Priority Inbox and my personal address remained the default address. I then rebooted to see if the setting would stick after a reboot and it did! Thank you again for the suggestion!
     
  10. amgala

    amgala Newbie
    Thread Starter

    Both are listed, and it shows my personal address first. But unfortunately I checked after my issue was fixed, so I can't say for sure what the order was before.
     
  11. jaydee77ca

    jaydee77ca Well-Known Member

    I found this thread while searching for the same issue. After some experimenting I believe I found the explanation. The account is uses for sharing is whatever account was last used in the Gmail app. First, it was sending from Account #2 when I shared from the gallery. I opened the Gmail app and it opened to Account #2's inbox. I switched to Account #1 inbox and then went back to the Gallery. After that when I shared from the Gallery it used Account #1.
     

Galaxy Nexus Forum

The Galaxy Nexus release date was November 2011. Features and Specs include a 4.65" inch screen, 5MP camera, 1GB RAM, TI OMAP 4460 processor, and 1750mAh battery.

November 2011
Release Date
0
Reviews
Loading...
Similar Threads - Default GMail Account
  1. Cataster
    Replies:
    0
    Views:
    285
  2. family coach
    Replies:
    14
    Views:
    1,375
  3. seeker1351
    Replies:
    6
    Views:
    1,234
  4. Milo Williamson
    Replies:
    12
    Views:
    890
  5. Startup123
    Replies:
    0
    Views:
    688
  6. Gobshyte
    Replies:
    2
    Views:
    452
  7. joshkrupinsky
    Replies:
    9
    Views:
    1,043
  8. DynV
    Replies:
    0
    Views:
    742
  9. Papamalo
    Replies:
    2
    Views:
    1,472
  10. Gobshyte
    Replies:
    11
    Views:
    2,139

Share This Page

Loading...