Root deleted framework-res.apk after notification bar mod.


I was hoping someone here can give me a bit of advice.

A couple days ago I was able to successfully root my SF and change out the bottom right search key so it would default to Google from now on.

Feeling good from all that I thought I'd take on a little tougher challenge and do some more customizing, starting out small before I think about tackling the Voodoo stuff later on.

WELL... I tried to change the battery indicator to the circle indicator followed the directions here: UOT Kitchen. How-To

It asked me to back up my "framework-res.apk" because I would have to replace it with one the website generated for me.

Everything went fine until I stupidly tried to do a 1:1 exchange of the new "framework-res.apk" for the original one, by first renaming it to apk.old with the hopes to paste in the new one in its place. BUt as soon as I renamed it and moved it to a backup folder it froze before I could insert the new one.

I know now I should've run the new .apk instead of swapping, but am now stuck with a SF that turns on but that is stuck at the SAMSUNG logo.

I hear the startup sound play and the verizon logo music, but that's as far as it goes. I can still boot into recovery or download mode.

Now, It seems that "all I need to do" is find a way to get access to my internal SD card and rename the "original back to .apk and move it to its original spot in the framework folder.

Is there a way to do something like this? I'm hoping there's some easy way to do this, short of having to do something more radical.

Hopefully there's someone out there that might be able to offer some advice for my current situation.



Well-Known Member
assuming you are root, yes you can do this. I know using rootexplorer, you're able to move files from your SDcard to the root. Being an inexperienced user with other file apps, I'm not sure if the other ones such as astro file manager will let you. Maybe you can try? Hopefully others chime in!

On a side note, Root Explorer is well worth the app!


Thread starter
Thanks for the input GoBruins

The only thing is I can't really access anything beyond the Recovery menu. How would I get an app to run?

However, I think I made some progress???

I Used Odin to flash Clockworkmod. Used the to run CWM and I used this menu to select "Install from zip from sdcard" and I used the battery percentage mod from another thread:

Now I can get past the start up screen just fine. even to the Lock screen. BUT when I'm at my home screen I keep getting forced closes.

I think its because I kept trying the "wipe data/factory reset" and "wipe cache partition" options from the recovery menu. because i didn't know what else to do.

ANYone have any suggestions for what I might try next?


Thread starter

Thanks Bruin,
I think My phone is back to stock

In part thanks to you.

Here's what I did.
I tried all the fixes in this link
Odin Restore files to get you to stock - xda-developers
but i was still getting forced closes.
then I saw your last message and wiped the stock recovery cache.
After that it was still giving me FCs but to a lesser degree and I was able to make it into the "Settings menu" and do a factory reset.

Now I'm pretty sure I'm back to stock.

Well now that I'm back to being good. How do I go about backing up my phone so I can basically restore it to a specific point? Is that even possible.
I've heard of Nandroid, Titanium backup etc.

Thanks again for your input!


Well-Known Member
Yeah no worries. Remember there's a thanks button ;) I'm glad you got your phone back to stock.

Regarding nandroid, yes you heard correctly.

Using CWM, you can go to backup/restore => backup => nandroid (along those lines, I don't remember exactly). Backup all the possible settings. This is how you make a nandroid backup.

If you want to restore, then you do CWM => Backup/restore => restore => your nandroid that you saved.

Also, when you're making a "nandroid" make sure you don't have anything that changes your data partitions (I'm referring to Voodoo). If you have Voodoo on, disable it and then make your nandroid. If you don't have Voodoo, then just forget what I just said.