1. Check out our companion app, Forums for Android! Download from Google Play

Support Drivers for Nexus 5 won't install

Discussion in 'Android Devices' started by xbroogw1, Nov 21, 2013.

  1. xbroogw1

    xbroogw1 Well-Known Member
    Thread Starter
    36

    Aug 7, 2011
    170
    6
    36
    When I connect my phone to the PC, it does not install the drivers. It always says failed to install. When I check in the device manager the Nexus 5 appears under other devices with a yellow triangle next to it. This is stopping me from rooting my phone.

    Has anyone else had this problem?
     

    Advertisement

  2. alostpacket

    alostpacket Over Macho Grande?
    513

    Nov 29, 2009
    7,978
    3,606
    513
    Android App Developer
    NY
    iowabowtech likes this.
  3. CrystalSC

    CrystalSC Well-Known Member
    18

    Nov 9, 2013
    70
    16
    18
    Female
    Digital Marketing
    Greenville, SC, USA
    I have the same problem. I had a thread going for it here. Something in that might be useful for you if you're using a newer OS than me (I have XP). The thread is HERE.
     
  4. iowabowtech

    iowabowtech root@android:/ #
    1,493

    May 2, 2010
    12,170
    8,669
    1,493
    Making the Establishment nervous
    Iowa|USA
    +1 to the above source. Download as zip to your PC's desktop. Extract contents of zip which should make a folder of the same name most likely, regardless, you want all the contents of that zip to end up in a folder.

    Then goto your device manager, right click on the device that has the "yellow triangle" and update driver. Choose option to provide/find driver yourself selecting the driver folder you just made on your desktop as the destination.

    Note: Just select the entire folder as the driver destination. Windows will drill into any subfolders/files automatically when searching for compatible device drivers.
     
    alostpacket likes this.
  5. xbroogw1

    xbroogw1 Well-Known Member
    Thread Starter
    36

    Aug 7, 2011
    170
    6
    36
    My OS is windows 7. I will try those Google drivers when I get home and post back.

    Thanks.
     
  6. CrystalSC

    CrystalSC Well-Known Member
    18

    Nov 9, 2013
    70
    16
    18
    Female
    Digital Marketing
    Greenville, SC, USA
    Those drivers didn't work for me but hopefully they'll do the trick for you!
     
  7. xbroogw1

    xbroogw1 Well-Known Member
    Thread Starter
    36

    Aug 7, 2011
    170
    6
    36
    Thanks for your reply.

    I used the drivers from here and they worked fine.
     
  8. CrystalSC

    CrystalSC Well-Known Member
    18

    Nov 9, 2013
    70
    16
    18
    Female
    Digital Marketing
    Greenville, SC, USA
    Lucky you. It didn't work for me. :(
     
  9. Hook

    Hook Ever since DU... ;-)
    233

    Mar 17, 2010
    1,358
    648
    233
    Male
    Northern VA, USA
    IIRC, you have XP. XP is a bear with getting MTP protocol working and that is, I think, the problem you ran into. I no longer have an XP machine, but y9ou might see if Post #10 in this thread is useful of differentfrom advice you already received.

    [Q] MTP XP Driver - xda-developers

    I haven't tried this so I'm making no claims for the results. I just know the issue is MTP and XP. ;)
     
  10. Rocco2012

    Rocco2012 Well-Known Member
    43

    Jan 3, 2012
    120
    28
    43
    Toronto
    This is annoying. It says my drivers are installed but still won't connect. Uninstalled and re installed with the above methods. Have debugging enabled. Tried everything. On my laptop at home its working fine. On my PC at work, forget about it.
     
Tags:

Share This Page

Loading...