1. Check out our app, Forums for Android! Download and leave feedback here!

Eclipse and Android SDK Question (Vista)

Discussion in 'Application Development' started by seanjohn9848, Dec 19, 2009.

  1. seanjohn9848

    seanjohn9848 New Member
    Thread Starter
    5

    Dec 19, 2009
    2
    0
    5
    I'm sure this question has been asked before, and I even browsed through a few similar threads, but I couldn't find a satisfactory answer.

    I just downloaded Eclipse Ganymede and the Android SDK. I am using Windows Vista. So far I have installed Eclipse, unpacked the Android SDK and installed the Android Development Tools plugin in Eclipse. My problem is that when I go into Window -> Preferences and specify the SDK location under the Android tab, My list of SDK targets does not populate. Similarly when I attempt to create a new Android project, I don't have any SDK targets.

    I have run the SDK and ADV manager several times, and it is habitually unable to find the site https://dl-ss.google.com/android/repository/repository.xml to download and install the available packages, so I wound up browsing to that site, saving a copy of it on a web server of my own and then using my webserver as a new site. The SDK and ADV manager found it, and claims to have successfully installed all of the components, however my problems in eclipse are persisting. Additionally, my <sdk>/platforms folder is completely empty, and that is where the components are supposedly installed (according to google's Android SDK instructions).

    Wanyone know why I'm having these problems, or how to fix them? Thanks.
     

    Advertisement

  2. wige

    wige Well-Known Member
    35

    Oct 28, 2009
    46
    0
    35
    Director of IT
    Pennsylvania, USA
    In the SDK/ADV manager, try unchecking the box for SSL, and connect normally, that should allow you to download the packages (had the same issue in Win 7). See if doing it this way corrects the problem, if not I'll try to replicate when I rebuild my dev environment.
     
  3. seanjohn9848

    seanjohn9848 New Member
    Thread Starter
    5

    Dec 19, 2009
    2
    0
    5
    That worked, thank you very much.

    For anyone else with a similar problem, the checkbox you need to check is in "Settings" under "Misc", and the checkbox says "Force https://... sources to be fetched using http://..."
     

Share This Page

Loading...