1. Download our Official Android App: Forums for Android!

Support Galaxy S 4G not mounting on MBP

Discussion in 'Android Devices' started by VladTheInhaler, Nov 16, 2012.

  1. VladTheInhaler

    Thread Starter
    Nov 16, 2012

    Nov 16, 2012
    NOTE: This post was originally posted in Android Lounge.

    Recently I found my old Galaxy S 4G from T-Mobile gathering dust in a desk drawer. I charged it up, SIM unlocked it (I've switched carriers) and I'd like to use it as my go-to phone until I'm eligible for an upgrade. (Why all this trouble? Because quite frankly, even at two years old and counting, the SGS4G is still better than my iPhone.) It's still loaded with Froyo.

    But I've hit a snag. My Macbook Pro (early 2012) absolutely will not recognize this device under USB mass storage or Media Player. I heard someone say that rooting affects the ability of the device to be recognized via USB; all I know, it used to work on my old iMac back in 2010 and it was rooted then as well. I've tried everything. I enabled USB debug, selected media player as an option, I've switched out USB cables.... no dice. I'm reduced to yanking the MicroSD and plugging into the card reader on the MBP but the transfer rate on that is unbelievably slow. I even took a shot and tried Android File Transfer even though I know it does not work with anything under 3.0.

    I'd like to have this thing working. Any thoughts or ideas?

    EDIT: Sorted it. Move along now, nothing to see here...


Share This Page