1. Check out our app, Forums for Android! Download and leave feedback here!

Help, 1.5 broke my settings menu!

Discussion in 'Android Lounge' started by croaka, Jun 3, 2009.

  1. croaka

    croaka New Member
    Thread Starter
    5

    Jun 3, 2009
    1
    0
    5
    Okay, here's the sad story so far:

    I have a (previously) unmodded G1, with normal T-Mobile software. Yesterday morning around 5AM I get the little notice that I can upgrade to Cupcake. Unfortunately, it's 5 in the morning, I couldn't sleep, and I wasn't thinking all that straight... so I decided to root my phone and upgrade it to 1.5 instead.

    So I downgraded to RC29, got myself root access, and installed the latest Jesus Freke build. Now the fun starts. As soon as the phone boots into the JF build I get constant android.process.acore force close errors. And I do mean constant, I force close, and it pops up again, force close, pop up again ad infinatum. I reflashed a few more times, varying the order of installing the radio update and misc. stuff like that, but still no luck.

    So I decide to go back to the T-Mobile build without root access. I mean, I lived without it before, and not having root is better than not having a functioning phone, right? So I download the official cupcake update from google's dev site and install that. Woohoo, no more force closing, it looks like everything works!

    Orrrrr not. I can't get into Settings now. I've tried to open Settings from the home menu, from a shortcut on the desktop, and through the menu button. Every time I try to do so, it will open up a black screen (like it's starting to load the settings menu), stay there for anywhere between 1-4 seconds, then go back to the main desktop screen. Everything else on the phone works, Market, Camcorder, soft keyboard, everything. Most apps I've downloaded also seem to work. However, when I installed the Toggle Settings app and tried to toggle the GPS, it popped into the settings menu with a black screen with the Security and Location text at the top, and then promptly went back to the app without changing the GPS.

    Then I flashed it back to RC29, manually upgraded to RC30, and left it overnight. Next morning the OTA update to cupcake was available, so I installed that. Unfortunately, the problem with the settings menu is still there.

    I've tried everything I can think of at this point and the almighty Google doesn't seem to have any answers, anyone else able to give me some help? It would be much appreciated.
    [​IMG] [​IMG]
     

    Advertisement

  2. I'd return it.
     

Share This Page

Loading...