1. Download our Official Android App: Forums for Android!

Support How to hide Text Messages from Lock Screen

Discussion in 'Android Devices' started by thahim, May 25, 2013.

  1. thahim

    thahim Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    83
    Posts:
    500
    Joined:
    May 29, 2011

    May 29, 2011
    500
    20
    83
    Male
    Assistant Director
    Karachi, Pakistan
    If I have any unread messages they appear on my lock screen, I have tried everything but i can't remove that widget except for reading those messages.

    Is there any way to hide it?
     

    Advertisement

  2. TheGeek

    TheGeek Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    268
    Joined:
    Nov 26, 2011

    Nov 26, 2011
    268
    30
    43
    West Chester, PA
    I'm looking for the same thing; annoying the piss out of me.
     
  3. Kelmar

    Kelmar Done by choice
    Rank:
    None
    Points:
    823
    Posts:
    11,820
    Joined:
    Nov 28, 2009

    Nov 28, 2009
    11,820
    4,751
    823
    Open your messaging app.

    Menu/Settings... scroll down to preview message and uncheck the box
     
  4. TheGeek

    TheGeek Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    268
    Joined:
    Nov 26, 2011

    Nov 26, 2011
    268
    30
    43
    West Chester, PA
    Doesn't work; I already tried that.

    All it does is remove name/message but still has the annoying yellow box.
     
  5. Kelmar

    Kelmar Done by choice
    Rank:
    None
    Points:
    823
    Posts:
    11,820
    Joined:
    Nov 28, 2009

    Nov 28, 2009
    11,820
    4,751
    823
    *goes to test*

    *rereads OP and realizes I completely misread what you are asking for*


    I know that if I have my work email set up on the phone it won't show it (probably device admin stuff?)... not sure if that'll help get anyone on the right trail. :)
     
  6. TheGeek

    TheGeek Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    268
    Joined:
    Nov 26, 2011

    Nov 26, 2011
    268
    30
    43
    West Chester, PA
    Heh, I just turned it back on.

    I checked screen too; there are no widgets for it -- I can't find a setting to disable it; been all over the settings menu.
     
  7. thahim

    thahim Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    83
    Posts:
    500
    Joined:
    May 29, 2011

    May 29, 2011
    500
    20
    83
    Male
    Assistant Director
    Karachi, Pakistan
    Settingis in messaging app?
     
  8. TheGeek

    TheGeek Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    268
    Joined:
    Nov 26, 2011

    Nov 26, 2011
    268
    30
    43
    West Chester, PA
    We already talked about that; it doesn't take the yellow box out of the lockscreen; it just simply removes the message and contact and replaces it with "New Message".

    Still have stupid yellow box.
     
  9. chris2k5

    chris2k5 Android Enthusiast
    Rank:
    None
    Points:
    68
    Posts:
    512
    Joined:
    Nov 13, 2010

    Nov 13, 2010
    512
    48
    68
    I would love if I could remove it as well. It feels like a cheap implementation of Apple's messaging notifications on the lock screen but doesn't work as well.
     
  10. mhynek

    mhynek Member
    Rank:
    None
    Points:
    18
    Posts:
    74
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    74
    14
    18
    I hated that too. So now I disabled notifications in the message app and use Handcent instead. Problem solved.
     
  11. stevefranks

    stevefranks Newbie
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    May 14, 2013

    May 14, 2013
    10
    2
    16
    I have been having this problem as well. I think someone replied to a post I made about it that they are having it too. I have tried NiLs and another lock screen notification widget, but the default action of that ugly yellow notification steals focus from both of them. It is frustrating. I am hoping someone figures out how to fix it. I wonder if, with root, the implementation of the lock screen that comes stock with the phone can be replaced with a version that doesn't have this behavior? My phone is the Verizon version. Is this a problem with just the verizon version, or is it a problem with all the versions of the S4?
     
  12. mhynek

    mhynek Member
    Rank:
    None
    Points:
    18
    Posts:
    74
    Joined:
    Nov 23, 2009

    Nov 23, 2009
    74
    14
    18
    If you disable notifications in the stock message app and use a 3rd party message app, your problem will be solved.
     
  13. dopejayoh

    dopejayoh Member
    Rank:
    None
    Points:
    16
    Posts:
    65
    Joined:
    Jul 2, 2011

    Jul 2, 2011
    65
    4
    16
    Student
    Los Angeles, CA
    Happens to me too and I have the T-Mobile version.
    I too agree that it's beyond annoying.
     
  14. Kie

    Kie Android Expert
    Rank:
    None
    Points:
    113
    Posts:
    822
    Joined:
    Oct 7, 2011

    Oct 7, 2011
    822
    223
    113
    Risk and Safety Engineer
    Perth, Australia
    Yep I use GoSMS; Handcent is good too. Guys I know it's not ideal if you adore the stock messaging app, but maybe try a 3rd party app and see how you go :D
     
  15. thahim

    thahim Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    83
    Posts:
    500
    Joined:
    May 29, 2011

    May 29, 2011
    500
    20
    83
    Male
    Assistant Director
    Karachi, Pakistan
    Chomp and handcent are good but they are too crowded with theming options on my old s3 I had them but on s4 I preffer to stay with stock
     
  16. jamsterdm

    jamsterdm Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    122
    Joined:
    Oct 25, 2012

    Oct 25, 2012
    122
    9
    36
    Male
    its annoying as i like messages in the notification bar yet if you turn it off in messages it just shows as 'new message' in the notif bar :(
     
  17. Idamo

    Idamo Lurker
    Rank:
    None
    Points:
    6
    Posts:
    1
    Joined:
    Sep 22, 2013

    Sep 22, 2013
    1
    1
    6
    My co worker just got an S4 and came to me complaining about this same problem. What i did to fix it was disable all the message notification and then went to the playstore and downloaded handcent. much better messaging program. set this up to be your defult txt program and there ya have it. No stupid yellow box on the lock screen and still get your notification on your top bar :) hope this helps.
     
    thahim likes this.
  18. Wren22

    Wren22 Lurker
    Rank:
    None
    Points:
    16
    Posts:
    1
    Joined:
    Jun 19, 2015

    Jun 19, 2015
    1
    1
    16
    Male
    Sure there is - Try this,

    How to change the lock screen notifications behavior?
    You can do so by using the following steps:
    1. On any screen, swipe down the top of the screen to open up the notifications panel and then tap [​IMG] at the top right to go to the settings menu.
    2. Tap My device tab.
    3. Tap Sounds and notifications.
    4. Scroll the screen to the very bottom.
    5. Tap While locked and then select from the following options:
      • Show all content: select this option if you want your phone displays notifications and its contents when the screen is locked.
      • Hide sensitive content: select this option if you want your phone displays notifications without its contents when the screen is locked.
      • Do not show notifications: select this option if you want to completely turn off lock screen notifications, or in other words, your phone won't show any notification when the screen is locked.

    Have a great day :^>
     
    subway05 likes this.
  19. subway05

    subway05 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Aug 10, 2012

    Aug 10, 2012
    3
    0
    5
    Very nice.... thank you!
     

Share This Page

Loading...