1. Download our Official Android App: Forums for Android!

Apps main.out.xml problem

Discussion in 'Android Development' started by alsaket, May 28, 2011.

  1. alsaket

    alsaket Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    May 28, 2011

    May 28, 2011
    4
    1
    6
    Hi all,
    I am new with android and I have faced a problem that I hope you can help me solve. The problem is: I added form widget (button) to "Hello World" application. When I run to launch it in the emulator I get this problem
    [2011-05-29 04:33:43 - HelloWorld] C:\Users\ALSAKET\workspace\HelloWorld\res\layout\main.out.xml:1: error: Error parsing XML: no element found
    [2011-05-29 04:34:24 - HelloWorld] res\layout\main.xml:0: error: Resource entry main is already defined.
    [2011-05-29 04:34:24 - HelloWorld] res\layout\main.out.xml:0: Originally defined here.
    [2011-05-29 04:34:24 - HelloWorld] C:\Users\ALSAKET\workspace\HelloWorld\res\layout\main.out.xml:1: error: Error parsing XML: no element found

    Hope I can have someone helps me with this problem.
     

    Advertisement

  2. james27007

    james27007 Look into my Eye
    Rank:
     #86
    Points:
    193
    Posts:
    1,192
    Joined:
    Mar 6, 2010

    Mar 6, 2010
    1,192
    471
    193
    Male
    Travel and teaching for tech and automotive
    Riverside, CA
    Welcome to Android forums, we are glad you are here. Unfortunately I do not know the answer to your question, but if you check out the Android Applications - Android Forums you may be able to hook up with other application developers for help.
     
    alsaket likes this.
  3. ardchoille

    ardchoille Android Expert
    Rank:
    None
    Points:
    333
    Posts:
    3,684
    Joined:
    Mar 8, 2011

    Mar 8, 2011
    3,684
    1,940
    333
    Male
    Ordained Minister
    Seattle
    Hi and welcome to the forums! We hope you enjoy your stay :)
     
    alsaket likes this.
  4. alsaket

    alsaket Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    4
    Joined:
    May 28, 2011

    May 28, 2011
    4
    1
    6
    I am sorry for late reply .
    I got the problem source and solved it wanna post to share.
    The problem was when tried to lunch the application make sure u select the root directory. If you select main.xml eclips will create you out.xml , then everytime you try to run you will come out with the message above.
    Delete the file out.xml , make sure you select the root directory for your application, and run as android project.
     
    james27007 likes this.

Share This Page

Loading...