1. Are you ready for the Galaxy S20? Here is everything we know so far!

MMS not working on Samsung S10e

Discussion in 'Android Lounge' started by FatBear, Feb 21, 2021.

  1. FatBear

    FatBear Newbie
    Thread Starter

    My wife and I each have a Samsung S10e, though they were purchased a few weeks apart. Mine receives photos and large messages just fine. Hers does not.

    I've tried both the default Samsung messages app that comes with the phone and Google's messages app downloaded from GooglePlay. The Google app shows a progress circle going endlessly round and round. The Samsung app actually shows the message size and identifies it as MMS, but never displays it.

    I have compared every setting I could find that might apply and all are the same.

    Any idea what might be wrong?

    Thanks.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hadron

    Hadron Smoke me a kipper...
    VIP Member

    The usual cause of these problems is the APN settings (Access Point Names - should be in your mobile data settings). These are carrier-specific, and some carriers use separates APNs for MMS and mobile data (meaning that one can work fine and the other not).

    Apologies is this is something you've already checked: whether "compared every setting that might apply" includes any particular setting depends on whether you know which settings do apply, which of course I cannot know. ;)
     
    MrJavi likes this.
  3. FatBear

    FatBear Newbie
    Thread Starter

    Every setting I could find that might apply. I didn't find this one. :)

    And they are different! The one with working MMS is set to "T-Mobile US LTE" and the one that is not working is set to "Ting Data". (We get our service through Ting.com which is a T-Mobile reseller or some such arrangement.) But I don't know if I can just add the T-Mobile APN and copy its settings or if there is more to it than that.

    Thanks!
     
  4. Yes add the new APN and copy all the settings over exactly. It will then appear as a selection in the APN settings.
    I had an issue where I couldn't send MMS and it was the APN.
     
    MrJavi and Dannydet like this.
  5. FatBear

    FatBear Newbie
    Thread Starter

    Well it was certainly worth a try, but I made the APN settings identical and it still does not download MMS. (Photo)
     
Loading...

Share This Page

Loading...