1. Are you ready for the Galaxy S20? Here is everything we know so far!

Need help from an advanced user re: Busybox / Android Market download woes

Discussion in 'Android Devices' started by rickytenzer, Sep 2, 2011.

  1. rickytenzer

    rickytenzer Lurker
    Thread Starter

    A few nights ago, I was trying to update Busybox using Stericson's app from the market, but it failed and said there is now 2 versions installed. Ever since then, I have had issues with downloading from the market OVER WIFI (3G works just fine).

    Logically, I can only assume this has to do with the screwed up installation of Busybox as the issue appeared quite literally after I tried to upgrade.

    Since then, I've tried wiping EVERYTHING and starting from scratch. Flashing a pure stock ROM, using CWM to unmount and wipe everything, but nothing seems to work. And the annoying thing is that "Root Checker" from the market tells me that I still have Busybox installed even with a stock ROM and kernel (no CF root):

    "Installed Busybox Version:
    Busybox is not sharing its version information

    Busybox supports the following applets:
    Busybox is not sharing its supported applets"

    Can that be right? Should wiping everything get rid of all remnants of Busybox? If not, then how can I? I can't rightly use adb or root explorer as those require root/busybox to begin with to gain access to that depth of the system...

    Someone please guide me in the right direction. I'm afraid that this might be a hardware issue at this point...

    Logcat for a download that doesn't start gives me this:

    Code (Text):
    1. W/DownloadManager( 2982): Aborting request for download 14: while trying to execute request: java.net.UnknownHostException: xt-vdt-yul1.v13.lscache2.c.android.clients.google.com
    Which according to this h t t p ://download.oracle.com/javase/1....Exception.html means that the IP address of the host could not be determined.

    Does this mean that the market can't figure out what IP address I want to download to?

    Thanks to anyone who can help me! I'm dying here... I can't believe that I may have to send the phone in to be repaired, which means having to buy a USB Jig to get back down to zero and going to Bell with whom I'm no longer a customer as I only signed up for a monthly contract to be able to buy the phone :'(
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Shotgun84

    Shotgun84 Extreme Android User

    This might be a stupid suggestion as I assume you've probably tried but. Did you ever do a nandroid backup. If so and you haven't already, try to restore. Or maybe manually uninstall both busybox's and all files associated and root again.

    Second edit as just thought of something. A full wipe won't get rid of busybox. I've had a few failed flashes so I've had to wipe and reflash but root and busybox are still installed. So yeah try and find the files manually and uninstall them. I know I suggested that already but thought I would add some background to the info.
     
  3. Shotgun84

    Shotgun84 Extreme Android User

    Another thought would flashing an unrooted kernel remove manually installed busybox? Not to sure about that as never manually installed busybox. You said you tried flashing a stock rom but its the kernel that's rooted, not the rom. Hope this helps just throwing some ideas at you. Might work, might not.
     
  4. rickytenzer

    rickytenzer Lurker
    Thread Starter

    Thanks for your suggestions.

    1) No, I don't have a Nandroid backup, but if a full system flash won't fix the problem, a Nandroid backup definintely won't either.

    2) I mentioned that I flashed a stock ROM AND kernel, so Busybox should be gone.

    3) I don't know where it's installed to remove it manually. On a stock install, I couldn't find anything that resembled Busybox in my /system folders so it's really weird that it tells me that it's installed...

    Thanks again!

    This issue has NO consistency. I just managed to download THREE straight apps over Wifi, and on the 4th it stopped working again. This is REALLY pissing me off...
     
  5. Shotgun84

    Shotgun84 Extreme Android User

    Sorry unmount meant unroot, my bad. Anyway if your're still rooted download root explorer from the market. It will cost you but there should be a folder called /sbin or something like that. It should include busybox.
     
  6. rickytenzer

    rickytenzer Lurker
    Thread Starter

    Ya I removed it in both folders and upgraded but the problem still persists. I'm more concerned with the fact that it told me I had Busybox installed when I had removed everything...
     
  7. Shotgun84

    Shotgun84 Extreme Android User

    Beyond my knowledge now. Root again hope it will give you the busybox you deleted back. There will be other people about tomorrow who know more than me. Funny thing though just downloaded that app as easier to find an easy out if I do it myself. But told sorry can't work you don't have root access. Strange as I know I do.
     
  8. rickytenzer

    rickytenzer Lurker
    Thread Starter

    So I just spent a while with Stericson (thanks for that!) and we definitely removed a faulty BB installation as the culprit for NOW. Maybe when I tried upgrading it that one time it did screw something up, but it would have to be hardware.

    I literally don't know what else to do...
     
  9. rickytenzer

    rickytenzer Lurker
    Thread Starter

    Today I finally got a chance to try my phone on 2 other wireless networks, and what do you know, WiFi Market downloads work perfectly!

    So it definitely is my router. It just seems so ASTRONOMICALLY impossible based on the timing of things, but at least I've isolated the cause.

    Anyone care to troubleshoot me on how to fix it? I've restored my router (ASUS RT-N12 running DD-WRT) to default settings and even used DHCP to set my IP address to .101 instead of .109 as it usually was but the problem persists.

    Thankfully I don't have to bring in my phone for service!
     

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews
Loading...

Share This Page

Loading...