1. Check out our companion app, Forums for Android! Download from Google Play

Root Need help: Rooting Samsung Galaxy Spica

Discussion in 'Android Devices' started by saxoni, Nov 16, 2010.

  1. saxoni

    saxoni New Member
    Thread Starter
    5

    Nov 16, 2010
    3
    0
    5
    Hey guys. Ive been trying to root my Samsung Galaxy Spica for a couple of days now, without any luck. I am using this walkthrough: http://www.addictivetips.com/mobile/...eshaks-kernel/

    I have followed the steps as it sais, and everything works until I run Odin Multi Downloader v4.03. As I push "Start", I get this message:

    Download Start...
    <0> Create File...
    <1> StartThread Detected : 1
    <2> StartThread Detected : 0
    <3> StartThread Detected : 0
    <4> StartThread Detected : 0
    <5> StartThread Detected : 0
    <6> StartThread Detected : 0
    <7> StartThread Detected : 0
    <8> StartThread Detected : 0
    <1> --- cannot open the usb serial port. code: 5

    Because of what the last line sais, <1> --- cannot open the usb serial port. code: 5, Im thinking there might be a problem with my USB connection. Has anyone had this problem, and managed to fix it?
    Please help me, cause right now it seems like Im outta luck!

    Thanks!
     

    Advertisement

  2. copestag

    copestag Well-Known Member
    143

    May 23, 2010
    1,355
    247
    143
    Welcome to the forums :)

    I moved this thread to the Spica forum for you so you can get help from people more familiar with that specific phone
     
  3. karfeef

    karfeef Active Member
    16

    Jun 8, 2010
    42
    2
    16
    application developer
    liverpool, blighty
    Do you have any other usb devices plugged in at the time of flashing? if so, remove them. also, make sure the usb drivers are installed for the phone
     
  4. saxoni

    saxoni New Member
    Thread Starter
    5

    Nov 16, 2010
    3
    0
    5
    Okay, so I made the rooting, and I also managed to innstall the android 2.2 on my spica. That was probably not that smart, as I figured out I've got no sound on the phone, and the sensors doesnt work.

    So as I connect my USB, nothing happens, and I wont even get that mark on the top of my screen, where I can choose to connect it to my PC.
    I do have the debug thing on.

    Any answers?
     
  5. saxoni

    saxoni New Member
    Thread Starter
    5

    Nov 16, 2010
    3
    0
    5
    Never mind guys, I figured it out. I found out that my computer has a microSD input, so I just put the memorycard inside there, instead of trying to make it with the USB. By the way guys, if anyone of you want to root your Galaxy Spica, and update it to Android 2.2, use these two links:

    Root Samsung Galaxy Spica i5700 With LeshaK&#8217;s Kernel (Rooting)

    Install Android 2.2 Froyo CM 6 Custom ROM On Samsung i5700 Spica [Working Multi-Touch, GPS, Bluetooth, Sensors] (Updating to 2.2)
    This version of 2.2 has made the sound come back, which means you may listen to music and call your friends or mom!
     
  6. binnist

    binnist New Member
    5

    Nov 21, 2010
    1
    0
    5
    I've got a similar problem, except code 87
    [​IMG]


    using Odin v.4.03

    any ideas?
     

Share This Page

Loading...