1. Download our Official Android App: Forums for Android!

Support Optimus F6 [MetroPCS] stuck on LG Logo on startup

Discussion in 'Android Devices' started by shakim91, Mar 6, 2016.

  1. shakim91

    shakim91 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    Sep 10, 2015

    Sep 10, 2015
    10
    2
    16
    Hey Folks,
    I have learned a lot about F6 reading through these forums and had rooted and installed recovery following this guide: http://www.haganfox.net/Main/LGOptimusF6MS500. Few days ago I was repeatedly getting error that android.google.talk has stopped and android.system.ui has stopped(can't recall exact app names) . And finally it completely stopped booting up.

    I tried reviving it by restoring it using the same above guide and following guide lines here: http://androidcreations.weebly.com/unbrick-unroot-factory-restore-ms500.html. That didn't work so I tried restoring it using LG Mobile Support tool and following this steps: http://www.lg.com/us/support/product-help/CT10000027-1387479960570-software-updates. That also didn't help. I tried restoring from TWRP backup and also tried loading custom ROM using TWRP by following this steps: http://androidcreations.weebly.com/xperion-rom-f6-ms500.html. Nothing seems to help. Phone is still stuck on LG logo on start up.

    Here is what I see when I get into TWRP recovery using Volume down + Power and looking at the TWRP console:
    E:Unable to mount '/data'
    E:Unable to recreate /data/media folder .
    Updating Partition details...
    E:Unable to mount '/cache'
    E:Unable to mount '/data'
    E:Unable to mount '/system'
    E:Unable to mount internal storage.
    E:Unable to mount /data/media during GUI startup.
    E:Unable to mount '/cache'
    Running boot script...

    Finished running boot script.
    E:Unable to mount '/cache'
    E:Unable to mount /data/media/TWRP/.twrps when trying
    E:Failed to mount external storage. using internal sto......
    E:Unable to mount '/data'
    E:Unable to mount '/data'
    E:Unable to mount '/data'
    E:Unable to mount '/data'

    I have tried wipe and factory reset using TWRP but most of these fail with unable to mount errors. From reading online forums it looks like internal storage partitions are all messed up. Is there a way to recover from these issues? Is ADB the answer? If so, can someone point me to right direction please. I love this phone and would like to continue to use it if possible.

    Thanks a lot in advance.
    Shakim
     

    Advertisement

    #1 shakim91, Mar 6, 2016
    Last edited: Mar 6, 2016
  2. shakim91

    shakim91 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    Sep 10, 2015

    Sep 10, 2015
    10
    2
    16
    Bump! Anybody got any suggestions? If I can't fix today, I will have to buy a new phone tomorrow. Please help!
     
  3. EldonMcGuinness

    Rank:
    None
    Points:
    45
    Posts:
    6
    Joined:
    Sep 30, 2015

    Sep 30, 2015
    6
    0
    45
    Male
    Web Developer / Programmer / Writer
    I am having this exact same issue as of today. I was hoping I could restore the system using the KDZ file, but when I do I get the same errors as the guy that is posting here (KDZ WParam: 100 LParam: 64, WParam: 100 LParam: 0). I would love to be able to get this fixed.

    I previously been successful at reviving this phone using the boarddiag 3.99c app along with extracting the tot files from the KDZ file. I have also been able to flash the KDZ file directly to the device using the information and software from @GameTheory site. However, this time seems this is just not working.

    I am really at a loss at this point as I can get into download mode, but can not complete the KDZ flash. If I could get it into 9008 mode I would use boarddiag, but it is not there. I can also get into TWRP recovery, but as the OP mentioned I am not able to mount any partitions or get anywhere.

    Any Ideas?
     
    #3 EldonMcGuinness, Apr 6, 2016
    Last edited: Apr 6, 2016
  4. WarrantyVoider

    WarrantyVoider Android Enthusiast
    Rank:
    None
    Points:
    78
    Posts:
    352
    Joined:
    Aug 18, 2014

    Aug 18, 2014
    352
    243
    78
    I don't have any experience with this problem, so I'm just guessing here. If I'm guessing, I'd say it's some sort of hardware problem. More specifically, I'm guessing a cell or a region of the internal eMMC is having some problem. If so, I'd consider (sorry if I'm being too technical; I can elaborate if needed):
    1) First copy the entire content of the eMMC as an image. This should show whether the memory cells are all readable.
    2) For each valid partition, run fsck (usually just vfat and ext4 types) in read-only mode. This should check each file system.
    3) Check the image or files of each critical partition (boot, system, userdata, etc.) against a backup. This should check the integrity of the files necessary for booting.
    4) For a typically writable partition (userdata, cache, etc.), do a simple write test by creating and then verifying a new file. This should check whether the flash memory microcontroller is still allowing writes.

    My guess is some memory cells are worn out or are flaky so that either those cells are causing read errors or the microcontroller is making them read-only. Assuming that I'm right and that the boot partition is still writable, one possible solution to the problem is to run the OS from the SD card.

    Well, I don't know if this helps at all. Just throwing ideas out there. Good luck.
     
  5. EldonMcGuinness

    Rank:
    None
    Points:
    45
    Posts:
    6
    Joined:
    Sep 30, 2015

    Sep 30, 2015
    6
    0
    45
    Male
    Web Developer / Programmer / Writer
    I had left the phone without the battery for a few days and tried it today and was greated with the qdload 9008 driver, so I proceeded to try the boarddiag tool again. When it came to testing the MMC it failed, so it looks like this is just a case of a dead internal memory chip. I'm going to see if there is a way I can boot from sd as I would love to keep using the phone if I can. :D
     
  6. shakim91

    shakim91 Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    10
    Joined:
    Sep 10, 2015

    Sep 10, 2015
    10
    2
    16
    I ended up buying a new phone but I would love to bring my optimus F6 back to life if possible. Were you able to boot from the sd card? Did it work for you? If so, would you please share how to do so and any other instructions you can provide. Thanks in advance!!
     

Share This Page

Loading...