Oct 31, 2010
Ok, I've been having battery drain problems ever since i purchased my phone through ebay( from the US because I live in Europe). The phone is a quad band world phone so I can get 3g etc perfectly here.

The problem is that my battery drains far too fast when in standby mode (cell standby takes up too much battery) and today I think i found the solution.

After reading countless threads and articles I dialed *#*#4636*#*#, went into Phone Information to see which preferred network type it was set too.

I asked around some friends first who live in my area with android phones and theirs is all set to WCDMA PREFERRED (htc hero, htc desire and motorola milestone) and my moto charm is set to GSM auto (PRL).

Ive tried countless times to change my pref. network type to wcdma preffered but failed, then i tried changing it to CDMA auto (prl) and exited and reentered the screen and finally it said WCDMA preferred.

Used it for couple of hours and my battery app and I saw that the battery was atleast 1.5 times better than it previously was.
Then the phone automaticly rebooted and the change I made was gone again and reverted back to gsm auto (prl), this happened twice.

It seems it wont stick while it should, does anyone one a workaround to get it to stick to wcdma pref?

I also didnt put this in the charm forum because i dont think this is a charm issue and almost nobody is active in that forum to answer my question.
  • Like
Reactions: crocodoyle
Leaving it on WCDMA only saves a little battery, if it's set to auto then it'll switch back and forth when searching for the strongest signal which does drain your battery. You could always use APNoid or juicedefender to disable data when you don't want to use it, and couple it with a timer or locale app.

Charm's battery is one of the worst I've experienced.