1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Recovery] Unofficial CWM - 6.0.5.0 - peregrine

Discussion in 'Android Devices' started by Shabbypenguin, Jul 16, 2014.

  1. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    Shabbypenguin and the OUDHS
    presents to you

    ClockWorkMod Recovery 6.0.5.0
    for your Moto G LTE

    You need to be unlocked to use this i suggest following this guide :)

    CWM-6.0.5.0 https://mega.co.nz/#!sdRBTKQZ!Km20ItpCMi34ph6X6yS98_JOtMTANNinAC_dihtyoSY

    Code (Text):
    1. fastboot flash recovery CWM-6.0.5.0-peregrine.img
    -----------------------------------------------------------------------------------------------------------------
    Congrats you now have CWM now if you wish to root youll need to follow these instructions :)
    -----------------------------------------------------------------------------------------------------------------


    SuperSU


    Directions:

    1) Download the above file
    2) Connect your phone and copy them to your phone or your sdcard
    3) Once they are copied power down your device
    4) Hold volume up, down and power to enter Clockworkmod recovery
    5) Navigate recovery by using the volume keys and power to select
    6) Choose install zip from sdcard, then pick internal or external (where you copied it to)
    7) Scroll down to the SuperSU.zip and select it to install

    -----------------------------------------------------------------------------------------------------------------
    Congrats you are rooted! this procedure will work on any firmware update you guys get :)
    -----------------------------------------------------------------------------------------------------------------


    Bugs:

    Credits:
    eteles - testing
    suhridkhan - testing
    dhacker - for all the heavy lifting on previous moto devices.


     


    cubone, mitja_i, somcom3x and 12 others like this.

    1. Download the Forums for Android™ app!


      Download

       
  2. consystor

    consystor Lurker

    Hi!

    I could fastboot boot your CWM image and create a backup of my original firmware on my SD-card (Transcend 32GB class10) without any problems and in a surprising fast time.

    So, yesterday I've bought my phone and todays it's the first time, I use CWM or a recovery image and I'm very happy that it worked.
    It's because you've done a very good job and just in time!

    Maybe tomorrow I'll test your alpha/beta CM image just for fun... :)
    Thanks again!
     
    Shabbypenguin likes this.
  3. pharm

    pharm Lurker

    ShabbyPenguin, I can't install this recovery on my X1039 - fastboot installl recovery.img reports a size mismatch on the phone. I can boot it over USB just fine & everything seems to work OK, I just can't install it.

    Is this expected, or do we need slightly different recoveries for the different Moto G 4G models?

    (Going to try your CM build as soon as a backup has run on the phone.)
     
  4. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    that error means that the partition you flashed is a different size than stock, its actually flashed on there jsut fine.
     
  5. pharm

    pharm Lurker

    Oh, OK. It's just the phone being unclear then...cheers.
     
  6. LarvasFaint

    LarvasFaint Lurker

    target reported max download size of 536870912 bytes
    error: cannot load 'CWM-6.0.5.0-peregrine.img': No error
    XT1039 device.. and yes i unlocked bootloader.
     
  7. LarvasFaint

    LarvasFaint Lurker

    How can i fix this error?
     
  8. LarvasFaint

    LarvasFaint Lurker

    NVM.. Got it fixed
     
  9. chand690

    chand690 Newbie

    please help i have moto g lte xt1040 i want recovery
    i already unlock the bootloader but next step to install recovery so confused which recovery is good which one working need help
     
  10. chand690

    chand690 Newbie

    i try do ur recovery with adb and it says mismatched partition size recovery
     
  11. Shabbypenguin

    Shabbypenguin Extreme Android User
    Thread Starter

    that is a normal message
     
  12. chand690

    chand690 Newbie

    ok u mean its norml massage means my cmw recovery successfully done but when i power and volume down press i cant see cwm recovery its original option come as before recovery
    which way i can open cwm recovery thanks
     
  13. chand690

    chand690 Newbie

    Thanks i got it
     
  14. chand690

    chand690 Newbie

    please help ,y phone stuck at motorola boot log
     
  15. chand690

    chand690 Newbie

    cwm recovery come but after reboot stuck at motorola logo
     
  16. Ninnetyer

    Ninnetyer Lurker

    Hi I have a question, after flash the custom recovery I got the missmatch message. And since you guys said that its normal, I went to the recovery screen but, nothing shows up, it just shows the white screen that recovery screen has been unlocked, and then it just start the normal boot, but nothing with the custom recovery i've just flashed.

    Can anyone point to a solution?, I will really apreciate it, thanks in advance.
     
  17. Ninnetyer

    Ninnetyer Lurker

    nevermind just figure it out, you just have to press volumen up button to select instead of the power buttom, Duh for me lmao!
     
  18. kyuchukovv

    kyuchukovv Lurker

    When a install CWM and try to start 'recovery' with volume up it gives me an error dead android and says "missing command" or "No command."
     
  19. thatsimplekid

    thatsimplekid Lurker

    Having slight issues at the moment... I've installed this recovery before on a different moto g LTE phone and it has worked fine, but on my current device I'm having issues...
    When i use "fastboot boot CWM-6.0.5.0-peregrine.img" it will boot and stay loaded for ~5 seconds and then crash to a blank screen...
    Any ideas?
     
  20. scontrerasmer

    scontrerasmer Lurker

    I get this error
    " Fastboot: can't load "CWM_FILENAME.IMG"

    Edit: I've figured it out on my own (had to set the prompt in the directory where the recovery image was , yeah, how dumb) , but every time i try to back up the stock ROM i get an error after attempting to make a back up image of /data
     
    #20 scontrerasmer, Jan 20, 2015
    Last edited: Jan 25, 2015
  21. Is this method for unlocking bootloader and rooting still valid? I've read on other android forum that as of Dec 2014 since AT&T bought Cricket that AT&T locked the bootloader without a current method to unlock it.

    True or no?

    I'll answer my question. Phone does appeared to be locked and using this method to unlock bootloader doesn't work anymore. On the step to request code from motorola website, it replied your device does not qualify for unlocking.
     
    #21 trying916things, Feb 19, 2015
    Last edited: Feb 22, 2015
  22. zecchetti

    zecchetti Lurker

    Hello!

    I am really struggling. I have unlocked bootloader and when I try the clockword recovery, it comes up with a symbol of the green android robot lying down with its front door open BUT it has a red triangle with an exclamation mark on it. Then after a while it just reboots my phone as normal. What am I doing wrong? I have tried putting the image file in my internal storage as well as sd card but same problem happens.
     
  23. scontrerasmer

    scontrerasmer Lurker

    Hey!, unlocking the bootloader is the first step,but it seem that you haven't actually installed CWM. To install CMW make sure to have:
    1) the apropiate drivers for your device on your PC, you can get them from Motorola's wbsite
    2) Working ADB and Fastboot
    3) ADB should run fine regardless of the directory on your command line

    Now, connect and autorize the ADB. browse from your Command line to the directory in which tou have downloaded the IMG file (i'll assume that you know how to do so, if not, Google is your allie) Then type into the command line this:
    " adb reboot bootloader " (your device should reboot to fastboot)
    then type " fastboot devices " to make sure that fastboot can talk to your device
    then it's time to really flash CWM, type " fastboot flash recovery CWM-6.0.5.0-peregrine.img ", wait until it's done, it may give a nismatch partition size, but it's normal
    now you have really installed CWM
     
Loading...
Similar Threads - Recovery Unofficial CWM
  1. borhieda
    Replies:
    8
    Views:
    213
  2. Ronald J
    Replies:
    6
    Views:
    459
  3. quddy
    Replies:
    27
    Views:
    827
  4. SYOB SYOT
    Replies:
    13
    Views:
    892
  5. Hillary kipkirui
    Replies:
    3
    Views:
    365
  6. kumaranil13k
    Replies:
    0
    Views:
    1,115
  7. 69Rixter
    Replies:
    21
    Views:
    1,806
  8. kumaranil13k
    Replies:
    0
    Views:
    815
  9. Alexenferman
    Replies:
    0
    Views:
    1,410
  10. electimon
    Replies:
    6
    Views:
    5,852

Share This Page

Loading...