1. Are you ready for the Galaxy S20? Here is everything we know so far!

Redmi 7a Not Working

Discussion in 'Android Help' started by Redmi7aUK, May 30, 2020.

  1. Redmi7aUK

    Redmi7aUK Lurker
    Thread Starter

    Hi. In the UK, I bought a Redmi 7a last autumn. It'll still be under warranty if the problem is something I can take to them. I don't use it that much; the only apps I've installed are Firefox and BT Wi-Fi (from my ISP). Twice now I've had the same problem, maybe a couple of months apart. The last time I fixed it by resetting the phone, but obviously I want to avoid doing that over and over. The issue is: the alarm doesn't work in the morning, I unlock and look at the phone and the whole screen is flashing, I reboot and get a home screen with a big square area at the top saying "Loading" (see screenshot). I've tried the built in "find and fix issues" app, clearing cache, searching for viruses. Help appreciated.
     

    Attached Files:




    1. Download the Forums for Android™ app!


      Download

       
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    what app is the widget associated with? have you tried clearing cache just for that app? maybe try uninstalling and re-installing the app.
     
    MrJavi likes this.
  3. Redmi7aUK

    Redmi7aUK Lurker
    Thread Starter

    If I tap where it says Loading, the clock app comes up, so it's that that can't load. I did try clearing all data for the clock app. No change. How do I uninstall system apps like this? There's no option to uninstall under Manage Apps. And how do I reinstall later? I'm not sure if this is a standard Google clock or a Xiaomi thing. There are various things in the app store called clock, but not this, as far as I can see. Will the system updater just pick up that this is missing, if it is?
     
    #3 Redmi7aUK, May 30, 2020
    Last edited: May 30, 2020
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    what is on your screen shot is called a widget and is usually associated with an app. if you hold on the widget i would try and remove the widget and then re-add it back. you do know what widget it is, correct? do you have a custom launcher?

    for instance on my phone:
    [​IMG]
    that widget is from 1weather and its a clock but also it will launch the 1weather app for a more detailed weather analysis. now if the same is happening on my phone, i would not look into the clock, but the 1weather widget and app and see if they are the cause of your issue.
     
  5. Redmi7aUK

    Redmi7aUK Lurker
    Thread Starter

    Thank you very much. You have solved my problem. I didn't think to kill the widget as distinct from the app. I have done this and everything seems back to normal. Hopefully the problem won't recur.
     
    Dannydet and ocnbrze like this.
Loading...

Share This Page

Loading...