1. Download our Official Android App: Forums for Android!

Support RUU error 190 [need help]

Discussion in 'Android Devices' started by Aprhys, May 9, 2012.

  1. Aprhys

    Aprhys Lurker
    Thread Starter
    May 9, 2012

    I am trying to root my HTC hero (HERO13000, TELUS WWE, 3.36.661.2) and whenever I run my RUU I keep getting ERROR [190]: ROM IS NOT UPDATED, and tells me to upgrade to my CURRANT software (3.36.661.2). I am really not sure what to do here. I believe I am doing everything correct and can't find one problem with what I am doing. Please help?

    EDIT: I forgot to mention, I have tried skipping this step, but that doesn't seem to work either, perhaps I am just not doing the next step right? Will keep posted.

    EDIT2:(more info)
    More info about my phone I would think relative:
    HBOOT-1.76.0007 (HERO13000)
    Firmware version: 2.1-update1
    Software number: 3.36.661.2
    (more info upon request and explanation of relevance)

    I think I will just system reset and start from there...


  2. tofumaster

    tofumaster Lurker
    May 4, 2014

    I had the same problem and couldn't find the answer, but kept finding this question posted on many spammy sites that link back to androidforums.com...

    Anyhow... what I did was this:

    (can't post links yet, so use your imagination... =))

    This is a summary, so you should read the original thread if you have problems.

    Getting the ROM:
    1. Ran HERO10000_Hero_hboot_1.76.0013_R.exe
    2. Click "I understand" / next.
    3. Click "I completed the steps indicated above." / next.
    4. (I also clicked Update, but I don't think it's necessary according to the link above.)
    5. Find rom.zip in a temp folder. In my case it was C:/Users/Me/AppData/Local/Temp/{guid1}/{guid2} --> but fast way is to sort folders by date and look in the newest one.
    6. Copy rom.zip for later user.
    7. Kill the RUU updater (HERO100...*.exe).
    Also it may be that htcdev has the wrong ruu updater linked? Not sure, didn't check them all at htcdev, because the Telus HTC Hero is a HERO13000... (see filename).

    Updating the RUU:
    1. If you haven't already, turn on USB debugging (on phone: settings -> applications -> developer options).
    2. In your android-sdk platform-tools folder (or wherever adb now currently resides in the future)...
    3. adb devices
      (make sure that it's listed)
    4. adb reboot bootloader
      (check to see that it's a white screen/fastboot screen.)
    5. fastboot devices
      (make sure you can still see your device)
    6. Note: fastboot erase cache does not work. Probably because the bootloader is still locked.
    7. fastboot oem rebootRUU
      (Puts it into another white screen that has orange "RUU USB" text somewhere -- if my memory serves me right.)
    8. fastboot flash zip path/to/rom.zip
      (Wait until this succeeds...)
    9. fastboot reboot-bootloader
      (Takes you back to main fastboot screen, but now mine has a white text with magenta background at the top that says: "** LOCKED (00W) ***". It's also now on HBOOT-1.76.0013 (HERO13000).)
    10. Note: fastboot reboot didn't seem to work. Instead I pressed the hardware menu button to reboot the device (it's an option on the fastboot menu).

    If you don't want to bother w/ that, I stuffed roms.zip in an Amazon S3 bucket somewhere...

    MD5: 51e29986f317d9826a784a2c38a4a456

    I'm assuming this unblocks the RUU issue, but I wanted to post this before moving on (I'm also running out of the allocated time today to play w/ this and wanted to record this before I forget). If I run into any other problems later, I'll reply here or update this post.
  3. tofumaster

    tofumaster Lurker
    May 4, 2014

    Just thought I've give a quick update.

    I was using the HTC Easy Unlock Bootloader Tool from:
    [TOOL] HTC Easy Unlock Bootloader Tool - xda-developers

    It basically downloads the right tool from http://www.htcdev.com/bootloader/ruu-downloads (you may have to be logged into htcdev to see that link...) and executes it.

    Of course that didn't work for me (as you know).

    Anyhow, after all those steps above, it will extract the Device Identifier Token for you where you will copy it into: http://www.htcdev.com/bootloader/unlock-instructions/page-2 and then wait for your email w/ the unlock file.

    Anyhow, after following all that and rebooting back into fastboot/bootloader, I now see *** UNLOCKED *** at the top (instead of *** LOCKED (00W) ***), so I'm pretty sure unlocking is a success. :smokingsomb:

Share This Page